Updating math/p5-Math-Pari from 2.010806.03 to 2.010806.04
pkgsrc changes: - Adjust patch which allows to use math/pari Upstream changes: 2.01080604 Add (missing in 2.1.*) declaration for pari_init(). Minor miscount in docs. Math::PariBuild: detecting `patch --binary' missed -p1; same for inc_h.diff Work around bug in XSUB.h (at least up to 5.11.2) with puts. Get GPDATADIR from gp, if present. Make self-documentation for switching to 2.3.* more explicit. kmx patch for mingw 32-bit Win-build: include windows.h (early!) in Pari.xs and highlvl.c enable assembler for this build x86_64 assembler detection after 2.2.7; thanks to Alexander Haeckel
This commit is contained in:
parent
c6cc3dba5e
commit
31c67f0944
3 changed files with 36 additions and 38 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.37 2010/02/12 18:19:40 sno Exp $
|
||||
# $NetBSD: Makefile,v 1.38 2010/03/10 09:24:52 sno Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Math-Pari-2.01080603
|
||||
PKGNAME= p5-${DISTNAME:S/01080603/010806.03/}
|
||||
PKGREVISION= 1
|
||||
DISTNAME= Math-Pari-2.01080604
|
||||
PKGNAME= p5-${DISTNAME:S/01080604/010806.04/}
|
||||
#PKGREVISION= 1
|
||||
SVR4_PKGNAME= p5mpa
|
||||
CATEGORIES+= perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Math/}
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.16 2010/02/06 10:52:37 sno Exp $
|
||||
$NetBSD: distinfo,v 1.17 2010/03/10 09:24:52 sno Exp $
|
||||
|
||||
SHA1 (Math-Pari-2.01080603.tar.gz) = f8d8a85428886cd682c7672740421d6803dea0fa
|
||||
RMD160 (Math-Pari-2.01080603.tar.gz) = 93641a51a2dd1a2f0d9af691da28e7579511bb3b
|
||||
Size (Math-Pari-2.01080603.tar.gz) = 121370 bytes
|
||||
SHA1 (patch-aa) = c1b4540c29699d99f8f21fcda84a790c1b84bc95
|
||||
SHA1 (Math-Pari-2.01080604.tar.gz) = 547474a4ba2c2bb0ca89d34e85ad1e58f2b64873
|
||||
RMD160 (Math-Pari-2.01080604.tar.gz) = 05a9ea99adf21a1011c37d0fd4e5caa58b981150
|
||||
Size (Math-Pari-2.01080604.tar.gz) = 122339 bytes
|
||||
SHA1 (patch-aa) = 3a145ca9bd4bbcbae910a85dd38d985c69b89b17
|
||||
SHA1 (patch-ab) = b1e66e636eb823b45dd0c53ab0fa0bdf6472cfff
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.4 2010/02/06 10:52:37 sno Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2010/03/10 09:24:52 sno Exp $
|
||||
|
||||
--- Makefile.PL.orig 2009-12-11 01:28:42.000000000 +0000
|
||||
--- Makefile.PL.orig 2010-03-03 21:26:10.000000000 +0000
|
||||
+++ Makefile.PL
|
||||
@@ -2,9 +2,6 @@
|
||||
use ExtUtils::MakeMaker;
|
||||
|
@ -12,7 +12,7 @@ $NetBSD: patch-aa,v 1.4 2010/02/06 10:52:37 sno Exp $
|
|||
# Uncomment and change this line if I fail to find it
|
||||
# $paridir = "..";
|
||||
|
||||
@@ -16,208 +13,54 @@ unless (-t STDOUT) { # Better reports i
|
||||
@@ -16,137 +13,16 @@ unless (-t STDOUT) { # Better reports i
|
||||
select $odef;
|
||||
}
|
||||
|
||||
|
@ -81,6 +81,13 @@ $NetBSD: patch-aa,v 1.4 2010/02/06 10:52:37 sno Exp $
|
|||
- ### words, updating to 2.3.* might allow your use of fast processor-specific
|
||||
- ### assembler code.)
|
||||
-
|
||||
- ### Switching to 2.3.* should be as simple as giving Makefile.PL an option
|
||||
- ### version23_ok=1
|
||||
- ### (if you or Makefile.PL already downloaded-and-extracted version-2.1.*
|
||||
- ### distribution, give an extra option, force_download).
|
||||
- ### Alternatively, give option
|
||||
- ### paridir=DIRECTORY-of-extracted-distribution
|
||||
-
|
||||
- ### However, keep in mind: v.2.3.* supports only plotting to PostScript.
|
||||
-
|
||||
-EOP
|
||||
|
@ -88,15 +95,9 @@ $NetBSD: patch-aa,v 1.4 2010/02/06 10:52:37 sno Exp $
|
|||
- $common::main_paridir = $paridir;
|
||||
- *MY::postamble = \&xMY::postamble;
|
||||
-}
|
||||
+my $pariprefix;
|
||||
+my $addlibs;
|
||||
+my $libpari = "pari";
|
||||
|
||||
-
|
||||
-$os = $Config{osname};
|
||||
+grep {/^pariprefix=(.*)$/i and $pariprefix = $1} @ARGV;
|
||||
+grep {/^addlibs=(.*)$/i and $addlibs = $1} @ARGV;
|
||||
+grep {/^libpari=(.*)$/i and $libpari = $1} @ARGV;
|
||||
|
||||
-
|
||||
-$define .= " -DPARI_VERSION_EXP=$pari_version -DDEBUG_PARI";
|
||||
-$define .= " -DUSE_SLOW_ARRAY_ACCESS -DUSE_SLOW_NARGS_ACCESS" if $] >= 5.009;
|
||||
-$libs = "-lm";
|
||||
|
@ -123,7 +124,14 @@ $NetBSD: patch-aa,v 1.4 2010/02/06 10:52:37 sno Exp $
|
|||
-} elsif ($os eq 'linux') {
|
||||
- $noexp2 = 1;
|
||||
-}
|
||||
-
|
||||
+my $pariprefix;
|
||||
+my $addlibs;
|
||||
+my $libpari = "pari";
|
||||
+
|
||||
+grep {/^pariprefix=(.*)$/i and $pariprefix = $1} @ARGV;
|
||||
+grep {/^addlibs=(.*)$/i and $addlibs = $1} @ARGV;
|
||||
+grep {/^libpari=(.*)$/i and $libpari = $1} @ARGV;
|
||||
|
||||
-my %opts;
|
||||
-unless ($common::parilib) {
|
||||
- build_tests $paridir; # Convert the test suite
|
||||
|
@ -147,26 +155,16 @@ $NetBSD: patch-aa,v 1.4 2010/02/06 10:52:37 sno Exp $
|
|||
- }
|
||||
-}
|
||||
+@ARGV = grep !/^((pariprefix|addlibs|libpari)=.*)$/i, @ARGV;
|
||||
|
||||
-# We want to find the offset of the least significant byte
|
||||
-# of SV.flags inside an SV.
|
||||
-# It is enough to find the offset of the least significant byte inside a U32.
|
||||
-# (Needed for recognizing Perl code supplied to lisseq and lisexpr.)
|
||||
+my $define = "-DPARI_VERSION_EXP=" . get_pari_formatted_version();
|
||||
|
||||
$offset = index($Config{byteorder}, "1");
|
||||
$offset = 3 if $offset > 3; # SvFLAGS is actually I32
|
||||
$define .= " -DLSB_in_U32=$offset";
|
||||
# We want to find the offset of the least significant byte
|
||||
# of SV.flags inside an SV.
|
||||
@@ -164,67 +40,40 @@ my $perl_int_size = $Config{'ivsize'} ||
|
||||
$define .= ' -DLONG_SHORTER_THAN_IV' if $perl_int_size > $longsize;
|
||||
|
||||
-my $longsize = length(eval { pack 'l!', 1 } or pack 'l', 1);
|
||||
-my $perl_int_size = $Config{'ivsize'} || $Config{'intsize'}
|
||||
- or die "Can't deduce Perl int size";
|
||||
-
|
||||
-$define .= ' -DLONG_SHORTER_THAN_IV' if $perl_int_size > $longsize;
|
||||
-
|
||||
-$define .= ' -Derr=pari_err'; # On linux it can get a wrong dynamic loading
|
||||
$define .= ' -Derr=pari_err'; # On linux it can get a wrong dynamic loading
|
||||
-$define .= ' -DHAVE_LADD' if $opts{have_ladd};
|
||||
-$define .= ' -DGCC_INLINE' if $Config{gccversion} and not $Config{optimize} =~ /-g\b/;
|
||||
$define .= ' -DGCC_INLINE' if $Config{gccversion} and not $Config{optimize} =~ /-g\b/;
|
||||
-$define .= ' -DHAVE_PARIPRIV' if -f "$paridir/src/headers/paripriv.h";
|
||||
-#$define .= ' -DNO_GRAPHICS_PARI' unless -f "$paridir/src/graph/plotgnuplot.c";
|
||||
-
|
||||
|
@ -177,7 +175,7 @@ $NetBSD: patch-aa,v 1.4 2010/02/06 10:52:37 sno Exp $
|
|||
-
|
||||
-# This is done in Makefile in GP/PARI, and in paricfg.h without do_configure
|
||||
-$define .= ' -DDL_DFLT_NAME=NULL' if $common::do_configure;
|
||||
-
|
||||
|
||||
-my $extra_inc = extra_includes($paridir);
|
||||
+$define .= " -DNO_HIGHLEVEL_PARI";
|
||||
|
||||
|
|
Loading…
Reference in a new issue