catch up with py-imaging - use distutils and don't depend strictly
on Python-2.0 anymore
This commit is contained in:
parent
3f3f5d5c6d
commit
31e625bc2f
5 changed files with 91 additions and 47 deletions
|
@ -1,38 +1,37 @@
|
|||
# $NetBSD: Makefile,v 1.9 2003/07/17 21:42:34 grant Exp $
|
||||
# $NetBSD: Makefile,v 1.10 2003/08/18 10:15:39 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Imaging-1.1.3
|
||||
PKGNAME= py20-imagingtk-1.1.3
|
||||
DISTNAME= Imaging-1.1.4
|
||||
PKGNAME= ${PYPKGPREFIX}-imagingtk-1.1.4
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.pythonware.com/downloads/
|
||||
MASTER_SITES= http://effbot.org/downloads/
|
||||
|
||||
MAINTAINER= tech-pkg@NetBSD.org
|
||||
HOMEPAGE= http://www.pythonware.com/products/pil/
|
||||
COMMENT= Tk support for the Python Imaging Library (PIL)
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 20 # XXX for now until some things are cleaned up
|
||||
BUILDLINK_DEPENDS.python20= python20>=2.0.1nb1
|
||||
|
||||
DIST_SUBDIR= python
|
||||
ALL_TARGET= sharedmods
|
||||
PYDISTUTILSPKG= yes
|
||||
BUILDLINK_DEPENDS.python20= python20>=2.0.1nb4
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BUILDLINK2= yes
|
||||
USE_X11= yes
|
||||
|
||||
do-configure:
|
||||
(cd ${WRKSRC}/libImaging; CC="cc -fPIC" LIBS="${LDFLAGS}" ./configure)
|
||||
${CHMOD} +w ${WRKSRC}/Setup.in ${WRKSRC}/Makefile.pre.in
|
||||
${SED} -e 's,@PREFIX@,${PREFIX},g' -e 's,@X11BASE@,${X11BASE},g' \
|
||||
${FILESDIR}/Setup.in >${WRKSRC}/Setup.in
|
||||
${CP} ${LOCALBASE}/${PYLIB}/config/Makefile.pre.in ${WRKSRC}
|
||||
(cd ${WRKSRC}; ${MAKE} -f Makefile.pre.in boot)
|
||||
PLIST_SUBST+= PYPKGPREFIX=${PYPKGPREFIX}
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/_imagingtk.so \
|
||||
${PREFIX}/lib/python2.0/site-packages/PIL
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/py20-imaging
|
||||
do-configure:
|
||||
(cd ${WRKSRC}/libImaging && ${SETENV} ${CONFIGURE_ENV} ./configure \
|
||||
${CONFIGURE_ARGS} && ${SETENV} ${MAKE_ENV} ${MAKE})
|
||||
${SED} "s|@JPEGDIR@|${BUILDLINK_PREFIX.jpeg}|g" <${WRKSRC}/setup.py \
|
||||
>${WRKSRC}/setup.py.tmp && ${MV} -f ${WRKSRC}/setup.py.tmp \
|
||||
${WRKSRC}/setup.py
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/${PYPKGPREFIX}-imaging
|
||||
(cd ${WRKSRC}/Scripts; \
|
||||
${INSTALL_DATA} enhancer.py painter.py player.py \
|
||||
thresholder.py viewer.py ${PREFIX}/share/examples/py20-imaging )
|
||||
thresholder.py viewer.py \
|
||||
${PREFIX}/share/examples/${PYPKGPREFIX}-imaging )
|
||||
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../graphics/py-imaging/buildlink2.mk"
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2002/01/22 18:12:12 drochner Exp $
|
||||
lib/python2.0/site-packages/PIL/_imagingtk.so
|
||||
share/examples/py20-imaging/enhancer.py
|
||||
share/examples/py20-imaging/painter.py
|
||||
share/examples/py20-imaging/player.py
|
||||
share/examples/py20-imaging/thresholder.py
|
||||
share/examples/py20-imaging/viewer.py
|
||||
@comment share/examples/py-imaging and lib/python2.0/site-packages/PIL
|
||||
@comment belong to py-imaging, do not remove them here.
|
||||
@comment $NetBSD: PLIST,v 1.3 2003/08/18 10:15:39 drochner Exp $
|
||||
${PYSITELIB}/PIL/_imagingtk.so
|
||||
share/examples/${PYPKGPREFIX}-imaging/enhancer.py
|
||||
share/examples/${PYPKGPREFIX}-imaging/painter.py
|
||||
share/examples/${PYPKGPREFIX}-imaging/player.py
|
||||
share/examples/${PYPKGPREFIX}-imaging/thresholder.py
|
||||
share/examples/${PYPKGPREFIX}-imaging/viewer.py
|
||||
@dirrm share/examples/${PYPKGPREFIX}-imaging
|
||||
@comment ${PYSITELIB}/PIL
|
||||
@comment belongs to py-imaging, do not remove it here.
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.4 2002/10/24 19:32:22 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.5 2003/08/18 10:15:40 drochner Exp $
|
||||
|
||||
SHA1 (python/Imaging-1.1.3.tar.gz) = a926c722f26f2b19cd2eaf052fc5db1940d68e4b
|
||||
Size (python/Imaging-1.1.3.tar.gz) = 346194 bytes
|
||||
SHA1 (python/Imaging-1.1.4.tar.gz) = 611972b63272bf4967ca966848ba8ddda970abcc
|
||||
Size (python/Imaging-1.1.4.tar.gz) = 416338 bytes
|
||||
SHA1 (patch-aa) = fbaf2e06237535ec52094bf6eb43e6a471f3966a
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
# $NetBSD: Setup.in,v 1.1.1.1 2001/03/20 16:47:09 wiz Exp $
|
||||
#
|
||||
|
||||
*shared*
|
||||
|
||||
# --------------------------------------------------------------------
|
||||
# Tkinter bindings. Comment away if you don't need ImageTk, or if
|
||||
# you're using a custom _tkinter instead (like in earlier versions of
|
||||
# PIL). Edit the library specifications to match your configuration.
|
||||
|
||||
_imagingtk _imagingtk.c \
|
||||
-IlibImaging Tk/tkImaging.c \
|
||||
-I@PREFIX@/include \
|
||||
-L@PREFIX@/lib -R@PREFIX@/lib -ltcl83 -ltk83 \
|
||||
-I@X11BASE@/include -L@X11BASE@/lib -lX11
|
58
graphics/py-imagingtk/patches/patch-aa
Normal file
58
graphics/py-imagingtk/patches/patch-aa
Normal file
|
@ -0,0 +1,58 @@
|
|||
$NetBSD: patch-aa,v 1.1 2003/08/18 10:15:43 drochner Exp $
|
||||
|
||||
--- setup.py.orig Fri May 9 14:00:56 2003
|
||||
+++ setup.py Sun Aug 17 00:55:09 2003
|
||||
@@ -85,16 +85,16 @@
|
||||
# standard windows libraries
|
||||
LIBRARIES.extend(["kernel32", "user32", "gdi32"])
|
||||
|
||||
-MODULES.append(
|
||||
- Extension(
|
||||
- "_imaging",
|
||||
- ["_imaging.c", "decode.c", "encode.c", "map.c", "display.c",
|
||||
- "outline.c", "path.c"],
|
||||
- include_dirs=INCLUDE_DIRS,
|
||||
- library_dirs=LIBRARY_DIRS,
|
||||
- libraries=LIBRARIES
|
||||
- )
|
||||
- )
|
||||
+#MODULES.append(
|
||||
+# Extension(
|
||||
+# "_imaging",
|
||||
+# ["_imaging.c", "decode.c", "encode.c", "map.c", "display.c",
|
||||
+# "outline.c", "path.c"],
|
||||
+# include_dirs=INCLUDE_DIRS,
|
||||
+# library_dirs=LIBRARY_DIRS,
|
||||
+# libraries=LIBRARIES
|
||||
+# )
|
||||
+# )
|
||||
|
||||
# security check
|
||||
|
||||
@@ -121,7 +121,7 @@
|
||||
|
||||
try:
|
||||
import _tkinter
|
||||
- TCL_VERSION = _tkinter.TCL_VERSION[:3]
|
||||
+ TCL_VERSION = ''.join(_tkinter.TCL_VERSION[:3].split('.'))
|
||||
except (ImportError, AttributeError):
|
||||
pass
|
||||
else:
|
||||
@@ -206,7 +206,7 @@
|
||||
|
||||
if not tk_framework_found:
|
||||
# assume the libraries are installed in the default location
|
||||
- LIBRARIES.extend(["tk" + TCL_VERSION, "tcl" + TCL_VERSION])
|
||||
+ LIBRARIES.extend(["tk" + TCL_VERSION, "tcl" + TCL_VERSION, "X11"])
|
||||
HAVE_TCLTK = 1
|
||||
|
||||
if HAVE_TCLTK:
|
||||
@@ -300,7 +300,7 @@
|
||||
author_email=AUTHOR[1],
|
||||
description=DESCRIPTION,
|
||||
url=HOMEPAGE,
|
||||
- packages=[""],
|
||||
+# packages=[""],
|
||||
extra_path = "PIL",
|
||||
package_dir={"": "PIL"},
|
||||
ext_modules = MODULES,
|
Loading…
Reference in a new issue