CVE-2008-2939

bump PKGREVISION
This commit is contained in:
kefren 2008-08-09 20:33:37 +00:00
parent 94a3b96e82
commit 320bf7f57f
3 changed files with 15 additions and 3 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.125 2008/07/10 15:18:23 joerg Exp $
# $NetBSD: Makefile,v 1.126 2008/08/09 20:33:37 kefren Exp $
.include "Makefile.common"
PKGNAME= apache-${APACHE_VERSION}
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= www
HOMEPAGE= http://httpd.apache.org/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.53 2008/06/20 13:28:08 he Exp $
$NetBSD: distinfo,v 1.54 2008/08/09 20:33:38 kefren Exp $
SHA1 (httpd-2.0.63.tar.bz2) = 20e2b64944e38e96491af788a37cb709d2c5b755
RMD160 (httpd-2.0.63.tar.bz2) = f6a7de59860f627ac40b245fcf742fb07e1b4870
@ -14,3 +14,4 @@ SHA1 (patch-al) = 9af7b6c56177d971e135f0a00b3ab9ded5d1b6dd
SHA1 (patch-am) = ab4a2f7e5a1a3064e908b61157e7fd349c0b0c08
SHA1 (patch-ao) = c629a7563d0e555922526e26b266251144a14ff6
SHA1 (patch-ap) = 260b9c88bbcb238a81319ff5bef523ec6d765a27
SHA1 (patch-aq) = ef712b4f0573bb59185eba4143db6917daa7c8bc

View file

@ -0,0 +1,11 @@
$NetBSD: patch-aq,v 1.5 2008/08/09 20:33:38 kefren Exp $
--- modules/proxy/proxy_ftp.c.orig 2008-08-09 23:27:01.000000000 +0300
+++ modules/proxy/proxy_ftp.c 2008-08-09 23:27:30.000000000 +0300
@@ -382,6 +382,7 @@
c->bucket_alloc));
}
if (wildcard != NULL) {
+ wildcard = ap_escape_html(p, wildcard);
APR_BRIGADE_INSERT_TAIL(out, apr_bucket_pool_create(wildcard,
strlen(wildcard), p,
c->bucket_alloc));