make this build with newer NetBSD (where fmin()/fmax() is supported):
get static inline replacements out of the namespace
This commit is contained in:
parent
4c51ebb4c8
commit
322289ceeb
3 changed files with 15 additions and 11 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.6 2010/10/08 05:28:55 obache Exp $
|
||||
$NetBSD: distinfo,v 1.7 2010/10/22 17:55:28 drochner Exp $
|
||||
|
||||
SHA1 (metisse-0.4.1.tar.bz2) = acf97b125905d91988955560a9b14b06a530eed6
|
||||
RMD160 (metisse-0.4.1.tar.bz2) = 7487322f22a3655d756b5d3d3cc59afbf277d137
|
||||
|
@ -7,7 +7,7 @@ SHA1 (patch-aa) = 4dc24324dfaa54f5fbd0b6732707245c79047c6c
|
|||
SHA1 (patch-ab) = 8fa77eaed337a617b8f14d75de0d92b0dc1529df
|
||||
SHA1 (patch-ac) = 2ed1d666d535ee2003cb3d11e58188ff9cff7de9
|
||||
SHA1 (patch-ad) = 1a3fc39d5ce20be56b0331b6f426ab3a78a742fb
|
||||
SHA1 (patch-ae) = eab55e17f7e3518434d4ad42e7637c18cef5bf72
|
||||
SHA1 (patch-ae) = 3e938fd03995b6990768067de02ab6bd661ffc5c
|
||||
SHA1 (patch-af) = 45cf852490bd30d17cac341916d83b0688f7bce0
|
||||
SHA1 (patch-ag) = b7159e56a1d1f1b5b12ea99ca60de0071bcf5294
|
||||
SHA1 (patch-ag) = e3d817a40a85dca1147f7d47a7adcb0596097494
|
||||
SHA1 (patch-ah) = 6afe0c047a67f83149a4130b4eae55612e437ad0
|
||||
|
|
|
@ -1,23 +1,25 @@
|
|||
$NetBSD: patch-ae,v 1.3 2009/07/24 12:10:18 obache Exp $
|
||||
$NetBSD: patch-ae,v 1.4 2010/10/22 17:55:28 drochner Exp $
|
||||
|
||||
--- FvwmCompositor/main/LayerManager.cxx.orig 2008-08-25 13:54:44.000000000 +0000
|
||||
+++ FvwmCompositor/main/LayerManager.cxx
|
||||
@@ -25,6 +25,20 @@
|
||||
@@ -25,6 +25,22 @@
|
||||
using namespace std;
|
||||
|
||||
// --------------------------------------------------------------------
|
||||
+#if defined(__NetBSD__) || defined(__DragonFly__)
|
||||
+static inline double
|
||||
+fmin(double x, double y)
|
||||
+xxxfmin(double x, double y)
|
||||
+{
|
||||
+ return (x < y) ? x : y;
|
||||
+}
|
||||
+
|
||||
+static inline double
|
||||
+fmax(double x, double y)
|
||||
+xxxfmax(double x, double y)
|
||||
+{
|
||||
+ return (x > y) ? x : y;
|
||||
+}
|
||||
+#define fmin xxxfmin
|
||||
+#define fmax xxxfmax
|
||||
+#endif
|
||||
+
|
||||
|
||||
|
|
|
@ -1,23 +1,25 @@
|
|||
$NetBSD: patch-ag,v 1.1 2009/07/24 12:10:18 obache Exp $
|
||||
$NetBSD: patch-ag,v 1.2 2010/10/22 17:55:28 drochner Exp $
|
||||
|
||||
--- FvwmCompositor/renderer/goodies.cxx.orig 2008-06-26 12:32:30.000000000 +0000
|
||||
+++ FvwmCompositor/renderer/goodies.cxx
|
||||
@@ -22,6 +22,20 @@
|
||||
@@ -22,6 +22,22 @@
|
||||
#include "FoldablePolygon.H"
|
||||
#include "desktop/MetisseWindow.H"
|
||||
|
||||
+#if defined(__NetBSD__) || defined(__DragonFly__)
|
||||
+static inline double
|
||||
+fmin(double x, double y)
|
||||
+xxxfmin(double x, double y)
|
||||
+{
|
||||
+ return (x < y) ? x : y;
|
||||
+}
|
||||
+
|
||||
+static inline double
|
||||
+fmax(double x, double y)
|
||||
+xxxfmax(double x, double y)
|
||||
+{
|
||||
+ return (x > y) ? x : y;
|
||||
+}
|
||||
+#define fmin xxxfmin
|
||||
+#define fmax xxxfmax
|
||||
+#endif
|
||||
+
|
||||
void goodies_marcking_feedback(
|
||||
|
|
Loading…
Reference in a new issue