Update to 1.13:

1.13
- move non fatal Perl bug checks into the help screen output
- fix Perl warnings when wrong/unknown charset is used
- run check for some essential Encode functionality at every startup
- add --fixdouble option to only fix files that are double-UTF-8 encoded
- add --parsable option to allow convmv output parsable suggestions for external tools to to something with it
- add --preserve-mtimes option to restore mtimes of parent directories
- allow an argv to be a symlink
- don't checksum deleted files in tar ball and use sha256 now
- allow skippig of certain test suite tests, useful for OS X to skip NFC/NFD related stuff, for example "make test SKIPTESTS=nfd-test,someothertest" will skip that test(s)
This commit is contained in:
wiz 2009-01-08 16:14:16 +00:00
parent 0155c98d12
commit 3241a569c1
3 changed files with 19 additions and 15 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.8 2008/02/16 13:17:12 wiz Exp $
# $NetBSD: Makefile,v 1.9 2009/01/08 16:14:16 wiz Exp $
DISTNAME= convmv-1.12
DISTNAME= convmv-1.13
CATEGORIES= converters
MASTER_SITES= http://www.j3e.de/linux/convmv/

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.4 2008/02/11 23:28:45 heinz Exp $
$NetBSD: distinfo,v 1.5 2009/01/08 16:14:16 wiz Exp $
SHA1 (convmv-1.12.tar.gz) = 7fe095e54f03b2ad689d3e970906373c4214f753
RMD160 (convmv-1.12.tar.gz) = c805c6c7993e465ea94daa8fe9439c2a5e32ff77
Size (convmv-1.12.tar.gz) = 23059 bytes
SHA1 (patch-aa) = 7efbad0d0007e3b67f4af8ec20a2710e33859d9d
SHA1 (convmv-1.13.tar.gz) = d226010584cae8223362287283ba5c63b079d1e8
RMD160 (convmv-1.13.tar.gz) = a20eb333e944c3dc735e1fc8791f5a921c01caa3
Size (convmv-1.13.tar.gz) = 26917 bytes
SHA1 (patch-aa) = 294c1713940926745dda0c15e66c585dbb8fe47e

View file

@ -1,16 +1,20 @@
$NetBSD: patch-aa,v 1.2 2008/02/11 23:28:46 heinz Exp $
$NetBSD: patch-aa,v 1.3 2009/01/08 16:14:16 wiz Exp $
- make variables overridable and thus the build process more flexible
Submitted upstream.
--- Makefile.orig Thu Jul 24 16:46:30 2003
--- Makefile.orig 2008-11-29 14:49:38.000000000 +0100
+++ Makefile
@@ -1,14 +1,18 @@
DESTDIR=
@@ -1,17 +1,21 @@
-DESTDIR=
-PREFIX=/usr/local
-MANDIR=$(PREFIX)/share/man
+DESTDIR?=
+PREFIX?=/usr/local
+MANDIR?=$(PREFIX)/share/man
TAR=tar
FIND=find
SED=sed
+INSTALL_MAN_DIR?=mkdir -p
+INSTALL_SCRIPT_DIR?=mkdir -p
+INSTALL_MAN?=cp
@ -23,10 +27,10 @@ $NetBSD: patch-aa,v 1.2 2008/02/11 23:28:46 heinz Exp $
- mkdir -p $(DESTDIR)$(PREFIX)/bin/
- cp convmv.1.gz $(DESTDIR)$(MANDIR)/man1/
- install -m 755 convmv $(DESTDIR)$(PREFIX)/bin/
+ ${INSTALL_MAN_DIR} $(DESTDIR)$(MANDIR)/man1
+ ${INSTALL_SCRIPT_DIR} $(DESTDIR)$(PREFIX)/bin
+ ${INSTALL_MAN} convmv.1.gz $(DESTDIR)$(MANDIR)/man1
+ ${INSTALL_SCRIPT} convmv $(DESTDIR)$(PREFIX)/bin
+ ${INSTALL_MAN_DIR} $(DESTDIR)$(MANDIR)/man1/
+ ${INSTALL_SCRIPT_DIR} $(DESTDIR)$(PREFIX)/bin/
+ ${INSTALL_MAN} convmv.1.gz $(DESTDIR)$(MANDIR)/man1/
+ ${INSTALL_SCRIPT} convmv $(DESTDIR)$(PREFIX)/bin/
manpage:
pod2man --section 1 --center=" " convmv | gzip > convmv.1.gz