Try to fix cmake syntax error when building with clang.
XXX ipv6 detection is still broken
This commit is contained in:
parent
1e8ccdebf1
commit
32438d41f2
2 changed files with 18 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.29 2012/06/16 04:45:39 markd Exp $
|
||||
$NetBSD: distinfo,v 1.30 2012/07/05 18:48:33 joerg Exp $
|
||||
|
||||
SHA1 (kdelibs-4.8.4.tar.xz) = 35cd199a30d84eb37b2b213fed5ee3adf810ea49
|
||||
RMD160 (kdelibs-4.8.4.tar.xz) = dba94c16eb0df9d6a4fccefc8097f39f4b63e9ec
|
||||
|
@ -15,6 +15,7 @@ SHA1 (patch-ak) = 73cc1bb149039d2fe3c05ee631426a8773f951c6
|
|||
SHA1 (patch-al) = 5efa7d504fe75bec53837bfa062a4b3f910fd71f
|
||||
SHA1 (patch-am) = b6c315d152d2c3d3c66ad85050549d0b39b263e5
|
||||
SHA1 (patch-cmake_modules_FindTaglib.cmake) = be38479966da542343dd962c57f7e9d1be3e9ff4
|
||||
SHA1 (patch-kdecore_CMakeLists.txt) = 1b517aa2d8c39988251c95bcd1daa012ea9bcfaa
|
||||
SHA1 (patch-kdecore_localization_klocale_kde.cpp) = b8a513a0c51e65d7e604a88c1d0e3325be6ad688
|
||||
SHA1 (patch-kdecore_util_kshareddatacache_p.h) = 6d064fe75fbecd489b0343960333864c717c0805
|
||||
SHA1 (patch-kjs_JSImmediate.h) = ecc761c7c82f711f41cf47d706c1c22d22c2980a
|
||||
|
|
16
x11/kdelibs4/patches/patch-kdecore_CMakeLists.txt
Normal file
16
x11/kdelibs4/patches/patch-kdecore_CMakeLists.txt
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-kdecore_CMakeLists.txt,v 1.1 2012/07/05 18:48:33 joerg Exp $
|
||||
|
||||
--- kdecore/CMakeLists.txt.orig 2012-07-05 12:21:26.000000000 +0000
|
||||
+++ kdecore/CMakeLists.txt
|
||||
@@ -384,8 +384,9 @@ if(NOT WIN32)
|
||||
set(kdecore_LIB_SRCS ${kdecore_LIB_SRCS} util/kshareddatacache.cpp)
|
||||
set(kdecore_OPTIONAL_LIBS ${kdecore_OPTIONAL_LIBS} ${CMAKE_THREAD_LIBS_INIT})
|
||||
|
||||
- set_source_files_properties(util/kshareddatacache.cpp
|
||||
- PROPERTIES COMPILE_FLAGS ${KDE4_ENABLE_EXCEPTIONS})
|
||||
+ if (KDE4_ENABLE_EXCEPTIONS)
|
||||
+ set_source_files_properties(util/kshareddatacache.cpp PROPERTIES COMPILE_FLAGS ${KDE4_ENABLE_EXCEPTIONS})
|
||||
+ endif (KDE4_ENABLE_EXCEPTIONS)
|
||||
else(NOT WIN32)
|
||||
set(kdecore_LIB_SRCS ${kdecore_LIB_SRCS} util/kshareddatacache_win.cpp)
|
||||
set(kdecore_LIB_SRCS ${kdecore_LIB_SRCS} io/kdirwatch_win.cpp)
|
Loading…
Reference in a new issue