firefox: fix build with latest rust. from Michael Forney in tech-pkg
This commit is contained in:
parent
45f3550ee9
commit
3277774e0d
2 changed files with 18 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.406 2020/07/31 01:26:43 maya Exp $
|
||||
$NetBSD: distinfo,v 1.407 2020/08/07 08:29:42 maya Exp $
|
||||
|
||||
SHA1 (firefox-79.0.source.tar.xz) = 3cbe88ce74cf834c7f91f72977ac443995bcee83
|
||||
RMD160 (firefox-79.0.source.tar.xz) = 58ee13d37da04099bae242df8534274e11776208
|
||||
|
@ -8,7 +8,7 @@ SHA1 (patch-aa) = 11060461fdaca5661e89651b8ded4a59d2abc4d7
|
|||
SHA1 (patch-browser_app_profile_firefox.js) = 89cea0a66457c96ad0b94aaa524aa5942ad781d0
|
||||
SHA1 (patch-build_moz.configure_rust.configure) = ee9e207e67709f3c9455b4d22f5f254890e99ca8
|
||||
SHA1 (patch-config_gcc-stl-wrapper.template.h) = 781a063fa6ab345face53fd88404ead11ab335b2
|
||||
SHA1 (patch-config_makefiles_rust.mk) = 8637cd3f56774648fd586c7ad8dd49e269b9eb2a
|
||||
SHA1 (patch-config_makefiles_rust.mk) = ffe12f9765a4dac3ee8c6b29416ffa6df6b14d0e
|
||||
SHA1 (patch-dom_base_nsAttrName.h) = ac7ba441a3b27df2855cf2673eea36b1cb44ad49
|
||||
SHA1 (patch-dom_media_CubebUtils.cpp) = 226821d961039ae5c9c50d8615757b73c6bcd80a
|
||||
SHA1 (patch-gfx_angle_checkout_src_common_third__party_smhasher_src_PMurHash.cpp) = e458c9c8dc66edc69c1874734af28a77fc5e3993
|
||||
|
|
|
@ -1,8 +1,11 @@
|
|||
$NetBSD: patch-config_makefiles_rust.mk,v 1.1 2020/04/30 19:08:50 maya Exp $
|
||||
$NetBSD: patch-config_makefiles_rust.mk,v 1.2 2020/08/07 08:29:42 maya Exp $
|
||||
|
||||
NetBSD doesn't get along with parallel rust builds (it causes issues
|
||||
with ld.so) which are the default. Force -j1.
|
||||
|
||||
Set -Cembed-bitcode=yes when using LTO to fix build with rust >= 1.45.
|
||||
Upstream bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1640982
|
||||
|
||||
--- config/makefiles/rust.mk.orig 2020-04-03 19:34:34.000000000 +0000
|
||||
+++ config/makefiles/rust.mk
|
||||
@@ -52,6 +52,9 @@ endif
|
||||
|
@ -15,3 +18,15 @@ with ld.so) which are the default. Force -j1.
|
|||
|
||||
# These flags are passed via `cargo rustc` and only apply to the final rustc
|
||||
# invocation (i.e., only the top-level crate, not its dependencies).
|
||||
@@ -62,6 +65,11 @@ ifndef MOZ_DEBUG_RUST
|
||||
# gkrust_gtest.
|
||||
ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
|
||||
cargo_rustc_flags += -Clto
|
||||
+endif
|
||||
+# Versions of rust >= 1.45 need -Cembed-bitcode=yes for all crates when
|
||||
+# using -Clto.
|
||||
+ifeq (,$(filter 1.38.% 1.39.% 1.40.% 1.41.% 1.42.% 1.43.% 1.44.%,$(RUSTC_VERSION)))
|
||||
+RUSTFLAGS += -Cembed-bitcode=yes
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
|
|
Loading…
Reference in a new issue