Patch htons issue with code. Don't define htons if configure didn't find it
and it's not already defined.
This commit is contained in:
parent
836eb2bb4e
commit
3279243cd1
3 changed files with 29 additions and 1 deletions
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/12/19 12:04:30 grant Exp $
|
||||
$NetBSD: distinfo,v 1.2 2003/03/01 11:08:35 jmc Exp $
|
||||
|
||||
SHA1 (quirc-0.9.82.tar.gz) = edb4e3acc8daf9d3451b91c3f98aed4a931b8c07
|
||||
Size (quirc-0.9.82.tar.gz) = 296135 bytes
|
||||
SHA1 (patch-aa) = 997938094af7ff493ad31248b13e428e393aa2a1
|
||||
SHA1 (patch-ab) = 4e37d9e64f55a5f587d513ac97dd284751c72e69
|
||||
SHA1 (patch-ac) = 5b147d7cfcd52264de43d501a159ee5dd150349b
|
||||
SHA1 (patch-ad) = a396c5a5ecbebae7b723cda1726866b474c79143
|
||||
|
|
13
chat/quirc/patches/patch-ac
Normal file
13
chat/quirc/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1 2003/03/01 11:08:35 jmc Exp $
|
||||
|
||||
--- support.cc.orig Sat Mar 1 11:02:55 2003
|
||||
+++ support.cc Sat Mar 1 11:03:12 2003
|
||||
@@ -46,7 +46,7 @@
|
||||
return string;
|
||||
}
|
||||
|
||||
-#ifndef HAVE_HTONS
|
||||
+#if !defined(HAVE_HTONS) && !defined(htons)
|
||||
unsigned short htons(unsigned short n) {
|
||||
return (n%256)*256+n/256;
|
||||
}
|
13
chat/quirc/patches/patch-ad
Normal file
13
chat/quirc/patches/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.1 2003/03/01 11:08:35 jmc Exp $
|
||||
|
||||
--- support.h.orig Sat Mar 1 11:01:17 2003
|
||||
+++ support.h Sat Mar 1 11:01:44 2003
|
||||
@@ -15,7 +15,7 @@
|
||||
0, effectively shortening the string's length by one. */
|
||||
extern char *chop(char *);
|
||||
|
||||
-#ifndef HAVE_HTONS
|
||||
+#if !defined(HAVE_HTONS) && !defined(htons)
|
||||
/* This function switches around the two bytes in the integer */
|
||||
extern unsigned short htons(unsigned short n);
|
||||
#endif
|
Loading…
Reference in a new issue