This package tries to avoid installing the docs for the subdirs of
wml/wml_common. Don't ask me why; however, make it do so correctly. Otherwise it breaks trying to chmod nothing. Fixes build with recent (or maybe not so recent, dunno how long this has been broken) perl.
This commit is contained in:
parent
2dffe44a3e
commit
3297c56d1d
4 changed files with 63 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.11 2009/03/26 18:19:31 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.12 2011/09/29 11:12:53 dholland Exp $
|
||||
|
||||
SHA1 (wml-2.0.9.tar.gz) = ce95ad9c55fd52e2028099d391858d88cffd5d9f
|
||||
RMD160 (wml-2.0.9.tar.gz) = bf14a4c09bdd850c5bad5f48f712717a13b13412
|
||||
|
@ -7,7 +7,7 @@ SHA1 (patch-aa) = 398ddb03402c17306e259b10cf9b5d7ec774d71b
|
|||
SHA1 (patch-ab) = dbd30a0a23189963aa60b06c319342fac4408a6b
|
||||
SHA1 (patch-ac) = 80863037faadf220ba1d01ef2133cdc42e08f0fa
|
||||
SHA1 (patch-ad) = 2955f349aa737f1758493897d1989a0b96220268
|
||||
SHA1 (patch-ae) = d250ebf44fa67fb247b0248476226d31a0c0c0c8
|
||||
SHA1 (patch-ae) = d52b117c67e9d521d4ffdd1a2ba03a512fcc315b
|
||||
SHA1 (patch-af) = e7dcb9287066e962d3fedafcea4302c71fbf0dce
|
||||
SHA1 (patch-ag) = 642371cb755e993118f5cc6a16abeaa62ec8d163
|
||||
SHA1 (patch-ah) = 8195a53d0a514b9ed1bd8e9460c8c3e77a1d0d8d
|
||||
|
@ -16,3 +16,5 @@ SHA1 (patch-aj) = eea40cf13d883656dc0db5d4de11df4a27bdc70f
|
|||
SHA1 (patch-ak) = 3b81025819f259d7ebb185de4d4890c9892aba87
|
||||
SHA1 (patch-al) = 9bdf732aad8520b89bc5925ae6eb0e2cce937f6b
|
||||
SHA1 (patch-am) = 5e597fed00ee56fbaf54d6725e36f9c9e5292c0e
|
||||
SHA1 (patch-wml__common_gd_makefile_pl_in) = 92481ea127e795bd92cc7d59c48a9224db8aaea1
|
||||
SHA1 (patch-wml__common_htmlclean_makefile_pl) = d9aea5c05b4b943adc9a74ae2f51858ee3213b74
|
||||
|
|
|
@ -1,8 +1,27 @@
|
|||
$NetBSD: patch-ae,v 1.1 2005/03/21 19:26:03 wiz Exp $
|
||||
$NetBSD: patch-ae,v 1.2 2011/09/29 11:12:53 dholland Exp $
|
||||
|
||||
--- wml_common/Makefile.in.orig 2001-02-07 00:02:12.000000000 +0100
|
||||
- Don't try to suppress building docs of the various subdirs by
|
||||
clearing the man installation directories; it croaks with recent Perl.
|
||||
Do it in the individual subdirs instead.
|
||||
|
||||
- Don't install File::PathConvert. (why?)
|
||||
|
||||
--- wml_common/Makefile.in.orig 2001-02-06 23:02:12.000000000 +0000
|
||||
+++ wml_common/Makefile.in
|
||||
@@ -46,7 +46,6 @@ INITVARS = \
|
||||
@@ -27,11 +27,7 @@ mandir = $(prefix)/man
|
||||
PATH_PERL = @PATH_PERL@
|
||||
MM_INSTALL_OPTS = PREFIX=$(libdir)/perl \
|
||||
INSTALLPRIVLIB=@INSTALLPRIVLIB@ \
|
||||
- INSTALLARCHLIB=@INSTALLARCHLIB@ \
|
||||
- INST_MAN1DIR= \
|
||||
- INSTALLMAN1DIR= \
|
||||
- INST_MAN3DIR= \
|
||||
- INSTALLMAN3DIR=
|
||||
+ INSTALLARCHLIB=@INSTALLARCHLIB@
|
||||
PERL_OPTS = @PERL_OPTS@
|
||||
|
||||
INITVARS = \
|
||||
@@ -46,7 +42,6 @@ INITVARS = \
|
||||
|
||||
SUBDIRS = \
|
||||
bitvector \
|
||||
|
|
22
www/wml/patches/patch-wml__common_gd_makefile_pl_in
Normal file
22
www/wml/patches/patch-wml__common_gd_makefile_pl_in
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-wml__common_gd_makefile_pl_in,v 1.1 2011/09/29 11:12:53 dholland Exp $
|
||||
|
||||
Suppress building/installation of the docs correctly. Fixes build
|
||||
failure with recent Perl.
|
||||
|
||||
--- wml_common/gd/Makefile.PL.in~ 2000-03-12 16:22:30.000000000 +0000
|
||||
+++ wml_common/gd/Makefile.PL.in
|
||||
@@ -13,10 +13,13 @@ WriteMakefile(
|
||||
# Uncomment the line below if you're getting link errors
|
||||
# having to do with missing math functions (like floor)
|
||||
'LIBS' => ["-lm @LIBPNG@"],
|
||||
- 'DEFINE' => '@DEFS@'
|
||||
+ 'DEFINE' => '@DEFS@',
|
||||
# Uncomment the line below if you're using a perl compiled
|
||||
# for fastCGI (http://www.fastcgi.com/).
|
||||
# 'DEFINE' => '-DFCGI'
|
||||
+ # suppress docs
|
||||
+ 'MAN1PODS' => { },
|
||||
+ 'MAN3PODS' => { }
|
||||
);
|
||||
|
||||
sub MY::postamble{
|
15
www/wml/patches/patch-wml__common_htmlclean_makefile_pl
Normal file
15
www/wml/patches/patch-wml__common_htmlclean_makefile_pl
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-wml__common_htmlclean_makefile_pl,v 1.1 2011/09/29 11:12:53 dholland Exp $
|
||||
|
||||
Suppress building/installation of the docs correctly. Fixes build
|
||||
failure with recent Perl.
|
||||
|
||||
--- wml_common/htmlclean/Makefile.PL~ 2000-04-19 22:23:08.000000000 +0000
|
||||
+++ wml_common/htmlclean/Makefile.PL
|
||||
@@ -4,4 +4,7 @@ WriteMakefile(
|
||||
'NAME' => 'HTML::Clean',
|
||||
'VERSION_FROM' => 'Clean.pm',
|
||||
'dist' => { COMPRESS => 'gzip', SUFFIX => 'gz' },
|
||||
+ # suppress docs
|
||||
+ 'MAN1PODS' => { },
|
||||
+ 'MAN3PODS' => { }
|
||||
);
|
Loading…
Reference in a new issue