gdbm: update to 1.23.

Version 1.23, 2022-02-04

* Bucket cache switched from balanced tree to hash table

Change suggested by Terence Kelly.

* Speed up flushing the changed buckets on disk

* New option codes for gdbm_setopt

** GDBM_GETDBFORMAT

Return the database format.

** GDBM_GETDIRDEPTH

Return the directory depth, i.e. the number of initial (most significant)
bits in hash value that are interpreted as index to the directory.

** GDBM_GETBUCKETSIZE

Return maximum number of keys per bucket.

** GDBM_GETCACHEAUTO

Return the status of the automatic cache adjustment.

** GDBM_SETCACHEAUTO

Enable or disable automatic cache adjustment.
This commit is contained in:
wiz 2022-02-15 09:26:46 +00:00
parent f76a942a82
commit 32a6fe79bf
3 changed files with 7 additions and 22 deletions

View File

@ -1,9 +1,9 @@
# $NetBSD: Makefile.common,v 1.12 2021/11/01 18:37:05 wiz Exp $
# $NetBSD: Makefile.common,v 1.13 2022/02/15 09:26:46 wiz Exp $
#
# used by databases/gdbm/Makefile
# used by databases/gdbm_compat/Makefile
DISTNAME= gdbm-1.22
DISTNAME= gdbm-1.23
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_GNU:=gdbm/}
@ -16,6 +16,7 @@ DISTINFO_FILE= ${.CURDIR}/../../databases/gdbm/distinfo
PATCHDIR= ${.CURDIR}/../../databases/gdbm/patches
USE_LIBTOOL= yes
USE_TOOLS+= gmake
GNU_CONFIGURE= yes
TEST_TARGET= check

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.22 2021/11/01 18:37:05 wiz Exp $
$NetBSD: distinfo,v 1.23 2022/02/15 09:26:46 wiz Exp $
BLAKE2s (gdbm-1.22.tar.gz) = c7562c7d917b7144d139e6746a7db3c3a57e83c6b4e8afa3b2868770025aa80c
SHA512 (gdbm-1.22.tar.gz) = 67461fc4f41e825d0134175ff99c913ccb4aa7ea3d0f64f32bdedbc7677b3ecabd2c525ac6b2ee47a9561e002e4224e492b72088d57bb4862a1f8c089521ec51
Size (gdbm-1.22.tar.gz) = 1090100 bytes
SHA1 (patch-src_Makefile.in) = 52b47f3dcd381143d1cdae40f1972bd989dcce1f
BLAKE2s (gdbm-1.23.tar.gz) = 569fadc9e8913bb217b666995f2673e29846602069d04b23cec02aed12dfbb7c
SHA512 (gdbm-1.23.tar.gz) = 918080cb0225b221c11eb7339634a95e00c526072395f7a3d46ccf42ef020dea7c4c5bec34aff2c4f16033e1fff6583252b7e978f68b8d7f8736b0e025838e10
Size (gdbm-1.23.tar.gz) = 1115854 bytes

View File

@ -1,15 +0,0 @@
$NetBSD: patch-src_Makefile.in,v 1.1 2017/03/20 06:02:26 adam Exp $
Fix parallel build.
--- src/Makefile.in.orig 2017-03-20 05:31:29.000000000 +0000
+++ src/Makefile.in
@@ -829,7 +829,7 @@ distdir: $(DISTFILES)
check-am: all-am
check: $(BUILT_SOURCES)
$(MAKE) $(AM_MAKEFLAGS) check-am
-all-am: Makefile $(LIBRARIES) $(LTLIBRARIES) $(PROGRAMS) $(HEADERS)
+all-am: Makefile $(LIBRARIES) $(LTLIBRARIES) .WAIT $(PROGRAMS) $(HEADERS)
install-binPROGRAMS: install-libLTLIBRARIES
installdirs: