xhyve: Fix build on Clang (OS X El Capitan).

This commit is contained in:
youri 2016-04-15 14:13:21 +00:00
parent e9a4d4861c
commit 32c14af61a
2 changed files with 17 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1 2016/03/19 18:11:36 sevan Exp $
$NetBSD: distinfo,v 1.2 2016/04/15 14:13:21 youri Exp $
SHA1 (xhyve-0.2.0.tar.gz) = 6c3e809c67f885dda260fbfc57dc5a117ba93deb
RMD160 (xhyve-0.2.0.tar.gz) = 2095268ac0ee9cfb835454857472dcc918a0edee
SHA512 (xhyve-0.2.0.tar.gz) = 99056a037efa63d1ff6c076bbff655e328f6e839b83d95f4b6eefc5dde122f471862e3ca0114413921df34f26b0e42874f47efd3478c0e015fc2bfeab35b890f
Size (xhyve-0.2.0.tar.gz) = 11632573 bytes
SHA1 (patch-src_vmm_io_vhpet.c) = 2db7bc7777cf3083d27247eeec81d4d619e42691

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_vmm_io_vhpet.c,v 1.1 2016/04/15 14:13:21 youri Exp $
Cast to void * to print address.
--- src/vmm/io/vhpet.c.orig 2015-07-27 02:07:09.000000000 +0000
+++ src/vmm/io/vhpet.c
@@ -291,7 +291,7 @@ vhpet_handler(void *a)
callout_deactivate(callout);
if (!vhpet_counter_enabled(vhpet))
- xhyve_abort("vhpet(%p) callout with counter disabled\n", vhpet);
+ xhyve_abort("vhpet(%p) callout with counter disabled\n", (void *)vhpet);
counter = vhpet_counter(vhpet, &now);
vhpet_start_timer(vhpet, n, counter, now);