malloc() and realloc() take a size_t, not an unsigned int. Fixes

compilation on Darwin.
This commit is contained in:
schmonz 2002-11-22 20:54:35 +00:00
parent a27501212c
commit 3307dee5f3
2 changed files with 24 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2002/09/01 05:58:49 schmonz Exp $
$NetBSD: distinfo,v 1.2 2002/11/22 20:54:35 schmonz Exp $
SHA1 (c4.tar.gz) = 3fba3364520ed28db8d1507cecde1ec0923f04b2
Size (c4.tar.gz) = 46038 bytes
SHA1 (patch-aa) = 1401168ee1d37cfcd243c82400bf924d8b4747f9
SHA1 (patch-ab) = b8f85a7c5f9c18ce62767e83f1f267899dc7aef3

22
devel/c4/patches/patch-ab Normal file
View file

@ -0,0 +1,22 @@
$NetBSD: patch-ab,v 1.1 2002/11/22 20:54:36 schmonz Exp $
--- main.c.orig Fri Feb 11 03:11:52 2000
+++ main.c
@@ -62,7 +62,7 @@ void *
Alloc(unsigned int sz)
{
void * p;
- extern void * malloc(unsigned int);
+ extern void * malloc(size_t);
p = malloc(sz);
if (!p)
@@ -75,7 +75,7 @@ void *
ReAlloc(void * xp, unsigned int sz)
{
void * p;
- extern void * realloc(void *, unsigned int);
+ extern void * realloc(void *, size_t);
p = realloc(xp, sz);
if (!p)