Import policykit version 0.9.
PolicyKit is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes: It is a framework for centralizing the decision making process with respect to granting access to privileged operations for unprivileged applications. PolicyKit is specifically targeting applications in rich desktop environments on multi-user UNIX-like operating systems. It does not imply or rely on any exotic kernel features.
This commit is contained in:
parent
8620414ff9
commit
33380d61b2
11 changed files with 242 additions and 0 deletions
7
security/policykit/DESCR
Normal file
7
security/policykit/DESCR
Normal file
|
@ -0,0 +1,7 @@
|
|||
PolicyKit is an application-level toolkit for defining and handling the
|
||||
policy that allows unprivileged processes to speak to privileged processes:
|
||||
It is a framework for centralizing the decision making process with respect
|
||||
to granting access to privileged operations for unprivileged applications.
|
||||
PolicyKit is specifically targeting applications in rich desktop environments
|
||||
on multi-user UNIX-like operating systems. It does not imply or rely on any
|
||||
exotic kernel features.
|
49
security/policykit/Makefile
Normal file
49
security/policykit/Makefile
Normal file
|
@ -0,0 +1,49 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
#
|
||||
|
||||
POLICYKIT_VER= 0.9
|
||||
DISTNAME= PolicyKit-${POLICYKIT_VER}
|
||||
PKGNAME= policykit-${POLICYKIT_VER}
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://hal.freedesktop.org/releases/
|
||||
|
||||
MAINTAINER= jmcneill@NetBSD.org
|
||||
HOMEPAGE= http://hal.freedesktop.org/
|
||||
COMMENT= Framework for managing admin policies and privileges
|
||||
|
||||
PKG_SYSCONFSUBDIR= PolicyKit
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/policykit
|
||||
CONF_FILES+= ${EGDIR}/PolicyKit.conf ${PKG_SYSCONFDIR}/PolicyKit.conf
|
||||
CONF_FILES+= ${EGDIR}/org.freedesktop.PolicyKit.conf ${PKG_SYSCONFBASE}/dbus-1/system.d/org.freedesktop.PolicyKit.conf
|
||||
#CONF_FILES+= ${EGDIR}/polkit ${PKG_SYSCONFBASE}/pam.d/polkit
|
||||
#CONF_FILES+= ${EGDIR}/polkit-bash-completion.sh ${PKG_SYSCONFDIR}/profile.d/polkit-bash-completion.sh
|
||||
|
||||
BUILD_DEFS+= VARBASE
|
||||
BUILD_DEFS+= PKG_SYSCONFBASE
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_DIRS+= xdg-1.4
|
||||
USE_PKGLOCALEDIR= YES
|
||||
USE_TOOLS+= gmake intltool msgfmt perl pkg-config
|
||||
USE_LIBTOOL= YES
|
||||
|
||||
POLICYKIT_USER?= polkit
|
||||
POLICYKIT_GROUP?= polkit
|
||||
PKG_GROUPS= ${POLICYKIT_GROUP}
|
||||
PKG_USERS= ${POLICYKIT_USER}:${POLICYKIT_GROUP}
|
||||
PKG_GROUPS_VARS+= POLICYKIT_GROUP
|
||||
PKG_USERS_VARS+= POLICYKIT_USER
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASE:Q}
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
|
||||
CONFIGURE_ARGS+= --with-polkit-user=${POLICYKIT_USER}
|
||||
CONFIGURE_ARGS+= --with-polkit-group=${POLICYKIT_GROUP}
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../textproc/xmlcatmgr/buildlink3.mk"
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../mk/pam.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
61
security/policykit/PLIST
Normal file
61
security/policykit/PLIST
Normal file
|
@ -0,0 +1,61 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
bin/polkit-action
|
||||
bin/polkit-auth
|
||||
bin/polkit-config-file-validate
|
||||
bin/polkit-policy-file-validate
|
||||
include/PolicyKit/polkit-dbus/polkit-dbus.h
|
||||
include/PolicyKit/polkit-dbus/polkit-simple.h
|
||||
include/PolicyKit/polkit-grant/polkit-grant.h
|
||||
include/PolicyKit/polkit/polkit-action.h
|
||||
include/PolicyKit/polkit/polkit-authorization-constraint.h
|
||||
include/PolicyKit/polkit/polkit-authorization-db.h
|
||||
include/PolicyKit/polkit/polkit-authorization.h
|
||||
include/PolicyKit/polkit/polkit-caller.h
|
||||
include/PolicyKit/polkit/polkit-config.h
|
||||
include/PolicyKit/polkit/polkit-context.h
|
||||
include/PolicyKit/polkit/polkit-error.h
|
||||
include/PolicyKit/polkit/polkit-policy-cache.h
|
||||
include/PolicyKit/polkit/polkit-policy-default.h
|
||||
include/PolicyKit/polkit/polkit-policy-file-entry.h
|
||||
include/PolicyKit/polkit/polkit-policy-file.h
|
||||
include/PolicyKit/polkit/polkit-result.h
|
||||
include/PolicyKit/polkit/polkit-seat.h
|
||||
include/PolicyKit/polkit/polkit-session.h
|
||||
include/PolicyKit/polkit/polkit-sysdeps.h
|
||||
include/PolicyKit/polkit/polkit-types.h
|
||||
include/PolicyKit/polkit/polkit.h
|
||||
lib/libpolkit-dbus.la
|
||||
lib/libpolkit-grant.la
|
||||
lib/libpolkit.la
|
||||
lib/pkgconfig/polkit-dbus.pc
|
||||
lib/pkgconfig/polkit-grant.pc
|
||||
lib/pkgconfig/polkit.pc
|
||||
libexec/polkit-explicit-grant-helper
|
||||
libexec/polkit-grant-helper
|
||||
libexec/polkit-grant-helper-pam
|
||||
libexec/polkit-read-auth-helper
|
||||
libexec/polkit-resolve-exe-helper
|
||||
libexec/polkit-revoke-helper
|
||||
libexec/polkit-set-default-helper
|
||||
libexec/polkitd
|
||||
man/man1/polkit-action.1
|
||||
man/man1/polkit-auth.1
|
||||
man/man1/polkit-config-file-validate.1
|
||||
man/man1/polkit-policy-file-validate.1
|
||||
man/man5/PolicyKit.conf.5
|
||||
man/man8/PolicyKit.8
|
||||
share/PolicyKit/config.dtd
|
||||
share/PolicyKit/policy/org.freedesktop.policykit.policy
|
||||
share/dbus-1/interfaces/org.freedesktop.PolicyKit.AuthenticationAgent.xml
|
||||
share/dbus-1/system-services/org.freedesktop.PolicyKit.service
|
||||
share/examples/policykit/PolicyKit.conf
|
||||
share/examples/policykit/polkit
|
||||
share/examples/policykit/org.freedesktop.PolicyKit.conf
|
||||
share/examples/policykit/polkit-bash-completion.sh
|
||||
@dirrm share/PolicyKit/policy
|
||||
@dirrm share/PolicyKit
|
||||
@dirrm share/examples/policykit
|
||||
@dirrm include/PolicyKit/polkit-grant
|
||||
@dirrm include/PolicyKit/polkit-dbus
|
||||
@dirrm include/PolicyKit/polkit
|
||||
@dirrm include/PolicyKit
|
22
security/policykit/buildlink3.mk
Normal file
22
security/policykit/buildlink3.mk
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
POLICYKIT_BUILDLINK3_MK:= ${POLICYKIT_BUILDLINK3_MK}+
|
||||
|
||||
.if ${BUILDLINK_DEPTH} == "+"
|
||||
BUILDLINK_DEPENDS+= policykit
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Npolicykit}
|
||||
BUILDLINK_PACKAGES+= policykit
|
||||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}policykit
|
||||
|
||||
.if ${POLICYKIT_BUILDLINK3_MK} == "+"
|
||||
BUILDLINK_API_DEPENDS.policykit+= policykit>=0.9
|
||||
BUILDLINK_PKGSRCDIR.policykit?= ../../security/policykit
|
||||
.endif # POLICYKIT_BUILDLINK3_MK
|
||||
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
11
security/policykit/distinfo
Normal file
11
security/policykit/distinfo
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
|
||||
SHA1 (PolicyKit-0.9.tar.gz) = ac99c580eff72f6d5df261c155fb047306439f85
|
||||
RMD160 (PolicyKit-0.9.tar.gz) = 197262d1c48e55558dd4bd57d7bbd8734666129c
|
||||
Size (PolicyKit-0.9.tar.gz) = 1254318 bytes
|
||||
SHA1 (patch-aa) = e282bf87a44e22181a61d1a5a29dd79a9f17afef
|
||||
SHA1 (patch-ab) = f869ed7f6298e4a88761782dada27984dbea0481
|
||||
SHA1 (patch-ac) = cf4b1fcfec1f079c015672235996c5331801fb48
|
||||
SHA1 (patch-ad) = 7d34235b9672680a146fe676d84ccaa09432f52c
|
||||
SHA1 (patch-ae) = b6a8c945de5cd7e605494d8575075e74c58da6a1
|
||||
SHA1 (patch-af) = 3363521088d151015fb5670d7f100d15b42a1d54
|
13
security/policykit/patches/patch-aa
Normal file
13
security/policykit/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
|
||||
--- src/polkit-dbus/polkit-resolve-exe-helper.c.orig 2008-05-30 17:24:44.000000000 -0400
|
||||
+++ src/polkit-dbus/polkit-resolve-exe-helper.c
|
||||
@@ -40,7 +40,7 @@
|
||||
#include <unistd.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
-#ifdef HAVE_FREEBSD
|
||||
+#if defined(HAVE_FREEBSD) || defined(__NetBSD__)
|
||||
#include <sys/param.h>
|
||||
#endif
|
||||
#include <security/pam_appl.h>
|
13
security/policykit/patches/patch-ab
Normal file
13
security/policykit/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
|
||||
--- tools/polkit-auth.c.orig 2008-05-30 17:24:44.000000000 -0400
|
||||
+++ tools/polkit-auth.c
|
||||
@@ -37,7 +37,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/types.h>
|
||||
-#if defined(HAVE_SOLARIS) || defined(HAVE_FREEBSD)
|
||||
+#if defined(HAVE_SOLARIS) || defined(HAVE_FREEBSD) || defined(__NetBSD__)
|
||||
#include <sys/wait.h>
|
||||
#endif
|
||||
#include <pwd.h>
|
18
security/policykit/patches/patch-ac
Normal file
18
security/policykit/patches/patch-ac
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
|
||||
--- data/Makefile.in.orig 2008-07-22 12:15:07.000000000 -0400
|
||||
+++ data/Makefile.in
|
||||
@@ -245,11 +245,11 @@ top_srcdir = @top_srcdir@
|
||||
|
||||
# See polkit-grant/Makefile.am for discussion
|
||||
#
|
||||
-@POLKIT_AUTHFW_PAM_TRUE@pamdir = $(sysconfdir)/pam.d
|
||||
+@POLKIT_AUTHFW_PAM_TRUE@pamdir = $(PREFIX)/share/examples/policykit
|
||||
@POLKIT_AUTHFW_PAM_TRUE@pam_DATA = polkit
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = polkit.pc polkit-dbus.pc polkit-grant.pc
|
||||
-confdir = $(sysconfdir)/PolicyKit
|
||||
+confdir = $(PREFIX)/share/examples/policykit
|
||||
conf_DATA = PolicyKit.conf
|
||||
dtddir = $(datadir)/PolicyKit
|
||||
dtd_DATA = config.dtd
|
13
security/policykit/patches/patch-ad
Normal file
13
security/policykit/patches/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
|
||||
--- polkitd/Makefile.in.orig 2008-07-22 12:15:07.000000000 -0400
|
||||
+++ polkitd/Makefile.in
|
||||
@@ -298,7 +298,7 @@ polkitd_LDADD = \
|
||||
servicedir = $(datadir)/dbus-1/system-services
|
||||
service_in_files = org.freedesktop.PolicyKit.service.in
|
||||
service_DATA = $(service_in_files:.service.in=.service)
|
||||
-dbusconfdir = $(sysconfdir)/dbus-1/system.d
|
||||
+dbusconfdir = $(PREFIX)/share/examples/policykit
|
||||
dbusconf_in_files = org.freedesktop.PolicyKit.conf.in
|
||||
dbusconf_DATA = $(dbusconf_in_files:.conf.in=.conf)
|
||||
CLEANFILES = $(BUILT_SOURCES)
|
13
security/policykit/patches/patch-ae
Normal file
13
security/policykit/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
|
||||
--- tools/Makefile.in.orig 2008-07-22 12:15:08.000000000 -0400
|
||||
+++ tools/Makefile.in
|
||||
@@ -292,7 +292,7 @@ polkit_auth_SOURCES = polkit-auth.c
|
||||
polkit_auth_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ $(top_builddir)/src/polkit/libpolkit.la $(top_builddir)/src/polkit-grant/libpolkit-grant.la $(top_builddir)/src/polkit-dbus/libpolkit-dbus.la
|
||||
polkit_action_SOURCES = polkit-action.c
|
||||
polkit_action_LDADD = $(top_builddir)/src/polkit/libpolkit.la
|
||||
-profiledir = $(sysconfdir)/profile.d
|
||||
+profiledir = $(PREFIX)/share/examples/policykit
|
||||
profile_SCRIPTS = polkit-bash-completion.sh
|
||||
EXTRA_DIST = $(profile_SCRIPTS)
|
||||
all: all-am
|
22
security/policykit/patches/patch-af
Normal file
22
security/policykit/patches/patch-af
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
||||
|
||||
--- src/polkit/polkit-sysdeps.c.orig 2008-11-21 22:17:08.000000000 -0500
|
||||
+++ src/polkit/polkit-sysdeps.c
|
||||
@@ -106,7 +106,7 @@ polkit_sysdeps_get_start_time_for_pid (p
|
||||
}
|
||||
start_time = (unsigned long long) (info.pr_start.tv_sec);
|
||||
#else
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__)
|
||||
filename = kit_strdup_printf ("/proc/%d/status", pid);
|
||||
#else
|
||||
filename = kit_strdup_printf ("/proc/%d/stat", pid);
|
||||
@@ -121,7 +121,7 @@ polkit_sysdeps_get_start_time_for_pid (p
|
||||
goto out;
|
||||
}
|
||||
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__)
|
||||
tokens = kit_strsplit (contents, ' ', &num_tokens);
|
||||
if (tokens == NULL)
|
||||
goto out;
|
Loading…
Reference in a new issue