emulators: remove libretro-fbalpha, replaced by libretro-fbneo

This commit is contained in:
nia 2020-05-31 12:28:21 +00:00
parent 997991312b
commit 33a785de93
7 changed files with 1 additions and 110 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.317 2020/05/31 12:19:33 nia Exp $
# $NetBSD: Makefile,v 1.318 2020/05/31 12:28:21 nia Exp $
#
COMMENT= Emulators for other operating systems
@ -106,7 +106,6 @@ SUBDIR+= libretro-cap32
SUBDIR+= libretro-core-info
SUBDIR+= libretro-desmume
SUBDIR+= libretro-dolphin
SUBDIR+= libretro-fbalpha
SUBDIR+= libretro-fbneo
SUBDIR+= libretro-fceumm
SUBDIR+= libretro-freeintv

View file

@ -1,7 +0,0 @@
Libretro is a simple but powerful development interface that allows for the
easy creation of emulators, games and multimedia applications that can plug
straight into any libretro-compatible frontend. This development interface is
open to others so that they can run these pluggable emulator and game cores
also in their own programs or devices.
FB Alpha (Final Burn Alpha) is an arcade game emulator.

View file

@ -1,41 +0,0 @@
# $NetBSD: Makefile,v 1.6 2020/05/26 09:45:14 nia Exp $
DISTNAME= libretro-fbalpha-0.2.97.43.20181022
PKGREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_GITHUB:=libretro/}
GITHUB_PROJECT= fbalpha2018
GITHUB_TAG= 20daa807957d7fce64371620271b502811318163
MAINTAINER= nia@NetBSD.org
HOMEPAGE= https://github.com/libretro/fbalpha
COMMENT= Libretro core based on the FB Alpha arcade game emulator
LICENSE= fbalpha-license AND mame-license
USE_TOOLS+= gmake
MAKE_FILE= makefile.libretro
USE_LANGUAGES= c c++
OPSYSVARS+= SOEXT
SOEXT.Darwin= dylib
SOEXT.*= so
PLIST_SUBST+= SOEXT=${SOEXT}
MAKE_FLAGS+= GIT_VERSION="-pkgsrc"
.include "../../mk/endian.mk"
.if ${MACHINE_ENDIAN} == "big"
MAKE_FLAGS+= ENDIANNESS_DEFINES=-DWORDS_BIGENDIAN
.endif
BUILDLINK_TRANSFORM.SunOS+= rm:-Wl,-no-undefined
BUILDLINK_TRANSFORM.SunOS+= rm:-Wl,--version-script=src/burner/libretro/link.T
INSTALLATION_DIRS+= ${PREFIX}/lib/libretro
do-install:
${INSTALL_LIB} ${WRKSRC}/fbalpha_libretro.so \
${DESTDIR}${PREFIX}/lib/libretro/fbalpha_libretro.so
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2020/05/26 09:45:14 nia Exp $
lib/libretro/fbalpha_libretro.${SOEXT}

View file

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.4 2018/11/13 17:16:25 nia Exp $
SHA1 (libretro-fbalpha-0.2.97.43.20181022-20daa807957d7fce64371620271b502811318163.tar.gz) = 45025f8fb79afcbb65d3de7d927f5eeed709faaf
RMD160 (libretro-fbalpha-0.2.97.43.20181022-20daa807957d7fce64371620271b502811318163.tar.gz) = d42603bb5298965cbcc0565846b893a2fef7685d
SHA512 (libretro-fbalpha-0.2.97.43.20181022-20daa807957d7fce64371620271b502811318163.tar.gz) = a5aee22e6e17905ac33bd221efced9844579ec11dfe7ba55755fdd327099f1017ec7d83ff5dbb5390ddfb4fe5661d792ffda204cbe3e14bd8598ae5800f77f4c
Size (libretro-fbalpha-0.2.97.43.20181022-20daa807957d7fce64371620271b502811318163.tar.gz) = 10216979 bytes
SHA1 (patch-makefile.libretro) = 53580ffc41c22c745d70aa9949c5df2affc783d4
SHA1 (patch-src_burner_libretro_burn__endian.h) = fbca4fbadbc6a15630719ab6d9494d00a36f226a

View file

@ -1,17 +0,0 @@
$NetBSD: patch-makefile.libretro,v 1.1 2018/08/17 12:54:48 nia Exp $
Don't force -O3.
--- makefile.libretro.orig 2018-04-08 06:33:58.000000000 +0000
+++ makefile.libretro
@@ -427,8 +427,8 @@ ifeq ($(DEBUG), 1)
CXXFLAGS += -O0 -g -DFBA_DEBUG
else
ifeq (,$(findstring msvc,$(platform)))
- CFLAGS += -O3 -DNDEBUG
- CXXFLAGS += -O3 -DNDEBUG
+ CFLAGS += -DNDEBUG
+ CXXFLAGS += -DNDEBUG
else
CFLAGS += -O2 -DNDEBUG
CXXFLAGS += -O2 -DNDEBUG

View file

@ -1,33 +0,0 @@
$NetBSD: patch-src_burner_libretro_burn__endian.h,v 1.1 2018/11/13 17:16:25 nia Exp $
More than games consoles are big endian.
--- src/burner/libretro/burn_endian.h.orig 2018-11-13 16:00:03.905824261 +0000
+++ src/burner/libretro/burn_endian.h
@@ -1,7 +1,7 @@
#ifndef _FBA_ENDIAN_H
#define _FBA_ENDIAN_H
-#ifndef _XBOX
+#if !defined(_XBOX) && !defined(__NetBSD__)
#define NO_64BIT_BYTESWAP
#endif
@@ -49,6 +49,17 @@ typedef union {
/* Not sure the asm stuff is working properly, so trying something else for debugging (may be slower) */
//#define BURN_ENDIAN_SWAP_INT16(x) (((x) >> 8) | (((x) & 0xFF) << 8))
//#define BURN_ENDIAN_SWAP_INT32(x) (((x) >> 24) | (((x) & 0x00FF0000) >> 8) | (((x) & 0x0000FF00) << 8) | (((x) & 0xFF) << 24))
+#elif defined(__NetBSD__)
+#include <sys/types.h>
+#include <machine/bswap.h>
+#define BURN_ENDIAN_SWAP_INT8(x) (x^1)
+#define BURN_ENDIAN_SWAP_INT16(x) (bswap16(x))
+#define BURN_ENDIAN_SWAP_INT32(x) (bswap32(x))
+#define BURN_ENDIAN_SWAP_INT64(x) (bswap64(x))
+#else
+#define BURN_ENDIAN_SWAP_INT8(x) (x^1)
+#define BURN_ENDIAN_SWAP_INT16(x) ((((x) << 8) & 0xff00) | (((x) >> 8) & 0x00ff))
+#define BURN_ENDIAN_SWAP_INT32(x) ((((x) << 24) & 0xff000000) | (((x) << 8) & 0x00ff0000) | (((x) >> 8) & 0x0000ff00) | (((x) >> 24) & 0x000000ff))
#endif
#ifdef NO_64BIT_BYTESWAP