openssl: Unbreak Darwin installs after --libdir change.
Adding --libdir seems innocuous enough, but due to OpenSSL's crazy complicated build system actually results in LIBDIR becoming unset, which trickles down to the Darwin -install_name being wrong. This broke the 'openssl' command and thus many many dependencies. Switch to $(libdir) instead which appears to still be set correctly.
This commit is contained in:
parent
18071af109
commit
33b1dc683a
2 changed files with 17 additions and 1 deletions
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.141 2020/04/30 11:21:57 nia Exp $
|
||||
$NetBSD: distinfo,v 1.142 2020/05/23 10:32:06 jperkin Exp $
|
||||
|
||||
SHA1 (openssl-1.1.1g.tar.gz) = b213a293f2127ec3e323fb3cfc0c9807664fd997
|
||||
RMD160 (openssl-1.1.1g.tar.gz) = 427b7b12c06715ad1c95d3ff5e38055c6bb66c1d
|
||||
SHA512 (openssl-1.1.1g.tar.gz) = 01e3d0b1bceeed8fb066f542ef5480862001556e0f612e017442330bbd7e5faee228b2de3513d7fc347446b7f217e27de1003dc9d7214d5833b97593f3ec25ab
|
||||
Size (openssl-1.1.1g.tar.gz) = 9801502 bytes
|
||||
SHA1 (patch-Configurations_shared-info.pl) = 0e835f6e343b5d05ef9a0e6ef2a195201262d15c
|
||||
SHA1 (patch-Configurations_unix-Makefile.tmpl) = d58376dfc8cbb4c7d98ca64093759f173eac73da
|
||||
SHA1 (patch-crypto_rand_rand__unix.c) = 9aa1ff0b0ff1db3fcadacf8707596a7db852f956
|
||||
|
|
15
security/openssl/patches/patch-Configurations_shared-info.pl
Normal file
15
security/openssl/patches/patch-Configurations_shared-info.pl
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-Configurations_shared-info.pl,v 1.1 2020/05/23 10:32:06 jperkin Exp $
|
||||
|
||||
Specifying --libdir makes LIBDIR empty and breaks library names.
|
||||
|
||||
--- Configurations/shared-info.pl.orig 2020-04-21 12:22:39.000000000 +0000
|
||||
+++ Configurations/shared-info.pl
|
||||
@@ -44,7 +44,7 @@ my %shared_info;
|
||||
'darwin-shared' => {
|
||||
module_ldflags => '-bundle',
|
||||
shared_ldflag => '-dynamiclib -current_version $(SHLIB_VERSION_NUMBER) -compatibility_version $(SHLIB_VERSION_NUMBER)',
|
||||
- shared_sonameflag => '-install_name $(INSTALLTOP)/$(LIBDIR)/',
|
||||
+ shared_sonameflag => '-install_name $(libdir)/',
|
||||
},
|
||||
'cygwin-shared' => {
|
||||
shared_ldflag => '-shared -Wl,--enable-auto-image-base',
|
Loading…
Reference in a new issue