dd patch to fix build with USE_FORTIFY.

This commit is contained in:
wiz 2015-12-11 13:11:08 +00:00
parent 3e6981bf0e
commit 33d5083b1f
2 changed files with 25 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.22 2015/11/03 23:33:41 agc Exp $
$NetBSD: distinfo,v 1.23 2015/12/11 13:11:08 wiz Exp $
SHA1 (pari-2.3.5.tar.gz) = f211ccfe42a4b18dbcde832dfd1ece6f477f4966
RMD160 (pari-2.3.5.tar.gz) = 488adf3af5398d0ab5390eb86b65cd79bd1044c5
@ -23,4 +23,5 @@ SHA1 (patch-ap) = 21a20b68b589f8be3036d1f2f9c4b2a7f43210a8
SHA1 (patch-config_get_fltk) = 2c2aa271fad5880a44b2df70a7143d2aea690ca0
SHA1 (patch-src_headers_paridecl.h) = ee02e487807d8ed1c1a11268965ade76a2f80cf2
SHA1 (patch-src_language_anal.c) = d0028a51e8ef14cae766cb881fcfce82cec0346f
SHA1 (patch-src_language_es.c) = 27c286da66ce1a2fc6e5179cfb3f4e222984813d
SHA1 (patch-src_modules_mpqs.c) = 3dd164e5c686fd2eb8317569cf05906a4c527721

View file

@ -0,0 +1,23 @@
$NetBSD: patch-src_language_es.c,v 1.1 2015/12/11 13:11:08 wiz Exp $
Remove fgets() indirection to fix build with USE_FORTIFY.
--- src/language/es.c.orig 2008-03-31 11:43:58.000000000 +0000
+++ src/language/es.c
@@ -215,7 +215,6 @@ gp_read_stream_buf(FILE *fi, Buffer *b)
init_filtre(&F, b);
IM.file = fi;
- IM.fgets= &fgets;
IM.getline= &file_input;
IM.free = 0;
return input_loop(&F,&IM);
@@ -309,7 +308,7 @@ file_input(char **s0, int junk, input_me
*s0 = b->buf + used0;
}
s = b->buf + used;
- if (! IM->fgets(s, left, IM->file))
+ if (! fgets(s, left, IM->file))
return first? NULL: *s0; /* EOF */
l = strlen(s); first = 0;