Add cfmakeraw compatability for SunOS.

This commit is contained in:
jperkin 2014-01-09 15:40:55 +00:00
parent 57be30d991
commit 33db72022a
4 changed files with 49 additions and 8 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.2 2013/01/26 23:00:32 wiz Exp $
$NetBSD: distinfo,v 1.3 2014/01/09 15:40:55 jperkin Exp $
SHA1 (trrntzip_v02_src.tar.gz) = ad2487d7e9edc6608358104df8367da3d535fd2b
RMD160 (trrntzip_v02_src.tar.gz) = 1a6718babc3cfb42e99fadbb53360ecb4f15b5b9
Size (trrntzip_v02_src.tar.gz) = 46971 bytes
SHA1 (patch-aa) = 639626aab0ab5f3a359cde057d83f0291f1476cb
SHA1 (patch-configure.ac) = f6657e42c74ad4722c852c733c819ebb0c58e8ef
SHA1 (patch-src_platform.c) = ef7d4dae6b40dfea623a882141316ddf80e4c6eb

View file

@ -0,0 +1,22 @@
$NetBSD: patch-src_platform.c,v 1.1 2014/01/09 15:40:55 jperkin Exp $
cfmakeraw compatability for SunOS.
--- src/platform.c.orig 2005-04-17 08:36:15.000000000 +0000
+++ src/platform.c
@@ -45,7 +45,15 @@ getch (void)
tcgetattr (1, &t);
t2 = t;
+#ifdef __sun
+ t2.c_iflag &= ~(IMAXBEL|IGNBRK|BRKINT|PARMRK|ISTRIP|INLCR|IGNCR|ICRNL|IXON);
+ t2.c_oflag &= ~OPOST;
+ t2.c_lflag &= ~(ECHO|ECHONL|ICANON|ISIG|IEXTEN);
+ t2.c_cflag &= ~(CSIZE|PARENB);
+ t2.c_cflag |= CS8;
+#else
cfmakeraw (&t2);
+#endif
tcsetattr (1, TCSANOW, &t2);
fread (&c, 1, 1, stdin);
tcsetattr (1, TCSANOW, &t);

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.5 2013/09/10 14:41:18 joerg Exp $
$NetBSD: distinfo,v 1.6 2014/01/09 15:45:18 jperkin Exp $
SHA1 (stylewriter.tar.gz) = 8efbbe7510341584ac5170b178f8e6c50c0f6f91
RMD160 (stylewriter.tar.gz) = 86484c2e8e357d891533c2d52c8e5f5ff64eb544
Size (stylewriter.tar.gz) = 30136 bytes
SHA1 (patch-aa) = 753d1eff4a1ca6d4048cc0bc4074f4f4f0f25ceb
SHA1 (patch-aa) = d8879e10a8f4ca831bbaa6af70c3fe5bf6fd0dba

View file

@ -1,8 +1,26 @@
$NetBSD: patch-aa,v 1.2 2013/09/10 14:41:18 joerg Exp $
$NetBSD: patch-aa,v 1.3 2014/01/09 15:45:18 jperkin Exp $
cfmakeraw compatability for SunOS.
--- lpstyl.c.orig 1999-03-31 09:05:21.000000000 +0000
+++ lpstyl.c
@@ -1015,10 +1015,13 @@ size_t readFileScanline(char *bufK, char
@@ -443,7 +443,15 @@ int main(int argc, char **argv)
struct termios t;
tcgetattr(1, &t);
+#ifdef __sun
+ t.c_iflag &= ~(IMAXBEL|IGNBRK|BRKINT|PARMRK|ISTRIP|INLCR|IGNCR|ICRNL|IXON);
+ t.c_oflag &= ~OPOST;
+ t.c_lflag &= ~(ECHO|ECHONL|ICANON|ISIG|IEXTEN);
+ t.c_cflag &= ~(CSIZE|PARENB);
+ t.c_cflag |= CS8;
+#else
cfmakeraw(&t);
+#endif
cfsetispeed(&t, B57600);
cfsetospeed(&t, B57600);
if(tcsetattr(1, TCSAFLUSH, &t) == -1)
@@ -1015,10 +1023,13 @@ size_t readFileScanline(char *bufK, char
if((i & 0x03) == 0)
{
/* write the output */
@ -20,7 +38,7 @@ $NetBSD: patch-aa,v 1.2 2013/09/10 14:41:18 joerg Exp $
cmyk = 0;
}
}
@@ -1031,10 +1034,10 @@ size_t readFileScanline(char *bufK, char
@@ -1031,10 +1042,10 @@ size_t readFileScanline(char *bufK, char
}
/* write the final part */
@ -35,7 +53,7 @@ $NetBSD: patch-aa,v 1.2 2013/09/10 14:41:18 joerg Exp $
}
else
{
@@ -1327,7 +1330,7 @@ void sendEncodedData(unsigned char *buff
@@ -1327,7 +1338,7 @@ void sendEncodedData(unsigned char *buff
if(verbose)
{
@ -44,7 +62,7 @@ $NetBSD: patch-aa,v 1.2 2013/09/10 14:41:18 joerg Exp $
ProcName, size);
}
begin[0] = 'G';
@@ -1827,7 +1830,8 @@ void waitStatus(int stat, int canHandleP
@@ -1827,7 +1838,8 @@ void waitStatus(int stat, int canHandleP
static int inputBack = -1;
size_t inputRead(void *buffer, size_t size)
{