py-pygit2: updated to 1.4.0

1.4.0
- Upgrade to libgit2 1.1, new ``GIT_BLAME_IGNORE_WHITESPACE`` constant
- Add wheels for Python 3.9
- Drop support for PyPy3 7.2
- New optional ``flags`` argument in ``Repository.__init__(...)``,
  new ``GIT_REPOSITORY_OPEN_*`` constants
- Documentation
This commit is contained in:
adam 2020-11-21 22:33:59 +00:00
parent 6865a06140
commit 33e44cbd44
3 changed files with 15 additions and 16 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.18 2020/10/22 16:24:10 jperkin Exp $
# $NetBSD: Makefile,v 1.19 2020/11/21 22:33:59 adam Exp $
DISTNAME= pygit2-1.3.0
DISTNAME= pygit2-1.4.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=p/pygit2/}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.14 2020/10/22 16:24:10 jperkin Exp $
$NetBSD: distinfo,v 1.15 2020/11/21 22:33:59 adam Exp $
SHA1 (pygit2-1.3.0.tar.gz) = 1527df46c38ae6eafd9de2424f8d005953279e51
RMD160 (pygit2-1.3.0.tar.gz) = 184e2cc6eab30ead8a3744a7ae61f12c565e743b
SHA512 (pygit2-1.3.0.tar.gz) = 297c6aef27019ca540d7ec9c26da7a5e870a7e5c2e06daa1a038023c4ab32c800b2494970e41a3d576e17e1d2c33402c3116389d9e2ebe1c2def0ba529dbde71
Size (pygit2-1.3.0.tar.gz) = 243399 bytes
SHA1 (patch-src_types.h) = 81eca685eb669818d9ad9eb05ff44b874fa04f76
SHA1 (pygit2-1.4.0.tar.gz) = 757269125f043b1cc2aacc211b79bc6d876cddb2
RMD160 (pygit2-1.4.0.tar.gz) = 03192325f88bd7d13447a9c5699374ce63a74f88
SHA512 (pygit2-1.4.0.tar.gz) = b6b9d5028fd63593e6ecd869735132edeeb55c1fd97664be5d0d5dac0c25f844ce0d981782fad7f47e54555ab1f7fa5e87d1ad8a76340d81e1f908ad4ea1e35a
Size (pygit2-1.4.0.tar.gz) = 244586 bytes
SHA1 (patch-src_types.h) = a7134bfd2a566832a7c62b96d11248fc17130213

View file

@ -1,17 +1,16 @@
$NetBSD: patch-src_types.h,v 1.1 2020/10/22 16:24:10 jperkin Exp $
$NetBSD: patch-src_types.h,v 1.2 2020/11/21 22:33:59 adam Exp $
Builds and tests fine against libgit2 1.1.x.
Builds and tests fine against newer libgit2.
--- src/types.h.orig 2020-07-24 11:39:38.000000000 +0000
--- src/types.h.orig 2020-10-14 06:40:15.000000000 +0000
+++ src/types.h
@@ -32,10 +32,6 @@
@@ -32,9 +32,6 @@
#include <Python.h>
#include <git2.h>
-#if !(LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR == 0)
-#error You need a compatible libgit2 version (1.0.x)
-#if !(LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR == 1)
-#error You need a compatible libgit2 version (1.1.x)
-#endif
-
/*
* Python objects
*