Ooops, stupid typo in previous

This commit is contained in:
martin 2013-10-24 19:25:43 +00:00
parent 9bd6ddf2ed
commit 33ed66cfcc
2 changed files with 8 additions and 6 deletions

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.10 2013/10/24 18:31:12 martin Exp $
$NetBSD: distinfo,v 1.11 2013/10/24 19:25:43 martin Exp $
SHA1 (gcc-4.8.2.tar.bz2) = 810fb70bd721e1d9f446b6503afe0a9088b62986
RMD160 (gcc-4.8.2.tar.bz2) = a417e682baa20877c290f6dc7d3d03a0c3710371
Size (gcc-4.8.2.tar.bz2) = 85999682 bytes
SHA1 (patch-gcc-config-vax-constraints.md) = e6cea7a5334b5b124ca3e8b62eba45423e788e55
SHA1 (patch-gcc-config-vax-vax.c) = 02e389ec418a0fee1431ecd61d65b7f8d7629785
SHA1 (patch-gcc-config-vax-vax.md) = c0e9cc1d64f67192b376e5e0d19ca7b35677ad57
SHA1 (patch-gcc-config-vax-vax.md) = e06696be85641cbe9131ecc10bb28c45a465916d
SHA1 (patch-gcc_Makefile.in) = b2bceb34537de1cf704f18a59aa4e4d4a4551c62
SHA1 (patch-gcc_config.gcc) = ac175c5eecf3dd53508479b30bf5c59cc0a5fca9
SHA1 (patch-gcc_config.host) = 1b1e11cd199eb93f49443d51c0063b09b7327858

View file

@ -1,10 +1,10 @@
$NetBSD: patch-gcc-config-vax-vax.md,v 1.1 2013/10/24 18:31:12 martin Exp $
$NetBSD: patch-gcc-config-vax-vax.md,v 1.2 2013/10/24 19:25:43 martin Exp $
Part of upstream change rev. 202796, additionally change from Matt Thomas
to fix http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58442.
--- gcc/config/vax/vax.md.orig 2013-01-15 22:30:24.000000000 +0100
+++ gcc/config/vax/vax.md 2013-10-24 18:21:32.000000000 +0200
+++ gcc/config/vax/vax.md 2013-10-24 21:18:17.000000000 +0200
@@ -697,14 +697,14 @@
(ashift:DI (match_operand:DI 1 "general_operand" "g")
(match_operand:QI 2 "general_operand" "g")))]
@ -46,13 +46,15 @@ to fix http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58442.
"*
{
if (REG_P (operands[1]))
@@ -838,7 +840,8 @@
@@ -838,8 +840,9 @@
"(INTVAL (operands[2]) == 8 || INTVAL (operands[2]) == 16)
&& INTVAL (operands[3]) % INTVAL (operands[2]) == 0
&& (REG_P (operands[1])
- || ! mode_dependent_address_p (XEXP (operands[1], 0),
- MEM_ADDR_SPACE (operands[1])))"
+ || (MEM_P(operands[1])
+ && ! mode_dependent_address_p (XEXP (operands[1], 0),
MEM_ADDR_SPACE (operands[1])))"
+ MEM_ADDR_SPACE (operands[1]))))"
"*
{
if (REG_P (operands[1]))