ffmpeg3: Enable section_data_rel_ro on NetBSD

Seems to resolve text relocation issues on aarch64.

Thanks to an upstream commit fixing the exact problem we're having
(on Linux...) from 2014 for the hint...

Bump PKGREVISION.
This commit is contained in:
nia 2020-06-26 21:19:16 +00:00
parent 324e73cd26
commit 33fa2486dc
3 changed files with 11 additions and 13 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.55 2020/06/26 03:11:40 jklos Exp $
# $NetBSD: Makefile,v 1.56 2020/06/26 21:19:16 nia Exp $
PKGNAME= ${DISTNAME:S/ffmpeg/ffmpeg3/}
PKGREVISION= 8
PKGREVISION= 9
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://ffmpeg.org/
COMMENT= Decoding, encoding and streaming software (v3.x)
@ -56,10 +56,6 @@ CFLAGS+= -mstackrealign -mpreferred-stack-boundary=4
NOT_PAX_MPROTECT_SAFE+= bin/ffmpeg4
.endif
.if ${MACHINE_ARCH} == "aarch64"
NOT_PAX_MPROTECT_SAFE+= bin/ffmpeg4
.endif
# configure script uses uname -m to detect arch, as opposed to uname -p in
# GNU/configure. Unable to detect NetBSD/macppc hosts correctly.
CONFIGURE_ARGS+= --arch=${MACHINE_ARCH}

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.32 2020/01/08 13:41:33 wiz Exp $
$NetBSD: distinfo,v 1.33 2020/06/26 21:19:16 nia Exp $
SHA1 (ffmpeg-3.4.7.tar.xz) = b9c4b52cda84b0d23c9a542beaf32a68b204c287
RMD160 (ffmpeg-3.4.7.tar.xz) = 7dfd08aac3295785034047bd73967a18ce4b8d79
SHA512 (ffmpeg-3.4.7.tar.xz) = a069618e25753b2c796c4221b5ff9251fea436b11890098166273f456eb7b7832d61f1e7976bd2117f1d55450975a94403be930bb0fa27d7a98cd7c61f80b0d2
Size (ffmpeg-3.4.7.tar.xz) = 8497552 bytes
SHA1 (patch-Makefile) = 0c35f53878b0420aeea49d8ccb249279e705eb40
SHA1 (patch-configure) = a30c25267dec3642a010d7cb66fc98e8c5c0bdea
SHA1 (patch-configure) = 48245369d03cb41576ab18abb4e93cfc5c2c5267
SHA1 (patch-doc_Makefile) = 50ee7aaf74f8a5c439b11f141b5408322659543a
SHA1 (patch-libavformat_sctp.c) = 22bad9c7dc152aec3c60e0009899af241f495535
SHA1 (patch-libavutil_common.h) = d0f1093bc82567807b39dde990ee347f90a082c9

View file

@ -1,18 +1,20 @@
$NetBSD: patch-configure,v 1.6 2018/05/27 15:24:32 tsutsui Exp $
$NetBSD: patch-configure,v 1.7 2020/06/26 21:19:16 nia Exp $
Enable PIC on NetBSD, even on i386 to avoid text relocations.
Enable PIC and section_data_rel_ro on NetBSD, even on i386,
to avoid text relocations.
--- configure.orig 2018-02-12 00:29:18.000000000 +0000
--- configure.orig 2019-12-01 22:46:41.000000000 +0000
+++ configure
@@ -4940,6 +4940,7 @@ case $target_os in
@@ -4941,6 +4941,8 @@ case $target_os in
;;
netbsd)
disable symver
+ enable pic
+ enable section_data_rel_ro
oss_indev_extralibs="-lossaudio"
oss_outdev_extralibs="-lossaudio"
enabled gcc || check_ldflags -Wl,-zmuldefs
@@ -5360,10 +5361,13 @@ check_cc <<EOF && enable attribute_may_a
@@ -5361,10 +5363,13 @@ check_cc <<EOF && enable attribute_may_a
union { int x; } __attribute__((may_alias)) x;
EOF