Added some patches for ISO C90 compliance. Approved by jlam.
This commit is contained in:
parent
6d28018b11
commit
343aa370b0
3 changed files with 46 additions and 2 deletions
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.5 2005/04/13 16:49:57 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.6 2005/04/13 16:56:57 rillig Exp $
|
||||
|
||||
SHA1 (ufraw-0.4.tar.gz) = dd907171f6e3b0055499f108ba212465839d6f89
|
||||
RMD160 (ufraw-0.4.tar.gz) = e1a8106305fcc2b5405344cdca28c0fa503dcb66
|
||||
Size (ufraw-0.4.tar.gz) = 101409 bytes
|
||||
SHA1 (patch-aa) = 6c8be230181b4184bb0f81ffad7fb808e4eb35cf
|
||||
SHA1 (patch-aa) = 4268efb3c00ac5517f6c27d8bcd84d42293f6345
|
||||
SHA1 (patch-ab) = 5def994eac734aaf1edf02138e5af29f880b77f3
|
||||
SHA1 (patch-ac) = e34fe4f2f6878dbc24a401a5c6b95363b78c3d30
|
||||
|
|
29
graphics/gimp-ufraw/patches/patch-ab
Normal file
29
graphics/gimp-ufraw/patches/patch-ab
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-ab,v 1.1 2005/04/13 16:56:27 rillig Exp $
|
||||
|
||||
Needed for ISO C90 compliance.
|
||||
|
||||
--- ufraw_preview.c.orig Tue Feb 8 16:04:59 2005
|
||||
+++ ufraw_preview.c Tue Apr 12 10:14:48 2005
|
||||
@@ -288,7 +288,7 @@ void color_labels_set(colorLabels *l, fl
|
||||
|
||||
for (c=0; c<3; c++) {
|
||||
switch (l->format) {
|
||||
- case pixel_format: snprintf(buf1, max_name, "%3.f", data[c]); break;
|
||||
+ case pixel_format: snprintf(buf1, max_name, "%3.0f", data[c]); break;
|
||||
case percent_format:
|
||||
if (data[c]<10.0)
|
||||
snprintf(buf1, max_name, "%2.1f%%", data[c]);
|
||||
@@ -599,11 +599,11 @@ void reset_to_defaults(GtkWidget *widget
|
||||
|
||||
void spot_wb(GtkWidget *widget, gpointer user_data)
|
||||
{
|
||||
- widget = widget;
|
||||
- user_data = user_data;
|
||||
int xi, yi, c;
|
||||
float rgb[3];
|
||||
|
||||
+ widget = widget;
|
||||
+ user_data = user_data;
|
||||
if (freezeDialog) return;
|
||||
if (!spotOn) {
|
||||
ufraw_message(UFRAW_ERROR, "Select a spot on the preview image "
|
15
graphics/gimp-ufraw/patches/patch-ac
Normal file
15
graphics/gimp-ufraw/patches/patch-ac
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ac,v 1.1 2005/04/13 16:56:27 rillig Exp $
|
||||
|
||||
Needed for ISO C90 compliance.
|
||||
|
||||
--- ufraw_ufraw.c.orig Tue Feb 8 16:04:59 2005
|
||||
+++ ufraw_ufraw.c Tue Apr 12 10:56:20 2005
|
||||
@@ -123,7 +123,7 @@ int ufraw_config(image_data *image, cfg_
|
||||
for (i=0; i<cfg->curveCount; i++)
|
||||
cfg->curve[i].black = cfg_default.curve[0].black;
|
||||
}
|
||||
- if (cfg->exposureLoad==load_auto) cfg->exposure = nan("");
|
||||
+ if (cfg->exposureLoad==load_auto) cfg->exposure = strtod("NAN", (char**) NULL);
|
||||
|
||||
if (image==NULL) return UFRAW_SUCCESS;
|
||||
|
Loading…
Reference in a new issue