(pkgsrc)
-- Drop patch-aa, was commented as: ------ Until the source catches up to the current Perl API, we need PERL_POLLUTE to look like an older perl. ------ (upstream) -- Update 1.2.2 (imported to pkgsrc in 1999) to 1.4.1 -------------------------------------------------- 2000-09-19 Leif Hedstrom <leif@perldap.org> * Conn.pm (update): Bug fix to allow us to delete() an attribute, call update(), and then add new values (or the same values...) to the entry again. 2000-09-19 Leif Hedstrom <leif@perldap.org> * Entry.pm (DESTROY): Bug fix from daniel.hams@db.com (Daniel Hams) to avoid warnings from Apache and mod_perl. 2000-09-13 Leif Hedstrom <leif@perldap.org> * Utils.pm (askPassword): Oops, stupid typo here, should be "unless $prompt" of course... 2000-09-13 Leif Hedstrom <leif@perldap.org> * Entry.pm (isDeleted): Removed a test which made this function not working at all... :) 2000-09-13 Leif Hedstrom <leif@perldap.org> * Removed an if defined() to avoid warnings with Perl v5.6. 2000-06-24 Wolfram Schmidt <wschmidt@decefix.iao.fhg.de> * Entry.pm (FIRSTKEY): Fix bug for deleting all attributes and calling keys. 2000-05-30 Kevin McCarthy <kevin@perldap.org> * Makefile.PL: Added fix so API.xs compiles under Perl 5.6 (POLLUTE=>1) 2000-05-30 Leif Hedstrom <leif@perldap.org> * Lots of small fixes... 1999-09-07 Leif Hedstrom <leif@perldap.org> * API.xs (avref2charptrptr): Fixed potential core dump, if the argument passed wasn't a proper array. (avref2berptrptr): Ditto. 1999-09-06 Leif Hedstrom <leif@perldap.org> * Conn.pm (search): Removed $res and $resv, set the internal data element directly. (searchURL): Ditto. 1999-08-25 John Kristian <kristian@netscape.com> * Entry.pm (printLDIF): Bug fix. * LDIF.pm: Cleaned out memory leaks. 1999-08-24 Leif Hedstrom <leif@netscape.com> * Merged v1.3.x into trunk, tagged it as v1.4, and released it! 1999-08-19 Leif Hedstrom <leif@netscape.com> * Changed internal version numbering again, just called this plain v1.4. * Entry.pm (FIRSTKEY): Bug fix, we'd crap out if there are no attributes in the returned entry. (NEXTKEY): Ditto. 1999-08-18 Leif Hedstrom <leif@netscape.com> * Set version number to v1.4! Woohoo! Also tagged it as v1.3.4, last "development" release. 1999-08-17 Leif Hedstrom <leif@netscape.com> * Makefile.PL: Fixes for Windows/NT, cleaned out some code etc. (MY::postamble): Support for "make html". * MANIFEST: Updated with all new files etc. * test.pl: Renamed to oldtest.pl, to avoid "make test" to fail. 1999-08-16 Kevin McCarthy <kmccarth@perldap.org> and Leif Hedstrom * API.xs: Cleaned most all the memory allocation changes, we are changing it to use the LDAP_OPT_MEMALLOC_FN_PTRS option in the C-SDK instead (much cleaner!). (perldap_init): New function, set up the memory management handlers. This is called when the API module is loaded. (perldap_malloc): New function, our memory management method(s). (perldap_calloc): Ditto. (perldap_realloc): Ditto. (perldap_free): Ditto. 1999-08-16 Kevin McCarthy <kmccarth@perldap.org> * API.xs: Cleaned up prototypes, changed strdup() to use a Perl'ified version, change a number of free()'s to use Safefree. (ldap_value_free_perl): New function, similar to ldap_mods_free_perl(), to avoid memory problems (on NT and ActivePerl primarily). (StrDup): New function, to handle strdup() calls in a safe way. (ber_bvfree_perl): Ditto. (ber_bvecfree_perl): Ditto. 1999-08-15 Leif Hedstrom <leif@netscape.com> * API.xs (ldap_mods_free_perl): Modified version of ldap_mods_free(), which uses Perl native free method instead of the things from the LDAP SDK. This fixes some nasty issues with Windows/NT and ActiveState Perl. Woohoo!!! 1999-08-14 Leif Hedstrom <leif@netscape.com> and Kevin McCarthy * Entry.pm (setValues): Implemented bug fix for bug id 7131, where the "_save_" structures weren't set properly when using setValues(). 1999-08-14 Kevin McCarthy <kmccarth@perldap.org> * Conn.pm (update): Rewrote to optimize add/remove vs replace operations. Basically, we'll try to do whatever seems to be the smallest amount of work for the LDAP server now. 1999-08-13 Leif Hedstrom <leif@netscape.com> * Makefile.PL: Cleaned up code, and added support for linking in the missing libraries need for some missing symbols. 1999-08-13 Michelle Wyner <mwyner@netscape.com> * Entry.pm: Updated documentation, and cleaned it up. * Conn.pm: Ditto. 1999-08-12 Leif Hedstrom <leif@netscape.com> * Entry.pm (move): Changed name, was rename(), is now move(). 1999-08-10 Leif Hedstrom <leif@netscape.com> * Entry.pm (setValues): Renamed, used to be setValue(), which is now an alias to setValues(). (getValues): New method, to get the array of values. (STORE): Fixed tests around DN handling, making sure it's not treated as an array. I also optimized a couple of tests, since we now filter out "DN" earlier in the funtion(s). (attrModified): Ditto. (attrClean): Ditto. (unRemove): Ditto. (removeValue): Ditto. (addValue): Ditto. 1999-08-08 Leif Hedstrom <leif@netscape.com> and Kevin McCarthy * Entry.pm (setValue): Remove _delete_ flag, if set. * Conn.pm (close): Fixed memory leak, moved code from the DESTROY method over here. (DESTROY): Call the close() method. (getErrorCode): We now return LDAP_SUCCESS if there is no LDAP connection handle. (getErrorString): Ditto. * Entry.pm (STORE): Bug fix for large attribute sets. (attrModified): Ditto. (removeValue): Ditto. (addValue): Ditto. (EXISTS): Fix for bug 4368, cleaning up the code, and avoid the double calls. 1999-08-06 Leif Hedstrom <leif@netscape.com> and Kevin McCarthy * API.xs: Added some more tests around free() statements. These are most likely never triggered, but better safe than sorrow (and the overhead of testing this is insignificant). * Conn.pm (browse): Added this function, to make it easy to browse an entry. (compare): Compare an attribute value against a DN/entry, without having to do the search. * Entry.pm (removeValue): Fixed loop bug. (addValue): Ditto. (hasValue): Ditto. (matchValue): Fixed loop bug, and also missing normalization in half of the case statement. (rename): Added this new method, to rename attributes. (copy): Added, to copy attributes. * Merged v1.2.3 with v1.3 branch. 1999-08-06 Kevin McCarthy <kmccarth@perldap.org> * Entry.pm (addDNValue): Bug fix, index for norm was wrong. * Entry.pm (size): Optimzied for performance. 1999-07-25 Kevin McCarthy <kmccarth@perldap.org> * API.xs: Fixed memory allocation problems in parsing and generating the LDAPMods structure. 1999-06-22 Leif Hedstrom <leif@netscape.com> * Conn.pm (add): Fixed bug 3342, thanks to Kevin McCarthy for debugging this, and providing a patch. This fixes the problem with adding new entries that has binary data. 1999-03-23 Leif Hedstrom <leif@netscape.com> * Changed versioning numbers for all .pm files. 1999-03-22 Leif Hedstrom <leif@netscape.com> * Entry.pm: Removed all _self_obj_ stuff... * Conn.pm: Ditto. * Conn.pm: Cleanup in use statements, and "use strict". (search): Avoid warnings of uninitialized variables. (searchURL): Ditto. (modifyRDN): Bugfix, we did not update the appropriate DN in the self object (very minor...). * Entry.pm: Cleanup in use statements, and "use strict". (BEGIN): Added this initializer, to use the new LDIF module. (STORE): Fixed bug where we would not ignore the internal instance variables properly. * Utils.pm: Cleanup in all use statements, and "use strict". Also enforces the VERSION control feature. * Merged v1.2.1 to devel-branch-1_3, and tagged v1.3.1.
This commit is contained in:
parent
f6b3e926fd
commit
344d5b1136
3 changed files with 22 additions and 24 deletions
|
@ -1,19 +1,17 @@
|
|||
# $NetBSD: Makefile,v 1.27 2014/10/09 13:44:42 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.28 2015/04/27 06:05:02 mef Exp $
|
||||
#
|
||||
|
||||
DISTNAME= perldap-1.2.2
|
||||
PKGNAME= p5-LDAP-1.2.2
|
||||
PKGREVISION= 9
|
||||
DISTNAME= perldap-1.4.1
|
||||
# remove 'per' and 'ldap' part into uppercase (perldap -> LDAP)
|
||||
PKGNAME= p5-${DISTNAME:S/per//tu}
|
||||
CATEGORIES= devel perl5 databases
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_ALL:=directory/perldap/ancient/}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.mozilla.org/directory/perldap.html
|
||||
COMMENT= Perl5 module to build LDAP clients with perl
|
||||
LICENSE= mpl-1.0
|
||||
|
||||
WRKSRC= ${WRKDIR}/perldap
|
||||
PERL5_PACKLIST= auto/Mozilla/LDAP/API/.packlist
|
||||
|
||||
MAKE_ENV+= LDAPSDKDIR=${BUILDLINK_PREFIX.ldapsdk}
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2011/12/19 15:26:51 hiramatsu Exp $
|
||||
$NetBSD: distinfo,v 1.5 2015/04/27 06:05:02 mef Exp $
|
||||
|
||||
SHA1 (perldap-1.2.2.tgz) = 71511b4c2c246db1b520732c3797551d35c26ae7
|
||||
RMD160 (perldap-1.2.2.tgz) = 834941555053f0b101712d0caeb26c86c22c65d7
|
||||
Size (perldap-1.2.2.tgz) = 74058 bytes
|
||||
SHA1 (patch-API.xs) = 761a7f1aef91c8c017f921d39fc899cd59e9a15f
|
||||
SHA1 (patch-aa) = 430f7e2e41087ca3a3eba19b012ba4f96c0a1de3
|
||||
SHA1 (perldap-1.4.1.tar.gz) = f07feb41e0639c80cb186381566f3baf2ffcbc83
|
||||
RMD160 (perldap-1.4.1.tar.gz) = 6087ffafbc0099f7ef0f3d2a4540a37cbac933b5
|
||||
Size (perldap-1.4.1.tar.gz) = 93930 bytes
|
||||
SHA1 (patch-API.xs) = 3e5ecd7e2afeb82537be266c0920935d848b1512
|
||||
SHA1 (patch-aa) = f4f4aada03cc97490cb78a698585fca257ece666
|
||||
SHA1 (patch-typemap) = 9255e0d9c53d57ee90f27f5e544867ca51d92d8c
|
||||
|
|
|
@ -1,19 +1,19 @@
|
|||
$NetBSD: patch-API.xs,v 1.1 2011/12/19 15:26:51 hiramatsu Exp $
|
||||
$NetBSD: patch-API.xs,v 1.2 2015/04/27 06:05:02 mef Exp $
|
||||
|
||||
Modification to be built with Perl 5.14 API.
|
||||
|
||||
--- API.xs.orig 2011-12-19 09:59:44.000000000 +0000
|
||||
+++ API.xs
|
||||
@@ -107,7 +107,7 @@ char ** avref2charptrptr(SV *avref)
|
||||
--- API.xs.orig 2000-10-06 04:47:27.000000000 +0900
|
||||
+++ API.xs 2015-02-08 22:52:28.000000000 +0900
|
||||
@@ -195,7 +195,7 @@ avref2charptrptr(SV *avref)
|
||||
for (ix_av = 0;ix_av <= avref_arraylen;ix_av++)
|
||||
{
|
||||
current_val = av_fetch((AV *)SvRV(avref),ix_av,0);
|
||||
- tmp_cpp[ix_av] = strdup(SvPV(*current_val,na));
|
||||
+ tmp_cpp[ix_av] = strdup(SvPV(*current_val,PL_na));
|
||||
- tmp_cpp[ix_av] = StrDup(SvPV(*current_val,na));
|
||||
+ tmp_cpp[ix_av] = StrDup(SvPV(*current_val,PL_na));
|
||||
}
|
||||
tmp_cpp[ix_av] = NULL;
|
||||
|
||||
@@ -135,7 +135,7 @@ struct berval ** avref2berptrptr(SV *avr
|
||||
@@ -226,7 +226,7 @@ avref2berptrptr(SV *avref)
|
||||
New(1,tmp_ber[ix_av],1,struct berval);
|
||||
current_val = av_fetch((AV *)SvRV(avref),ix_av,0);
|
||||
|
||||
|
@ -22,7 +22,7 @@ Modification to be built with Perl 5.14 API.
|
|||
val_len = SvCUR(*current_val);
|
||||
|
||||
Newz(1,tmp2,val_len+1,char);
|
||||
@@ -272,7 +272,7 @@ LDAPMod *parse1mod(SV *ldap_value_ref,ch
|
||||
@@ -368,7 +368,7 @@ parse1mod(SV *ldap_value_ref,char *ldap_
|
||||
} else {
|
||||
if (cont)
|
||||
return NULL;
|
||||
|
@ -31,16 +31,16 @@ Modification to be built with Perl 5.14 API.
|
|||
{
|
||||
if (ldap_add_func != 1)
|
||||
{
|
||||
@@ -289,7 +289,7 @@ LDAPMod *parse1mod(SV *ldap_value_ref,ch
|
||||
@@ -385,7 +385,7 @@ parse1mod(SV *ldap_value_ref,char *ldap_
|
||||
ldap_current_mod->mod_op = LDAP_MOD_REPLACE;
|
||||
}
|
||||
New(1,ldap_current_mod->mod_values,2,char *);
|
||||
- ldap_current_mod->mod_values[0] = strdup(SvPV(ldap_value_ref,na));
|
||||
+ ldap_current_mod->mod_values[0] = strdup(SvPV(ldap_value_ref,PL_na));
|
||||
- ldap_current_mod->mod_values[0] = StrDup(SvPV(ldap_value_ref,na));
|
||||
+ ldap_current_mod->mod_values[0] = StrDup(SvPV(ldap_value_ref,PL_na));
|
||||
ldap_current_mod->mod_values[1] = NULL;
|
||||
}
|
||||
}
|
||||
@@ -1528,7 +1528,7 @@ ldap_url_parse(url)
|
||||
@@ -1718,7 +1718,7 @@ ldap_url_parse(url)
|
||||
hv_store(FullHash,options_key,strlen(options_key),options,0);
|
||||
ldap_free_urldesc(realcomp);
|
||||
} else {
|
||||
|
|
Loading…
Reference in a new issue