Make it gcc4 friendly.
Cast args to ctype-macros to unsigned char.
This commit is contained in:
parent
0e42d0963f
commit
3496839abb
3 changed files with 32 additions and 1 deletions
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.5 2005/02/23 23:12:04 agc Exp $
|
||||
$NetBSD: distinfo,v 1.6 2006/06/02 09:08:15 martin Exp $
|
||||
|
||||
SHA1 (xmahjongg-3.6.1.tar.gz) = 35e380e53412568e6af7f4fcc1677693f52fc60e
|
||||
RMD160 (xmahjongg-3.6.1.tar.gz) = acfc0161322b22296639dff313bae8d57e012618
|
||||
Size (xmahjongg-3.6.1.tar.gz) = 462833 bytes
|
||||
SHA1 (patch-aa) = 5305cfb0c0c8c0fcc507bc3730043331255a94a5
|
||||
SHA1 (patch-ab) = d3c2574c8de7e85c8e38670017d0eda64fe3b0be
|
||||
|
|
13
games/xmahjongg/patches/patch-aa
Normal file
13
games/xmahjongg/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.5 2006/06/02 09:08:15 martin Exp $
|
||||
|
||||
--- permstr.hh.orig 2006-06-02 09:57:39.000000000 +0200
|
||||
+++ permstr.hh 2006-06-02 09:57:50.000000000 +0200
|
||||
@@ -93,7 +93,7 @@ operator!=(const char *a, PermString b)
|
||||
inline int
|
||||
hashcode(PermString s)
|
||||
{
|
||||
- return (int)(s.cc());
|
||||
+ return (int)(intptr_t)(s.cc());
|
||||
}
|
||||
|
||||
#endif
|
16
games/xmahjongg/patches/patch-ab
Normal file
16
games/xmahjongg/patches/patch-ab
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ab,v 1.4 2006/06/02 09:08:15 martin Exp $
|
||||
|
||||
--- giftoc.c.orig 1999-08-15 21:03:06.000000000 +0200
|
||||
+++ giftoc.c 2006-06-02 11:02:19.000000000 +0200
|
||||
@@ -192,9 +192,9 @@ or: giftoc -makename [OPTIONS] FILE [
|
||||
sin = strrchr(file_name, PATHNAME_SEPARATOR) + 1;
|
||||
if (!sin) sin = file_name;
|
||||
sout = rec_name = (char *)fmalloc(strlen(sin) + 2);
|
||||
- if (isdigit(*sin)) *sout++ = 'N';
|
||||
+ if (isdigit((unsigned char)*sin)) *sout++ = 'N';
|
||||
for (; *sin; sin++, sout++)
|
||||
- if (isalnum(*sin))
|
||||
+ if (isalnum((unsigned char)*sin))
|
||||
*sout = *sin;
|
||||
else
|
||||
*sout = '_';
|
Loading…
Reference in a new issue