* Fix PLIST when "ldap" is enabled in PKG_OPTIONS.
* Install README.LDAP when "ldap" is enabled in PKG_OPTIONS. * Fix build problem when "kerberos" is enabled in PKG_OPTIONS. Bump PKGREVISION since default PLIST has changed.
This commit is contained in:
parent
bfa30968e5
commit
34ccea250c
6 changed files with 53 additions and 21 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.123 2010/09/10 17:11:27 spz Exp $
|
||||
# $NetBSD: Makefile,v 1.124 2010/09/21 03:05:27 taca Exp $
|
||||
#
|
||||
|
||||
DISTNAME= sudo-1.7.4p4
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.courtesan.com/sudo/dist/ \
|
||||
ftp://ftp.courtesan.com/pub/sudo/ \
|
||||
|
@ -49,6 +50,6 @@ INSTALLATION_DIRS+= ${DOCDIR} ${EGDIR}
|
|||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/UPGRADE ${DESTDIR}${PREFIX}/${DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/sudoers ${DESTDIR}${PREFIX}/${EGDIR}/sudoers
|
||||
${INSTALL_DATA} ${WRKSRC}/README* ${DESTDIR}${PREFIX}/${DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${PREFIX}/${DOCDIR}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2010/09/10 17:11:27 spz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2010/09/21 03:05:27 taca Exp $
|
||||
bin/sudo
|
||||
bin/sudoedit
|
||||
bin/sudoreplay
|
||||
|
@ -15,10 +15,14 @@ share/doc/sudo/HISTORY
|
|||
share/doc/sudo/LICENSE
|
||||
share/doc/sudo/NEWS
|
||||
share/doc/sudo/README
|
||||
share/doc/sudo/README.LDAP
|
||||
${PLIST.ldap}share/doc/sudo/README.LDAP
|
||||
share/doc/sudo/TROUBLESHOOTING
|
||||
share/doc/sudo/UPGRADE
|
||||
share/doc/sudo/sample.pam
|
||||
share/doc/sudo/sample.sudoers
|
||||
share/doc/sudo/sample.syslog.conf
|
||||
${PLIST.ldap}share/doc/sudo/schema.ActiveDirectory
|
||||
${PLIST.ldap}share/doc/sudo/schema.OpenLDAP
|
||||
${PLIST.ldap}share/doc/sudo/schema.iPlanet
|
||||
${PLIST.ldap}share/doc/sudo/sudoers2ldif
|
||||
share/examples/sudo/sudoers
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.65 2010/09/10 17:11:27 spz Exp $
|
||||
$NetBSD: distinfo,v 1.66 2010/09/21 03:05:27 taca Exp $
|
||||
|
||||
SHA1 (sudo-1.7.4p4.tar.gz) = c873f509f80d5722989a912a42a61ad27b71453f
|
||||
RMD160 (sudo-1.7.4p4.tar.gz) = 3b5eb69b4317c72def0e811c58a24df8c9c1c892
|
||||
Size (sudo-1.7.4p4.tar.gz) = 963663 bytes
|
||||
SHA1 (patch-aa) = 05f2f71bf7393cfd878c0a6c14d2d5a79177daac
|
||||
SHA1 (patch-af) = 86b9bd17dbfe1951c48055cd191d3071766385c6
|
||||
SHA1 (patch-ag) = 7a64eed90eb88f10280e876a5a6beaab2e12e7c6
|
||||
SHA1 (patch-aa) = 5435f1ebf6faa0381d193a9a560a3752af5c9c4a
|
||||
SHA1 (patch-af) = 389af9aca76d7286c2e981573c56358846f8d0ca
|
||||
SHA1 (patch-ag) = 853232cc5fde6808562cc7dd6f5770069bdeae3f
|
||||
|
|
|
@ -1,4 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.24 2010/09/10 17:11:27 spz Exp $
|
||||
$NetBSD: patch-aa,v 1.25 2010/09/21 03:05:27 taca Exp $
|
||||
|
||||
* Fix libtools's link option.
|
||||
* Prevent to install sudoers files and directory.
|
||||
* Use standard instal(8) option instead of shell wrapper.
|
||||
|
||||
--- Makefile.in.orig 2010-09-03 21:43:57.000000000 +0000
|
||||
+++ Makefile.in
|
||||
|
|
|
@ -1,4 +1,11 @@
|
|||
$NetBSD: patch-af,v 1.25 2010/09/10 17:11:27 spz Exp $
|
||||
$NetBSD: patch-af,v 1.26 2010/09/21 03:05:27 taca Exp $
|
||||
|
||||
* Add "--with-nbsdops" option, NetBSD standard options.
|
||||
* Link with util(3) in the case of DragonFly, too.
|
||||
* When specified "--with-kerb5" option, test existence of several functions
|
||||
even if there is krb5-config. krb5-config dosen't give all definitions for
|
||||
functions (HAVE_KRB5_*).
|
||||
* Remove setting sysconfdir to "/etc".
|
||||
|
||||
--- configure.in.orig 2010-09-06 12:03:33.000000000 +0000
|
||||
+++ configure.in
|
||||
|
@ -30,15 +37,15 @@ $NetBSD: patch-af,v 1.25 2010/09/10 17:11:27 spz Exp $
|
|||
;;
|
||||
esac
|
||||
])
|
||||
@@ -2317,6 +2329,8 @@ if test ${with_kerb5-'no'} != "no"; then
|
||||
if test -n "$KRB5CONFIG"; then
|
||||
AC_DEFINE(HAVE_KERB5)
|
||||
AUTH_OBJS="$AUTH_OBJS kerb5.o"
|
||||
+ fi
|
||||
+ if test ${with_kerb5-'no'} != "no"; then
|
||||
CPPFLAGS="$CPPFLAGS `krb5-config --cflags`"
|
||||
SUDO_LIBS="$SUDO_LIBS `krb5-config --libs`"
|
||||
dnl
|
||||
@@ -2370,6 +2382,8 @@ if test ${with_kerb5-'no'} != "no" -a -z
|
||||
AC_CHECK_LIB(krb5support, main, [SUDO_LIBS="${SUDO_LIBS} -lkrb5support"])
|
||||
])
|
||||
AUTH_OBJS="$AUTH_OBJS kerb5.o"
|
||||
+fi
|
||||
+if test ${with_kerb5-'no'} != "no"; then
|
||||
_LIBS="$LIBS"
|
||||
LIBS="${LIBS} ${SUDO_LIBS}"
|
||||
AC_CHECK_FUNCS(krb5_verify_user krb5_init_secure_context)
|
||||
@@ -2798,7 +2812,6 @@ test "$libexecdir" = '${exec_prefix}/lib
|
||||
test "$includedir" = '${prefix}/include' && includedir='$(prefix)/include'
|
||||
test "$datarootdir" = '${prefix}/share' && datarootdir='$(prefix)/share'
|
||||
|
|
|
@ -1,4 +1,11 @@
|
|||
$NetBSD: patch-ag,v 1.16 2010/09/10 17:11:27 spz Exp $
|
||||
$NetBSD: patch-ag,v 1.17 2010/09/21 03:05:27 taca Exp $
|
||||
|
||||
* Add "--with-nbsdops" option, NetBSD standard options.
|
||||
* Link with util(3) in the case of DragonFly, too.
|
||||
* When specified "--with-kerb5" option, test existence of several functions
|
||||
even if there is krb5-config. krb5-config dosen't give all definitions for
|
||||
functions (HAVE_KRB5_*).
|
||||
* Remove setting sysconfdir to "/etc".
|
||||
|
||||
--- configure.orig 2010-09-06 12:03:39.000000000 +0000
|
||||
+++ configure
|
||||
|
@ -51,7 +58,16 @@ $NetBSD: patch-ag,v 1.16 2010/09/10 17:11:27 spz Exp $
|
|||
;;
|
||||
esac
|
||||
|
||||
@@ -18468,7 +18485,6 @@ test "$libexecdir" = '${exec_prefix}/lib
|
||||
@@ -17124,6 +17141,8 @@ fi
|
||||
fi
|
||||
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
AUTH_OBJS="$AUTH_OBJS kerb5.o"
|
||||
+fi
|
||||
+if test ${with_kerb5-'no'} != "no"; then
|
||||
_LIBS="$LIBS"
|
||||
LIBS="${LIBS} ${SUDO_LIBS}"
|
||||
for ac_func in krb5_verify_user krb5_init_secure_context
|
||||
@@ -18468,7 +18487,6 @@ test "$libexecdir" = '${exec_prefix}/lib
|
||||
test "$includedir" = '${prefix}/include' && includedir='$(prefix)/include'
|
||||
test "$datarootdir" = '${prefix}/share' && datarootdir='$(prefix)/share'
|
||||
test "$docdir" = '${datarootdir}/doc/${PACKAGE_TARNAME}' && docdir='$(datarootdir)/doc/$(PACKAGE_TARNAME)'
|
||||
|
|
Loading…
Reference in a new issue