Updated security/john to 1.7.0.1
The following changes have been made between John 1.7 and 1.7.0.1: * Minor bug and portability fixes. * Better handling of certain uncommon scenarios and improper uses of John. * Bonus: "Keyboard" cracker included in the default john.conf (john.ini) that will try sequences of adjacent keys on a keyboard as passwords. The following major changes have been made since John 1.6: * Bitslice DES code for x86 with MMX: more than twice faster than older non-bitslice MMX code. * Bitsliced the LM hash code as well: now several times faster. * Significant improvements to the generic bitslice DES code: +20% on RISC. * PowerPC G4+ AltiVec support (Mac OS X and Linux): effective 128-bitness for bitslice DES, resulting in huge speedups. * First attempt at generic vectorization support for bitslice DES. * Two MD5 hashes at a time for extra ILP on RISC: up to +80% on Alpha EV5+. * Generic Blowfish x86 assembly code in addition to the original Pentium version: +15% on the Pentium Pro family (up to and including Pentium III), +20% on AMD K6 (Pentium 4 and newer AMD CPUs are more happy running the original Pentium code for Blowfish). * Verbose logging of events to the global or a session-specific log file. * Better idle priority emulation with POSIX.1b (POSIX.4) scheduling calls. * System-wide installation support for *BSD ports and Linux distributions. * AIX, DU/Tru64 C2, HP-UX tcb files support in unshadow. * New make targets for Linux/x86-64, Linux/PowerPC, FreeBSD/Alpha, OpenBSD/x86-64, OpenBSD/Alpha, OpenBSD/SPARC, OpenBSD/SPARC64, OpenBSD/PowerPC, OpenBSD/PA-RISC, OpenBSD/VAX, NetBSD/VAX, Solaris/SPARC64, Mac OS X (PowerPC and x86), SCO, BeOS. * Bug and portability fixes, and new bugs. * Bonus: "Strip" cracker included in the default john.conf (john.ini).
This commit is contained in:
parent
d2f8b44e57
commit
34d56ce88a
5 changed files with 92 additions and 31 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.12 2005/11/03 20:41:43 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2006/03/14 10:17:25 martti Exp $
|
||||
#
|
||||
|
||||
DISTNAME= john-1.6
|
||||
PKGREVISION= 1
|
||||
DISTNAME= john-1.7.0.1
|
||||
#PKGREVISION= 1
|
||||
CATEGORIES= security textproc
|
||||
MASTER_SITES= http://www.openwall.com/john/
|
||||
MASTER_SITES= http://www.openwall.com/john/e/
|
||||
|
||||
MAINTAINER= DawS@irc.pl
|
||||
HOMEPAGE= http://www.openwall.com/john/
|
||||
|
@ -34,17 +34,30 @@ BUILD_TARGET= generic
|
|||
|
||||
INSTALLATION_DIRS= bin
|
||||
|
||||
SUBST_CLASSES+= john
|
||||
SUBST_STAGE.john= pre-build
|
||||
SUBST_FILES.john= src/params.h
|
||||
SUBST_SED.john= -e "s+@PREFIX@+${PREFIX}+g"
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/run/john ${PREFIX}/bin
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/john
|
||||
${INSTALL_DATA} ${WRKSRC}/run/all.chr ${PREFIX}/share/john
|
||||
${INSTALL_DATA} ${WRKSRC}/run/alpha.chr ${PREFIX}/share/john
|
||||
${INSTALL_DATA} ${WRKSRC}/run/digits.chr ${PREFIX}/share/john
|
||||
${INSTALL_DATA} ${WRKSRC}/run/john.ini ${PREFIX}/share/john
|
||||
${INSTALL_DATA} ${WRKSRC}/run/mailer ${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/run/password.lst ${PREFIX}/share/john
|
||||
${LN} -sf ${PREFIX}/bin/john ${PREFIX}/bin/unafs
|
||||
${LN} -sf ${PREFIX}/bin/john ${PREFIX}/bin/unique
|
||||
${LN} -sf ${PREFIX}/bin/john ${PREFIX}/bin/unshadow
|
||||
# programs and scripts
|
||||
${INSTALL_PROGRAM} ${WRKSRC:Q}/run/john ${PREFIX:Q}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC:Q}/run/mailer ${PREFIX:Q}/bin
|
||||
|
||||
# data directory
|
||||
${INSTALL_DATA_DIR} ${PREFIX:Q}/share/john
|
||||
|
||||
# configuration file
|
||||
${INSTALL_DATA} ${WRKSRC:Q}/run/john.conf ${PREFIX:Q}/share/john
|
||||
|
||||
# symbolic links
|
||||
.for i in unafs unique unshadow
|
||||
${LN} -sf ${PREFIX:Q}/bin/john ${PREFIX:Q}/bin/${i:Q}
|
||||
.endfor
|
||||
|
||||
# data files
|
||||
.for i in all.chr alnum.chr alpha.chr digits.chr lanman.chr password.lst
|
||||
${INSTALL_DATA} ${WRKSRC:Q}/run/${i:Q} ${PREFIX:Q}/share/john
|
||||
.endfor
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,11 +1,14 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2001/11/01 01:16:45 zuntum Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2006/03/14 10:17:25 martti Exp $
|
||||
bin/john
|
||||
bin/mailer
|
||||
bin/unafs
|
||||
bin/unique
|
||||
bin/unshadow
|
||||
share/john/all.chr
|
||||
share/john/alnum.chr
|
||||
share/john/alpha.chr
|
||||
share/john/digits.chr
|
||||
share/john/john.ini
|
||||
share/john/john.conf
|
||||
share/john/lanman.chr
|
||||
share/john/password.lst
|
||||
@dirrm share/john
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/11/03 20:41:43 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.7 2006/03/14 10:17:25 martti Exp $
|
||||
|
||||
SHA1 (john-1.6.tar.gz) = b49d371496b8ba5e439665b83190b1e4d4640bea
|
||||
RMD160 (john-1.6.tar.gz) = 5a34e7f57b190313cc0773e996f6eed74f28d160
|
||||
Size (john-1.6.tar.gz) = 497341 bytes
|
||||
SHA1 (patch-aa) = 3a99923611742807ca7258bd880244b9a252b0ff
|
||||
SHA1 (john-1.7.0.1.tar.gz) = 903b0e47772087225285e8b2f9937034437ad7b6
|
||||
RMD160 (john-1.7.0.1.tar.gz) = c2ceee23590989942324af9783b5e92f86a5a284
|
||||
Size (john-1.7.0.1.tar.gz) = 802325 bytes
|
||||
SHA1 (patch-aa) = 5daecad929d2fc3819354f969f885421b4077497
|
||||
SHA1 (patch-ab) = 331fa2333860879edabdbf1beeb3323d303406ec
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-aa,v 1.3 2005/11/03 20:41:43 rillig Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2006/03/14 10:17:25 martti Exp $
|
||||
|
||||
--- src/Makefile.orig 1998-12-03 11:29:50.000000000 +1100
|
||||
+++ src/Makefile
|
||||
@@ -3,21 +3,21 @@
|
||||
# Copyright (c) 1996-98 by Solar Designer
|
||||
--- src/Makefile.orig 2006-01-12 04:30:50.000000000 +0200
|
||||
+++ src/Makefile 2006-03-14 08:38:08.000000000 +0200
|
||||
@@ -3,10 +3,10 @@
|
||||
# Copyright (c) 1996-2005 by Solar Designer
|
||||
#
|
||||
|
||||
-CPP = gcc
|
||||
|
@ -17,7 +17,8 @@ $NetBSD: patch-aa,v 1.3 2005/11/03 20:41:43 rillig Exp $
|
|||
CP = cp
|
||||
LN = ln -sf
|
||||
RM = rm -f
|
||||
SED = sed
|
||||
@@ -15,11 +15,11 @@
|
||||
PERL = perl
|
||||
NULL = /dev/null
|
||||
CPPFLAGS = -E
|
||||
-CFLAGS = -c -Wall -O2 -fomit-frame-pointer
|
||||
|
@ -27,8 +28,8 @@ $NetBSD: patch-aa,v 1.3 2005/11/03 20:41:43 rillig Exp $
|
|||
-OPT_NORMAL = -funroll-loops
|
||||
-OPT_INLINE = -finline-functions
|
||||
+LDFLAGS += -s
|
||||
+OPT_NORMAL =
|
||||
+OPT_NORMAL =
|
||||
+OPT_INLINE =
|
||||
|
||||
JOHN_VERSION = 1.6
|
||||
JOHN_ARCHIVE = john-$(JOHN_VERSION)
|
||||
JOHN_OBJS_MINIMAL = \
|
||||
DES_fmt.o DES_std.o DES_bs.o \
|
||||
|
|
43
security/john/patches/patch-ab
Normal file
43
security/john/patches/patch-ab
Normal file
|
@ -0,0 +1,43 @@
|
|||
$NetBSD: patch-ab,v 1.1 2006/03/14 10:17:25 martti Exp $
|
||||
|
||||
--- src/params.h.orig 2006-03-14 09:16:37.000000000 +0200
|
||||
+++ src/params.h 2006-03-14 09:21:51.000000000 +0200
|
||||
@@ -49,15 +49,15 @@
|
||||
* notes above.
|
||||
*/
|
||||
#ifndef JOHN_SYSTEMWIDE
|
||||
-#define JOHN_SYSTEMWIDE 0
|
||||
+#define JOHN_SYSTEMWIDE 1
|
||||
#endif
|
||||
|
||||
#if JOHN_SYSTEMWIDE
|
||||
#ifndef JOHN_SYSTEMWIDE_EXEC /* please refer to the notes above */
|
||||
-#define JOHN_SYSTEMWIDE_EXEC "/usr/libexec/john"
|
||||
+#define JOHN_SYSTEMWIDE_EXEC "@PREFIX@/bin"
|
||||
#endif
|
||||
#ifndef JOHN_SYSTEMWIDE_HOME
|
||||
-#define JOHN_SYSTEMWIDE_HOME "/usr/share/john"
|
||||
+#define JOHN_SYSTEMWIDE_HOME "@PREFIX@/share/john"
|
||||
#endif
|
||||
#define JOHN_PRIVATE_HOME "~/.john"
|
||||
#endif
|
||||
@@ -101,8 +101,8 @@
|
||||
/*
|
||||
* File names.
|
||||
*/
|
||||
-#define CFG_FULL_NAME "$JOHN/john.conf"
|
||||
-#define CFG_ALT_NAME "$JOHN/john.ini"
|
||||
+#define CFG_FULL_NAME "@PREFIX@/share/john/john.conf"
|
||||
+#define CFG_ALT_NAME "@PREFIX@/share/john/john.ini"
|
||||
#if JOHN_SYSTEMWIDE
|
||||
#define CFG_PRIVATE_FULL_NAME JOHN_PRIVATE_HOME "/john.conf"
|
||||
#define CFG_PRIVATE_ALT_NAME JOHN_PRIVATE_HOME "/john.ini"
|
||||
@@ -116,7 +116,7 @@
|
||||
#endif
|
||||
#define LOG_SUFFIX ".log"
|
||||
#define RECOVERY_SUFFIX ".rec"
|
||||
-#define WORDLIST_NAME "$JOHN/password.lst"
|
||||
+#define WORDLIST_NAME "@PREFIX@/share/john/password.lst"
|
||||
|
||||
/*
|
||||
* Configuration file section names.
|
Loading…
Reference in a new issue