Adding patch from perl-5.10.1 upstream to fix "Unkown error bug" described

in http://rt.perl.org/rt3/Public/Bug/Display.html?id=49472

Bumping PKGREVISION
This commit is contained in:
sno 2009-05-02 19:23:44 +00:00
parent fb030b7205
commit 34fa524bc8
3 changed files with 48 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.149 2009/02/11 15:46:28 joerg Exp $
# $NetBSD: Makefile,v 1.150 2009/05/02 19:23:44 sno Exp $
DISTNAME= perl-5.10.0
CATEGORIES= lang devel perl5
PKGREVISION= 5
PKGREVISION= 6
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S,/modules/by-module/$,/src/,}
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX}

View file

@ -1,10 +1,11 @@
$NetBSD: distinfo,v 1.58 2009/05/02 18:42:32 sno Exp $
$NetBSD: distinfo,v 1.59 2009/05/02 19:23:44 sno Exp $
SHA1 (perl-5.10.0.tar.gz) = adf73606dd5248af7ccdd735bcaa0e628ea75b3c
RMD160 (perl-5.10.0.tar.gz) = c6614fc99a162790a703f91085b24a60af903ba2
Size (perl-5.10.0.tar.gz) = 15595020 bytes
SHA1 (patch-aa) = 5bd44a8076cf27e2deac52240af7f3898865859c
SHA1 (patch-ab) = e32427327192f023477b16f29bc55fdf4f057410
SHA1 (patch-ac) = e6dd7287c1d85a59953610406c5fc1f52c712fb7
SHA1 (patch-ah) = 1d2f4049dcc8dafcd0eafad36a74531dc7f305c9
SHA1 (patch-ai) = 5abdbbddcba79088996056ab88a34db5fcd16b01
SHA1 (patch-aq) = 3ece22678e3e6dcd3cf641e6389ff203cbe351b9

View file

@ -0,0 +1,44 @@
$NetBSD: patch-ac,v 1.12 2009/05/02 19:23:45 sno Exp $
--- toke.c.orig 2009-05-01 10:57:15.000000000 +0000
+++ toke.c 2009-05-01 10:57:49.000000000 +0000
@@ -692,6 +692,7 @@
#else
parser->nexttoke = 0;
#endif
+ parser->error_count = oparser ? oparser->error_count : 0;
parser->copline = NOLINE;
parser->lex_state = LEX_NORMAL;
parser->expect = XSTATE;
--- t/comp/require.t.orig 2009-05-01 10:58:10.000000000 +0000
+++ t/comp/require.t 2009-05-01 10:59:36.000000000 +0000
@@ -15,7 +15,7 @@
my $Is_EBCDIC = (ord('A') == 193) ? 1 : 0;
my $Is_UTF8 = (${^OPEN} || "") =~ /:utf8/;
-my $total_tests = 49;
+my $total_tests = 50;
if ($Is_EBCDIC || $Is_UTF8) { $total_tests -= 3; }
print "1..$total_tests\n";
@@ -258,6 +258,20 @@
}
}
+# [perl #49472] Attributes + Unkown Error
+
+{
+ do_require
+ 'use strict;sub MODIFY_CODE_ATTRIBUTE{} sub f:Blah {$nosuchvar}';
+ my $err = $@;
+ $err .= "\n" unless $err =~ /\n$/;
+ unless ($err =~ /Global symbol "\$nosuchvar" requires /) {
+ $err =~ s/^/# /mg;
+ print "${err}not ";
+ }
+ print "ok ", ++$i, " [perl #49472]\n";
+}
+
##########################################
# What follows are UTF-8 specific tests. #
# Add generic tests before this point. #