Correct a bad assumption in machine.sh. It's assuming MACHINE_ARCH is equiv to
MACHINE on *BSD platforms which isn't true for cases like macppc where it's arch is actually powerpc. So on *BSD run uname -p to get MACHINE_ARCH.
This commit is contained in:
parent
e5ec8ef1e5
commit
3516754c8c
2 changed files with 14 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2001/10/18 21:41:06 sjg Exp $
|
||||
$NetBSD: distinfo,v 1.4 2002/02/18 10:10:21 jmc Exp $
|
||||
|
||||
SHA1 (bmake-3.1.12.tar.gz) = 423c89cf5054b5bec1af4fff7c56dc089fb9f8f3
|
||||
Size (bmake-3.1.12.tar.gz) = 299528 bytes
|
||||
SHA1 (patch-aa) = d1a2e3c5638dcf657fb91019764987e3160a2a23
|
||||
SHA1 (patch-ab) = 8d98639f68138c9de21985197a346823c448bced
|
||||
|
|
12
devel/bmake/patches/patch-ab
Normal file
12
devel/bmake/patches/patch-ab
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ab,v 1.1 2002/02/18 10:10:22 jmc Exp $
|
||||
|
||||
--- machine.sh.orig Mon Feb 18 10:05:46 2002
|
||||
+++ machine.sh Mon Feb 18 10:06:09 2002
|
||||
@@ -38,6 +38,7 @@
|
||||
case $OS in
|
||||
*BSD)
|
||||
MACHINE=$OS$OSMAJOR.$machine
|
||||
+ MACHINE_ARCH=`uname -p 2>/dev/null`
|
||||
;;
|
||||
SunOS)
|
||||
MACHINE=$OS$OSMAJOR
|
Loading…
Reference in a new issue