Initial import of ncview:

Visual browser for netCDF format files
This commit is contained in:
jtb 2001-02-09 23:41:34 +00:00
parent 234996013b
commit 35605d0c3a
8 changed files with 102 additions and 0 deletions

24
graphics/ncview/Makefile Normal file
View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/02/09 23:41:34 jtb Exp $
DISTNAME= ncview-1.92b
CATEGORIES= graphics
MASTER_SITES= ftp://cirrus.ucsd.edu/pub/ncview/
MAINTAINER= jtb@netbsd.org
HOMEPAGE= http://meteora.ucsd.edu/~pierce/ncview_home_page.html
DEPENDS+= netcdf>=3.4:../../devel/netcdf
DEPENDS+= udunits>=1.11.7:../../math/udunits
GNU_CONFIGURE= yes
USE_XAW= yes
USE_X11BASE= yes
EVAL_PREFIX+= NETCDF=netcdf UDUNITS=udunits
CONFIGURE_ARGS+= --with-netcdf_incdir=${NETCDF}/include
CONFIGURE_ARGS+= --with-netcdf_libdir=${NETCDF}/lib
CONFIGURE_ARGS+= --with-udunits_incdir=${UDUNITS}/include
CONFIGURE_ARGS+= --with-udunits_libdir=${UDUNITS}/lib
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 2001/02/09 23:41:34 jtb Exp $
MD5 (ncview-1.92b.tar.gz) = fd835fa2e5f5eae3e59f8b4f46b18301

View file

@ -0,0 +1,4 @@
$NetBSD: patch-sum,v 1.1.1.1 2001/02/09 23:41:34 jtb Exp $
MD5 (patch-aa) = 95a36d17289da147390b13adb6438841
MD5 (patch-ab) = 4f9674bdbe559349dee2fb1e0f93d294

View file

@ -0,0 +1,31 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/02/09 23:41:34 jtb Exp $
--- configure.orig Thu Nov 16 18:08:36 2000
+++ configure
@@ -1229,7 +1229,7 @@
# It would also be nice to do this for all -L options, not just this one.
if test -n "$x_libraries"; then
- X_LIBS="$X_LIBS -L$x_libraries"
+ X_LIBS="$X_LIBS -R$x_libraries -L$x_libraries"
# For Solaris; some versions of Sun CC require a space after -R and
# others require no space. Words are not sufficient . . . .
case "`(uname -sr) 2>/dev/null`" in
@@ -1764,7 +1764,7 @@
# Check for libraries that X11R6 Xt/Xaw programs need.
ac_save_LDFLAGS="$LDFLAGS"
- test -n "$x_libraries" && LDFLAGS="$LDFLAGS -L$x_libraries"
+ test -n "$x_libraries" && LDFLAGS="$LDFLAGS -R$x_libraries -L$x_libraries"
# SM needs ICE to (dynamically) link under SunOS 4.x (so we have to
# check for ICE first), but we must link in the order -lSM -lICE or
# we get undefined symbols. So assume we have SM if we have ICE.
@@ -2462,7 +2462,7 @@
if test $do_udunits = true; then
DO_UDUNITS_LINE="INC_UDUNITS = -DINC_UDUNITS"
DO_UDUNITS_INCDIR="UDUNITSINCDIR = -I$UDUNITS_INCDIR"
- DO_UDUNITS_LIBDIR="UDUNITSLIBDIR = -L$UDUNITS_LIBDIR"
+ DO_UDUNITS_LIBDIR="UDUNITSLIBDIR = -Wl,-R$UDUNITS_LIBDIR -L$UDUNITS_LIBDIR"
DO_UDUNITS_LIBNAME="UDUNITSLIB = -l$UDUNITS_LIBNAME"
else
echo "************************************************************************"

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ab,v 1.1.1.1 2001/02/09 23:41:35 jtb Exp $
--- Makefile.in.orig Sat Dec 9 20:27:09 2000
+++ Makefile.in
@@ -8,7 +8,7 @@
################################################################
NETCDFINCDIR = -I@NETCDF_INCDIR@
NETCDFLIB = -l@NETCDF_LIBNAME@
-NETCDFLIBDIR = -L@NETCDF_LIBDIR@
+NETCDFLIBDIR = -Wl,-R@NETCDF_LIBDIR@ -L@NETCDF_LIBDIR@
################################################################
## If you DON'T want the udunits support, which will format
@@ -133,5 +133,5 @@
@echo "Installing manual in directory $(MANDIR)"
@echo "--------------------------------------------------------"
if test ! -d $(MANDIR); then mkdir -p $(MANDIR); fi; $(INSTALL) $(INSTMANFLAGS) ncview.1 $(MANDIR)/ncview.1
- /bin/sh ./install-appdef "$(INSTALL) $(INSTMANFLAGS)"
+ if test ! -d @prefix@/lib/X11/app-defaults; then mkdir -p @prefix@/lib/X11/app-defaults; fi; $(INSTALL) $(INSTDATFLAGS) Ncview @prefix@/lib/X11/app-defaults

View file

@ -0,0 +1 @@
Visual browser for netCDF format files

View file

@ -0,0 +1,6 @@
Ncview is an X Windows visual browser for netCDF data format files.
Ncview displays a 2-dimensional, color representation of data in a
netCDF file. You can animate the data in time (making simple movies),
flip or enlarge the picture, scan through various axes, change
colormaps, etc. You can also plot the data in X-Y plots and then
print those, courtesy of the SciPlot widget.

13
graphics/ncview/pkg/PLIST Normal file
View file

@ -0,0 +1,13 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2001/02/09 23:41:34 jtb Exp $
bin/ncview
lib/X11/app-defaults/Ncview
lib/ncview/3gauss.ncmap
lib/ncview/3saw.ncmap
lib/ncview/default.ncmap
lib/ncview/detail.ncmap
lib/ncview/hotres.ncmap
lib/ncview/nc_overlay.earth.lat-lon.p8deg
lib/ncview/nc_overlay.lat-lon-grid.10x30
lib/ncview/nc_overlay.lat-lon-grid.20x60
man/man1/ncview.1
@dirrm lib/ncview