Update to CLN 1.3.0.

Changes since previous package:

2009-06-30, version 1.3.0
* Use the GNU autotools as build system.
* Implemented a more portable module dependency mechanism.

2008-04-05, version 1.2.2
* Re-establish CLN-1.2.0 ABI and fix ARM build, both inadvertently broken in
  the previous release.

2008-03-24, version 1.2.1
* Fixed some bugs in the output of numbers larger than 2^32 decimal digits.
* Modifying C/C++ operators like +=, ++, etc. are now enabled by default.

2008-01-19, version 1.2.0
* Save big amounts of memory in computation of some functions and constants by:
    - Avoiding pre-computation of series terms and instead computing them in a
      streamed way.
    - Avoiding computation with excess precision in binary splitting algorithm
      by coercion of intermediate integer values to floating-point as early as
      possible.
* Added support for huge numbers:
    - intC used for all counter loops.
    - intE is now a 64-bit type on all 64-bit platforms and even on selected
      32-bit platforms.
* CLN now uses C++ exceptions for error handling. The cl_abort() hook is not
  supported any more. Please refer to the documentation to learn about existing
  exception types.
* Fixed a bug on i386 where comparing Z/2Z ring zeros returnd random results.
* Removed cl_boolean. Use built-in C++ bool instead.
* Dropped the cln-config script. Please use pkg-config instead.
* Updated infrastructure to that of libtool-1.5.24.
* Changed encoding of all files to UTF-8.
* Fix compilation issues with GCC-4.3.
* Fix linking issues on platforms that don't feature weak symbols (like win32).
This commit is contained in:
asau 2009-09-03 10:48:18 +00:00
parent 1862c9b8a5
commit 3562aae18c
5 changed files with 25 additions and 82 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.17 2008/06/12 02:14:36 joerg Exp $
# $NetBSD: Makefile,v 1.18 2009/09/03 10:48:18 asau Exp $
DISTNAME= cln-1.1.13
DISTNAME= cln-1.3.0
CATEGORIES= math
MASTER_SITES= http://www.ginac.de/CLN/ \
ftp://ftpthep.physik.uni-mainz.de/pub/gnu/
@ -9,6 +9,7 @@ EXTRACT_SUFX= .tar.bz2
MAINTAINER= adam@NetBSD.org
HOMEPAGE= http://www.ginac.de/CLN/
COMMENT= CLN Class Library for Numbers
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir

View file

@ -1,5 +1,5 @@
@comment $NetBSD: PLIST,v 1.6 2009/06/14 18:05:42 joerg Exp $
bin/cln-config
@comment $NetBSD: PLIST,v 1.7 2009/09/03 10:48:18 asau Exp $
bin/pi
include/cln/GV.h
include/cln/GV_complex.h
include/cln/GV_integer.h
@ -15,7 +15,6 @@ include/cln/SV_rational.h
include/cln/SV_real.h
include/cln/SV_ringelt.h
include/cln/V.h
include/cln/abort.h
include/cln/cln.h
include/cln/complex.h
include/cln/complex_class.h
@ -26,6 +25,7 @@ include/cln/config.h
include/cln/dfloat.h
include/cln/dfloat_class.h
include/cln/dfloat_io.h
include/cln/exception.h
include/cln/ffloat.h
include/cln/ffloat_class.h
include/cln/ffloat_io.h
@ -33,7 +33,7 @@ include/cln/float.h
include/cln/float_class.h
include/cln/float_io.h
include/cln/floatformat.h
include/cln/floatparam.h
include/cln/host_cpu.h
include/cln/input.h
include/cln/integer.h
include/cln/integer_class.h
@ -81,24 +81,4 @@ include/cln/version.h
info/cln.info
lib/libcln.la
lib/pkgconfig/cln.pc
man/man1/cln-config.1
share/aclocal/cln.m4
share/doc/cln/html/cln_1.html
share/doc/cln/html/cln_10.html
share/doc/cln/html/cln_11.html
share/doc/cln/html/cln_12.html
share/doc/cln/html/cln_13.html
share/doc/cln/html/cln_14.html
share/doc/cln/html/cln_15.html
share/doc/cln/html/cln_16.html
share/doc/cln/html/cln_2.html
share/doc/cln/html/cln_3.html
share/doc/cln/html/cln_4.html
share/doc/cln/html/cln_5.html
share/doc/cln/html/cln_6.html
share/doc/cln/html/cln_7.html
share/doc/cln/html/cln_8.html
share/doc/cln/html/cln_9.html
share/doc/cln/html/cln_abt.html
share/doc/cln/html/cln_ovr.html
share/doc/cln/html/cln_toc.html
man/man1/pi.1

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.6 2007/01/04 21:20:57 adam Exp $
$NetBSD: distinfo,v 1.7 2009/09/03 10:48:18 asau Exp $
SHA1 (cln-1.1.13.tar.bz2) = 61c130cbb00ed95a19ee9dffc136b2823e452647
RMD160 (cln-1.1.13.tar.bz2) = 798e8e2a8d4aa81b770b6606ae1fe617bcb0cbc3
Size (cln-1.1.13.tar.bz2) = 1708927 bytes
SHA1 (patch-ab) = d1fc5f290b8838af030f968fbba26e51be177100
SHA1 (patch-ac) = d93e47d81cb010f0eb21b3a98d5ce9b9a6150623
SHA1 (cln-1.3.0.tar.bz2) = 0b9df49c7c8d73aadc516b3574211718fe6a8dfc
RMD160 (cln-1.3.0.tar.bz2) = b57c133276b856e0fffb64eb954662817bf2b370
Size (cln-1.3.0.tar.bz2) = 1249521 bytes
SHA1 (patch-ab) = 5dba2a7f4b6ff2d1459880d72de63fd5500a8d22
SHA1 (patch-ac) = da39a3ee5e6b4b0d3255bfef95601890afd80709

View file

@ -1,36 +1,13 @@
$NetBSD: patch-ab,v 1.4 2007/01/04 21:20:57 adam Exp $
$NetBSD: patch-ab,v 1.5 2009/09/03 10:48:19 asau Exp $
--- doc/Makefile.in.orig 2006-08-06 14:14:20.000000000 +0200
+++ doc/Makefile.in
@@ -13,7 +13,7 @@ datarootdir = @datarootdir@
datadir = @datadir@
--- doc/Makefile.in.orig 2009-06-14 02:14:09.000000000 +0400
+++ doc/Makefile.in 2009-09-03 14:03:04.000000000 +0400
@@ -180,7 +180,7 @@
host_cpu = @host_cpu@
host_os = @host_os@
host_vendor = @host_vendor@
-htmldir = @htmldir@
+htmldir = @htmldir@/doc/cln/html
includedir = @includedir@
infodir = @infodir@
mandir = @mandir@
-htmldir = $(datadir)/html
+htmldir = $(datadir)/doc/cln/html
dvidir = $(datadir)/dvi
DESTDIR =
@@ -43,7 +43,7 @@ SHELL = /bin/sh
VPATH = $(srcdir)
-all : info dvi ps html
+all : info html
info : $(srcdir)/$(PACKAGE).info
@@ -88,13 +88,11 @@ install : all installdirs force
install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$(PACKAGE).info || :;\
else : ; fi
$(INSTALL_DATA) $(srcdir)/$(PACKAGE)_*.html $(DESTDIR)$(htmldir)
- $(INSTALL_DATA) $(srcdir)/$(PACKAGE).dvi $(DESTDIR)$(dvidir)/$(PACKAGE).dvi
installdirs : force
$(MKDIR) $(DESTDIR)$(datadir)
$(MKDIR) $(DESTDIR)$(infodir)
$(MKDIR) $(DESTDIR)$(htmldir)
- $(MKDIR) $(DESTDIR)$(dvidir)
uninstall : force
@if (install-info --version && \
install_sh = @install_sh@

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ac,v 1.3 2006/03/12 16:34:13 rillig Exp $
In parameterized __asm__ statements, literal % must be doubled.
--- src/base/cl_low.h.orig 2006-02-18 12:56:13.000000000 +0100
+++ src/base/cl_low.h 2006-02-18 12:56:23.000000000 +0100
@@ -238,7 +238,7 @@ inline uint32 mulu32_unchecked (uint32 a
#define mulu32(x,y,hi_zuweisung,lo_zuweisung) \
({ var register uint64 _hi; \
var register uint64 _lo; \
- __asm__("umul %2,%3,%1\n\trd %y,%0" \
+ __asm__("umul %2,%3,%1\n\trd %%y,%0" \
: "=r" (_hi), "=r" (_lo) \
: "r" ((uint32)(x)), "r" ((uint32)(y)) \
); \