py-trytond: fix build with latest setuptools

This commit is contained in:
wiz 2021-12-16 14:48:11 +00:00
parent e136894a3b
commit 3590ac2bc6
3 changed files with 22 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.20 2020/01/18 23:30:39 rillig Exp $
# $NetBSD: Makefile,v 1.21 2021/12/16 14:48:11 wiz Exp $
TRYTON_MODULE_NAME= trytond
.include "../../devel/py-trytond/Makefile.common"
CATEGORIES= devel python
@ -54,6 +54,13 @@ CONF_FILES+= ${EGDIR}/trytond.conf.example \
CONF_FILES+= ${EGDIR}/logging.conf.example \
${CONFDIR}/logging.conf
.include "../../lang/python/egg.mk"
.if ${PYPKGPREFIX} != "py27"
pre-build:
cd ${WRKSRC} && 2to3-${PYVERSSUFFIX} -w --no-diffs trytond
.endif
post-install:
${MV} ${DESTDIR}${PREFIX}/bin/trytond-admin \
${DESTDIR}${PREFIX}/bin/trytond-admin${PYVERSSUFFIX} || ${TRUE}
@ -67,5 +74,4 @@ post-install:
${DESTDIR}${PREFIX}/${EGDIR}/logging.conf.example
.include "../../lang/python/application.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.13 2021/10/26 10:19:12 nia Exp $
$NetBSD: distinfo,v 1.14 2021/12/16 14:48:11 wiz Exp $
BLAKE2s (tryton-4.2/trytond-4.2.1.tar.gz) = 633773d9a79c7974ba605350706231ce6a66a8dd306e690b4271efd494b987ad
SHA512 (tryton-4.2/trytond-4.2.1.tar.gz) = 3716a56d87e95dabaa77f2210c9499a6d1ae0278b7bae2034d6a19db8a40f1e22efd48118de9af1a72022b556a991d4293886804b2b531be0f4dd038fbe9e882
Size (tryton-4.2/trytond-4.2.1.tar.gz) = 581536 bytes
SHA1 (patch-setup.py) = 4b802daf2801407b5c0d89eb130742a63555bc10

View file

@ -0,0 +1,12 @@
$NetBSD: patch-setup.py,v 1.1 2021/12/16 14:48:11 wiz Exp $
Fix build with latest setuptools.
--- setup.py.orig 2016-12-13 17:02:57.000000000 +0000
+++ setup.py
@@ -115,5 +115,4 @@ setup(name=name,
test_suite='trytond.tests',
test_loader='trytond.test_loader:Loader',
tests_require=['mock'],
- use_2to3=True,
)