Update to version 0.9.11

IMPORTANT NOTE: This version does not include backwards support
                for the old style SILC private key so if you
                skipped 0.9.10 version you won't be able to run
                this client without generating new key pair.

Changes between 0.9.10 and 0.9.11
=================================

 * workaround a bug in GCC which causes memory exhaustion when
   compiling sha1 with optimizations on UltraSPARC.  from openbsd

 * Don't display "foo appears as foo\nYou're now known as foo"
   messages.
 * Do not print the nickname in SERVER_SIGNOFF if we do not
   have it.  Prevents asserts in Irssi core.  It is possible we
   don't have the nick if it was just being resolved when server
   signoff.
 * Prevent endless resolving of user informations in USERS
   command by checking the command reply status correctly.
 * Don't print signed messages when sending failed.
 * Send adequate signal when founding a channel by joing it.
 * Make GETKEY to update the client entrys fingerprint too.

 * Fixed autonick crashbug in client library.
 * Fix theme abstracts parsing.
 * Fixed double free in SKE library error hadling when signature
   error occurred.
This commit is contained in:
salo 2003-01-08 23:53:53 +00:00
parent ee26c7d6af
commit 35b6872eca
5 changed files with 31 additions and 50 deletions

View file

@ -1,13 +1,11 @@
# $NetBSD: Makefile,v 1.19 2002/12/06 19:51:25 salo Exp $
# $NetBSD: Makefile,v 1.20 2003/01/08 23:53:53 salo Exp $
DISTNAME= silc-client-0.9.10
DISTNAME= silc-client-0.9.11
CATEGORIES= chat security
MASTER_SITES= http://www.silcnet.org/download/client/sources/ \
ftp://ftp.silcnet.org/silc/client/sources/ \
http://www.fi.silcnet.org/download/client/sources/ \
ftp://ftp.au.silcnet.org/pub/silcnet/client/sources/ \
http://www.us.silcnet.org/download/client/sources/ \
ftp://ftp.no.silcnet.org/pub/silc/client/sources/ \
http://www.at.silcnet.org/download/client/sources/
EXTRACT_SUFX= .tar.bz2
@ -15,11 +13,11 @@ MAINTAINER= salo@netbsd.org
HOMEPAGE= http://www.silcnet.org/
COMMENT= Client for the Secure Internet Live Conferencing (SILC) protocol
GNU_CONFIGURE= # defined
USE_GMAKE= # defined
USE_GNU_ICONV= # defined
USE_BUILDLINK2= # defined
USE_LIBTOOL= # defined
GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_GNU_ICONV= YES
USE_BUILDLINK2= YES
USE_LIBTOOL= YES
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool ${WRKSRC}/irssi/libtool \
${WRKSRC}/lib/silcmath/mpi/libtool
@ -41,6 +39,7 @@ CONFIGURE_ARGS+= --with-etcdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --with-simdir=${PREFIX}/lib/silc/modules
CONFIGURE_ARGS+= --with-iconv=${BUILDLINK_DIR}
CONFIGURE_ARGS+= --with-terminfo
CONFIGURE_ARGS+= --without-libtoolfix
# Use native curses library.
.if (${OPSYS} == "NetBSD") || (${OPSYS} == "SunOS")

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2002/12/06 19:51:25 salo Exp $
@comment $NetBSD: PLIST,v 1.11 2003/01/08 23:53:53 salo Exp $
bin/silc
lib/silc/libsilc-1.0.so
lib/silc/libsilc-1.0.so.1
@ -133,6 +133,5 @@ share/silc/themes/default.theme
@dirrm share/silc/help
@dirrm share/silc
@dirrm share/doc/silc
@dirrm etc/silc
@dirrm lib/silc/modules
@dirrm lib/silc

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.16 2002/12/06 19:51:25 salo Exp $
$NetBSD: distinfo,v 1.17 2003/01/08 23:53:53 salo Exp $
SHA1 (silc-client-0.9.10.tar.bz2) = 0baa9f0a9000e6b55f33ee90e026f842969aa507
Size (silc-client-0.9.10.tar.bz2) = 1495547 bytes
SHA1 (silc-client-0.9.11.tar.bz2) = 4a6a7f63ce3ef487b0d0575ce31dc1bba2538a5f
Size (silc-client-0.9.11.tar.bz2) = 1492223 bytes
SHA1 (patch-aa) = bce1074fe6f9987d531a215327b4bc691fd555fb
SHA1 (patch-ab) = 8d1edd3e2112ec33186b70a65ec99ee44d9d88ad
SHA1 (patch-ac) = 796663dd1008997b08b6a627e9c0537cf518cf8f
SHA1 (patch-ab) = b919f6ab77abaf8765fb5bafa7fef8714502b989

View file

@ -1,22 +1,19 @@
$NetBSD: patch-ab,v 1.7 2002/12/06 19:51:26 salo Exp $
$NetBSD: patch-ab,v 1.8 2003/01/08 23:53:53 salo Exp $
--- lib/silcsim/Makefile.in.orig Thu Dec 5 22:39:00 2002
+++ lib/silcsim/Makefile.in Fri Dec 6 17:48:33 2002
@@ -561,7 +561,7 @@
$(SIM_CIPHER_OBJS):
@if test '!' -f lib$*.la ; then \
$(LIBTOOL) --mode=link $(CCLD) -rpath $(silc_modulesdir) \
- ../silccrypt/$*.lo -o lib$*.la --libtool-enable-shared; \
+ ../silccrypt/$*.lo -o lib$*.la ; \
cd $(srcdir) && $(LN_S) -f $(srcdir)/.libs/lib$*.so \
$(srcdir)/$*.sim.so; \
fi
@@ -569,7 +569,7 @@
$(SIM_HASH_OBJS):
@if test '!' -f lib$*.la ; then \
$(LIBTOOL) --mode=link $(CCLD) -rpath $(silc_modulesdir) \
- ../silccrypt/$*.lo -o lib$*.la --libtool-enable-shared; \
+ ../silccrypt/$*.lo -o lib$*.la ; \
cd $(srcdir) && $(LN_S) -f $(srcdir)/.libs/lib$*.so \
$(srcdir)/$*.sim.so; \
fi
--- lib/silccrypt/Makefile.in.orig Wed Jan 8 17:19:42 2003
+++ lib/silccrypt/Makefile.in Wed Jan 8 23:00:18 2003
@@ -366,6 +366,14 @@
.c.obj:
$(COMPILE) -c `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'`
+# Workaround a bug in GCC which causes momory exhaustion
+# when compiling sha1 with optimizations on UltraSPARC.
+#
+ifeq (sparc64, $(host_cpu))
+sha1.lo:
+ $(LTCOMPILE) -O0 -c -o $@ `test -f 'sha1.c' || echo '$(srcdir)/'`sha1.c
+ endif
+
.c.lo:
$(LTCOMPILE) -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ac,v 1.5 2002/12/06 19:51:26 salo Exp $
--- lib/silccrypt/Makefile.in.orig Thu Dec 5 22:38:58 2002
+++ lib/silccrypt/Makefile.in Fri Dec 6 17:49:59 2002
@@ -106,7 +106,7 @@
CCDEPMODE = @CCDEPMODE@
# Tell libtool to compile silccrypt as shared since silcsim will need it.
-CFLAGS = --libtool-enable-shared
+#CFLAGS = --libtool-enable-shared
CPP = @CPP@
CPPFLAGS = @CPPFLAGS@
CYGPATH_W = @CYGPATH_W@