Update to herrie-2.1. NOTE: the OSSv4 audio volume API change only applies
if OSSv4 is installed, so functionality should be retained on OSS-emulating platforms, e.g. NetBSD and OpenBSD. 2008-07-15 -- Herrie 2.1: * Added: -p switch to start playback on startup - Phillip Warner * Fixed: Crash in seek time format parsing * Added: 'F' button to jump to files in the file browser * Improved: Use OSSv4 volume adjustment API - Paulo Matias
This commit is contained in:
parent
e6dadde4fd
commit
35c726b104
3 changed files with 14 additions and 14 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.9 2008/03/27 14:24:36 bjs Exp $
|
||||
# $NetBSD: Makefile,v 1.10 2008/07/16 07:21:23 bjs Exp $
|
||||
#
|
||||
|
||||
DISTNAME= herrie-2.0
|
||||
DISTNAME= herrie-2.1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://herrie.info/distfiles/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2008/03/27 14:24:36 bjs Exp $
|
||||
$NetBSD: distinfo,v 1.4 2008/07/16 07:21:23 bjs Exp $
|
||||
|
||||
SHA1 (herrie-2.0.tar.bz2) = 560b8dc591e0f2d5e84ae33843e42fe726dd828e
|
||||
RMD160 (herrie-2.0.tar.bz2) = f53ed76f578ad92a6146fe2a19c5b6a4decf35a6
|
||||
Size (herrie-2.0.tar.bz2) = 69438 bytes
|
||||
SHA1 (patch-aa) = 6721730981182b07a668525e919cd5ec8cb4d9fa
|
||||
SHA1 (herrie-2.1.tar.bz2) = da9f0838826954066abe9900e618ed8ad4da85ca
|
||||
RMD160 (herrie-2.1.tar.bz2) = 638561a51aad2ee46a5915dc0ff921e5468218d3
|
||||
Size (herrie-2.1.tar.bz2) = 70592 bytes
|
||||
SHA1 (patch-aa) = ee64594d6a4157869e6c99dd419c9c538c78bb52
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.3 2008/03/27 14:24:36 bjs Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2008/07/16 07:21:23 bjs Exp $
|
||||
|
||||
--- configure.orig 2008-03-16 09:09:14.000000000 -0400
|
||||
--- configure.orig 2008-07-15 11:59:07.000000000 -0400
|
||||
+++ configure
|
||||
@@ -33,7 +33,7 @@ APP_LINGUAS='ca da de es fi ga nl pl pt_
|
||||
CFG_AO=oss
|
||||
|
@ -20,7 +20,7 @@ $NetBSD: patch-aa,v 1.3 2008/03/27 14:24:36 bjs Exp $
|
|||
CFG_SETPROCTITLE=yes
|
||||
[ "$PREFIX" = "" ] && PREFIX=/usr/local
|
||||
[ "$MANDIR" = "" ] && MANDIR=$PREFIX/man
|
||||
@@ -319,13 +319,13 @@ oss)
|
||||
@@ -320,13 +320,13 @@ oss)
|
||||
NetBSD|OpenBSD)
|
||||
CFLAGS="$CFLAGS -DOSS_HEADER=\\<soundcard.h\\>"
|
||||
LDFLAGS="$LDFLAGS -lossaudio"
|
||||
|
@ -36,7 +36,7 @@ $NetBSD: patch-aa,v 1.3 2008/03/27 14:24:36 bjs Exp $
|
|||
;;
|
||||
esac
|
||||
CFG_VOLUME=yes
|
||||
@@ -363,7 +363,7 @@ echo "- Using $CFG_AO audio output"
|
||||
@@ -364,7 +364,7 @@ echo "- Using $CFG_AO audio output"
|
||||
echo
|
||||
|
||||
# Perform a simple compiler test
|
||||
|
@ -45,7 +45,7 @@ $NetBSD: patch-aa,v 1.3 2008/03/27 14:24:36 bjs Exp $
|
|||
if [ $? -ne 0 ]
|
||||
then
|
||||
echo "Error: some dependencies are missing"
|
||||
@@ -390,13 +390,13 @@ done
|
||||
@@ -391,13 +391,13 @@ done
|
||||
all: $APP_NAME$CFG_BINEXT $APP_NAME.1.gz $SRCDIR/$APP_NAME.conf.sample $MOS
|
||||
$APP_NAME$CFG_BINEXT: $OBJS
|
||||
# Linking $APP_NAME$CFG_BINEXT
|
||||
|
@ -62,7 +62,7 @@ $NetBSD: patch-aa,v 1.3 2008/03/27 14:24:36 bjs Exp $
|
|||
${DOIT}rm -Rf *.dSYM
|
||||
distclean: clean
|
||||
# Removing Makefile
|
||||
@@ -405,29 +405,29 @@ Makefile: $0 `dirname $0`/depends
|
||||
@@ -406,29 +406,29 @@ Makefile: $0 `dirname $0`/depends
|
||||
# WARNING: Your Makefile is outdated. Please re-run $0!
|
||||
install: all
|
||||
# Installing \$(DESTDIR)$BINDIR/$APP_NAME$CFG_BINEXT
|
||||
|
@ -104,7 +104,7 @@ $NetBSD: patch-aa,v 1.3 2008/03/27 14:24:36 bjs Exp $
|
|||
EOF
|
||||
for i in $CFG_LINGUAS
|
||||
do
|
||||
@@ -444,7 +444,7 @@ do
|
||||
@@ -445,7 +445,7 @@ do
|
||||
done
|
||||
echo "$i.o: Makefile $SRCDIR/src/$i.c $SRCDIR/src/stdinc.h $DEPS"
|
||||
echo " # Compiling $i.o"
|
||||
|
|
Loading…
Reference in a new issue