Update rubygems to 1.3.1.
New features since 1.2.0: * RubyGems doesn't print LOCAL/REMOTE titles for `gem query` and friends if stdout is not a TTY, except with --both. * Added Gem.find_files, allows a gem to discover features provided by other gems. * Added pre/post (un)install hooks for packagers of RubyGems. (Not for gems themselves). * RubyGems now installs gems into ~/.gem if GEM_HOME is not writable. Use --no-user-install command-line switch to disable this behavior. * Fetching specs for update now uses If-Modified-Since requests. * RubyGems now updates the ri cache when the rdoc gem is installed and documentation is generated.
This commit is contained in:
parent
eed17a2325
commit
35e19d3f45
8 changed files with 72 additions and 64 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.22 2008/09/15 08:43:44 taca Exp $
|
||||
# $NetBSD: Makefile,v 1.23 2009/04/07 07:35:44 minskim Exp $
|
||||
|
||||
DISTNAME= rubygems-1.2.0
|
||||
DISTNAME= rubygems-1.3.1
|
||||
CATEGORIES= misc ruby
|
||||
MASTER_SITES= http://rubyforge.org/frs/download.php/38646/
|
||||
MASTER_SITES= http://rubyforge.org/frs/download.php/45905/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= minskim@NetBSD.org
|
||||
|
@ -57,7 +57,7 @@ INSTALL_TARGET= install
|
|||
INSTALL_TARGET+= --vendor
|
||||
INSTALL_TARGET+= --no-format-executable # "bin/gem", not "bin/gem18"
|
||||
.if ${_USE_DESTDIR} != "no"
|
||||
INSTALL_TARGET+= --destdir=${DESTDIR:Q}
|
||||
INSTALL_TARGET+= --destdir=${DESTDIR:Q}${PREFIX:Q}
|
||||
.endif
|
||||
|
||||
# rubygem's setup.rb is not the typical setup.rb -- manually run the
|
||||
|
|
|
@ -1,15 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.18 2008/09/15 08:43:44 taca Exp $
|
||||
$NetBSD: distinfo,v 1.19 2009/04/07 07:35:44 minskim Exp $
|
||||
|
||||
SHA1 (rubygems-1.2.0.tgz) = 89f8e35f03e1e8057cc8e237f2df025642653dde
|
||||
RMD160 (rubygems-1.2.0.tgz) = c66444cc3f372f7170ba1d8ef3c456052acb2bde
|
||||
Size (rubygems-1.2.0.tgz) = 246920 bytes
|
||||
SHA1 (rubygems-1.3.1.tgz) = a21ae466146bffb28ece05cddbdced0b908ca74f
|
||||
RMD160 (rubygems-1.3.1.tgz) = 898f33bf49ac6d29d8980cb4feaf30ade0125248
|
||||
Size (rubygems-1.3.1.tgz) = 263748 bytes
|
||||
SHA1 (patch-aa) = c504f63e6279a99ddc76a03c0978b89ae2e81024
|
||||
SHA1 (patch-ab) = 6eb8c453aab58a708dba04944cc0d4b8880014f8
|
||||
SHA1 (patch-ab) = b5a0de2c565ba15e2b0fd34993ead019ddee4469
|
||||
SHA1 (patch-ac) = 5f744d9556855f7a430401c855e288b42669c808
|
||||
SHA1 (patch-ad) = 5f11cff48cbafc4c210a514f50356742b74943ae
|
||||
SHA1 (patch-ad) = 84e1399a671d1888d330bace930fe44c2e72037a
|
||||
SHA1 (patch-af) = 75f7fe5c777c4eef652e537ba91c2977ee2cfdd6
|
||||
SHA1 (patch-ag) = e9c72c6d6af55fa60d3da96a56ffde3dc002f164
|
||||
SHA1 (patch-ag) = 9f18db21fcd77d09f810913dd90eecd88cec6250
|
||||
SHA1 (patch-ah) = 0dcf44dfaaa1ae5d2b4165c8b1431ddbe46b4b24
|
||||
SHA1 (patch-aj) = b19778ff6f12216f0a29f93c596492602809359e
|
||||
SHA1 (patch-ak) = 6230bb570f10b7b81f61ccd8f970128450520f52
|
||||
SHA1 (patch-al) = be02021fad82392bfb42c22ae5336700d62ff37e
|
||||
SHA1 (patch-aj) = 8b8c76daf32564eae2150a4262a85180f0cb0af7
|
||||
SHA1 (patch-ak) = 999b52ab6f61dd1c81608d08418b9bb34bdc8aa6
|
||||
|
|
|
@ -1,16 +1,28 @@
|
|||
$NetBSD: patch-ab,v 1.8 2008/09/15 08:43:44 taca Exp $
|
||||
$NetBSD: patch-ab,v 1.9 2009/04/07 07:35:44 minskim Exp $
|
||||
|
||||
--- lib/rubygems/dependency_installer.rb.orig 2008-06-21 04:55:40.000000000 +0900
|
||||
--- lib/rubygems/dependency_installer.rb.orig 2008-08-12 14:50:22.000000000 -0700
|
||||
+++ lib/rubygems/dependency_installer.rb
|
||||
@@ -37,6 +37,7 @@ class Gem::DependencyInstaller
|
||||
@@ -37,13 +37,18 @@ class Gem::DependencyInstaller
|
||||
# :format_executable:: See Gem::Installer#initialize.
|
||||
# :ignore_dependencies:: Don't install any dependencies.
|
||||
# :install_dir:: See Gem::Installer#install.
|
||||
+ # :install_root: See Gem::Installer#install.
|
||||
# :security_policy:: See Gem::Installer::new and Gem::Security.
|
||||
# :user_install:: See Gem::Installer.new
|
||||
# :wrappers:: See Gem::Installer::new
|
||||
|
||||
@@ -56,10 +57,15 @@ class Gem::DependencyInstaller
|
||||
def initialize(options = {})
|
||||
if options[:install_dir] then
|
||||
- spec_dir = options[:install_dir], 'specifications'
|
||||
+ if options[:install_root].nil? or options[:install_root] == "" then
|
||||
+ spec_dir = options[:install_root], options[:install_dir], 'specifications'
|
||||
+ else
|
||||
+ spec_dir = options[:install_dir], 'specifications'
|
||||
+ end
|
||||
@source_index = Gem::SourceIndex.from_gems_in spec_dir
|
||||
else
|
||||
@source_index = Gem.source_index
|
||||
@@ -65,7 +70,12 @@ class Gem::DependencyInstaller
|
||||
@installed_gems = []
|
||||
|
||||
@install_dir = options[:install_dir] || Gem.dir
|
||||
|
@ -21,18 +33,14 @@ $NetBSD: patch-ab,v 1.8 2008/09/15 08:43:44 taca Exp $
|
|||
+ install_dir = File.join(@install_root, @install_dir)
|
||||
+ end
|
||||
+ @cache_dir = options[:cache_dir] || install_dir
|
||||
end
|
||||
|
||||
if options[:install_dir] then
|
||||
- spec_dir = File.join @install_dir, 'specifications'
|
||||
+ spec_dir = File.join install_dir, 'specifications'
|
||||
@source_index = Gem::SourceIndex.from_gems_in spec_dir
|
||||
else
|
||||
@source_index = Gem.source_index
|
||||
@@ -237,6 +243,7 @@ class Gem::DependencyInstaller
|
||||
:format_executable => @format_executable,
|
||||
##
|
||||
@@ -241,6 +251,7 @@ class Gem::DependencyInstaller
|
||||
:format_executable => @format_executable,
|
||||
:ignore_dependencies => @ignore_dependencies,
|
||||
:install_dir => @install_dir,
|
||||
+ :install_root => @install_root,
|
||||
:security_policy => @security_policy,
|
||||
:wrappers => @wrappers,
|
||||
:bin_dir => @bin_dir,
|
||||
:install_dir => @install_dir,
|
||||
+ :install_root => @install_root,
|
||||
:security_policy => @security_policy,
|
||||
:source_index => @source_index,
|
||||
:user_install => @user_install,
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ad,v 1.3 2008/09/15 08:43:44 taca Exp $
|
||||
$NetBSD: patch-ad,v 1.4 2009/04/07 07:35:44 minskim Exp $
|
||||
|
||||
--- lib/rubygems/installer.rb.orig 2008-06-07 09:15:11.000000000 +0900
|
||||
--- lib/rubygems/installer.rb.orig 2008-10-10 11:22:39.000000000 -0700
|
||||
+++ lib/rubygems/installer.rb
|
||||
@@ -51,6 +51,9 @@ class Gem::Installer
|
||||
@@ -80,6 +80,9 @@ class Gem::Installer
|
||||
# for a signed-gems-only policy.
|
||||
# :ignore_dependencies:: Don't raise if a dependency is missing.
|
||||
# :install_dir:: The directory to install the gem into.
|
||||
|
@ -12,18 +12,18 @@ $NetBSD: patch-ad,v 1.3 2008/09/15 08:43:44 taca Exp $
|
|||
# :format_executable:: Format the executable the same as the ruby executable.
|
||||
# If your ruby is ruby18, foo_exec will be installed as
|
||||
# foo_exec18.
|
||||
@@ -63,6 +66,7 @@ class Gem::Installer
|
||||
options = {
|
||||
:force => false,
|
||||
:install_dir => Gem.dir,
|
||||
@@ -95,6 +98,7 @@ class Gem::Installer
|
||||
:exec_format => false,
|
||||
:force => false,
|
||||
:install_dir => Gem.dir,
|
||||
+ :install_root => nil,
|
||||
:exec_format => false,
|
||||
:env_shebang => false,
|
||||
:bin_dir => nil
|
||||
@@ -78,6 +82,11 @@ class Gem::Installer
|
||||
@wrappers = options[:wrappers]
|
||||
:source_index => Gem.source_index,
|
||||
}.merge options
|
||||
|
||||
@@ -109,6 +113,11 @@ class Gem::Installer
|
||||
@bin_dir = options[:bin_dir]
|
||||
@development = options[:development]
|
||||
@source_index = options[:source_index]
|
||||
+ install_root = options[:install_root]
|
||||
+ unless install_root.nil? or install_root == ""
|
||||
+ @install_root = File.expand_path install_root
|
||||
|
@ -32,7 +32,7 @@ $NetBSD: patch-ad,v 1.3 2008/09/15 08:43:44 taca Exp $
|
|||
|
||||
begin
|
||||
@format = Gem::Format.from_file_by_path @gem, @security_policy
|
||||
@@ -234,7 +243,11 @@ class Gem::Installer
|
||||
@@ -310,7 +319,11 @@ class Gem::Installer
|
||||
# If the user has asked for the gem to be installed in a directory that is
|
||||
# the system gem directory, then use the system bin directory, else create
|
||||
# (or use) a new bin dir under the gem_home.
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ag,v 1.2 2008/09/15 08:43:44 taca Exp $
|
||||
$NetBSD: patch-ag,v 1.3 2009/04/07 07:35:44 minskim Exp $
|
||||
|
||||
--- lib/rubygems/uninstaller.rb.orig 2008-06-21 03:34:46.000000000 +0900
|
||||
--- lib/rubygems/uninstaller.rb.orig 2008-08-14 15:57:27.000000000 -0700
|
||||
+++ lib/rubygems/uninstaller.rb
|
||||
@@ -31,6 +31,11 @@ class Gem::Uninstaller
|
||||
@@ -45,6 +45,11 @@ class Gem::Uninstaller
|
||||
@force_all = options[:all]
|
||||
@force_ignore = options[:ignore]
|
||||
@bin_dir = options[:bin_dir]
|
||||
|
@ -11,10 +11,10 @@ $NetBSD: patch-ag,v 1.2 2008/09/15 08:43:44 taca Exp $
|
|||
+ @install_root = File.expand_path install_root
|
||||
+ @gem_home = File.join(@install_root, @gem_home)
|
||||
+ end
|
||||
end
|
||||
|
||||
##
|
||||
@@ -74,7 +79,11 @@ class Gem::Uninstaller
|
||||
spec_dir = File.join @gem_home, 'specifications'
|
||||
@source_index = Gem::SourceIndex.from_gems_in spec_dir
|
||||
@@ -109,7 +114,11 @@ class Gem::Uninstaller
|
||||
return if gemspec.nil?
|
||||
|
||||
if gemspec.executables.size > 0 then
|
||||
|
@ -25,5 +25,5 @@ $NetBSD: patch-ag,v 1.2 2008/09/15 08:43:44 taca Exp $
|
|||
+ bindir = File.join(@install_root, bindir)
|
||||
+ end
|
||||
|
||||
list = Gem.source_index.search(gemspec.name).delete_if { |spec|
|
||||
list = @source_index.find_name(gemspec.name).delete_if { |spec|
|
||||
spec.version == gemspec.version
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-aj,v 1.2 2008/09/15 08:43:44 taca Exp $
|
||||
$NetBSD: patch-aj,v 1.3 2009/04/07 07:35:44 minskim Exp $
|
||||
|
||||
--- lib/rubygems/defaults.rb.orig 2008-06-05 11:34:47.000000000 +0900
|
||||
--- lib/rubygems/defaults.rb.orig 2008-10-10 13:29:53.000000000 -0700
|
||||
+++ lib/rubygems/defaults.rb
|
||||
@@ -9,7 +9,7 @@ module Gem
|
||||
# specified in the environment.
|
||||
@@ -18,7 +18,7 @@ module Gem
|
||||
|
||||
def self.default_dir
|
||||
if defined? RUBY_FRAMEWORK_VERSION then
|
||||
- File.join File.dirname(ConfigMap[:sitedir]), 'Gems',
|
||||
+ File.join File.dirname(ConfigMap[:vendordir]), 'Gems',
|
||||
ConfigMap[:ruby_version]
|
||||
elsif defined? RUBY_ENGINE then
|
||||
File.join ConfigMap[:libdir], RUBY_ENGINE, 'gems',
|
||||
else
|
||||
File.join(ConfigMap[:libdir], ruby_engine, 'gems',
|
||||
|
|
|
@ -1,18 +1,19 @@
|
|||
$NetBSD: patch-ak,v 1.2 2008/09/15 08:43:44 taca Exp $
|
||||
$NetBSD: patch-ak,v 1.3 2009/04/07 07:35:44 minskim Exp $
|
||||
|
||||
--- test/test_gem.rb.orig 2008-06-19 06:27:03.000000000 +0900
|
||||
--- test/test_gem.rb.orig 2008-10-09 15:42:25.000000000 -0700
|
||||
+++ test/test_gem.rb
|
||||
@@ -345,17 +345,17 @@ class TestGem < RubyGemTestCase
|
||||
@@ -384,18 +384,18 @@ class TestGem < RubyGemTestCase
|
||||
Gem::ConfigMap[:libdir] = orig_libdir
|
||||
end
|
||||
|
||||
- def test_self_prefix_sitelibdir
|
||||
- orig_sitelibdir = Gem::ConfigMap[:sitelibdir]
|
||||
+ def test_self_prefix_vendorlibdir
|
||||
+ orig_vendorlibdir = Gem::ConfigMap[:vendorlibdir]
|
||||
+ orig_sitelibdir = Gem::ConfigMap[:vendorlibdir]
|
||||
|
||||
file_name = File.expand_path __FILE__
|
||||
prefix = File.dirname File.dirname(file_name)
|
||||
prefix = File.dirname prefix if File.basename(prefix) == 'test'
|
||||
|
||||
- Gem::ConfigMap[:sitelibdir] = prefix
|
||||
+ Gem::ConfigMap[:vendorlibdir] = prefix
|
||||
|
@ -20,7 +21,7 @@ $NetBSD: patch-ak,v 1.2 2008/09/15 08:43:44 taca Exp $
|
|||
assert_nil Gem.prefix
|
||||
ensure
|
||||
- Gem::ConfigMap[:sitelibdir] = orig_sitelibdir
|
||||
+ Gem::ConfigMap[:vendorlibdir] = orig_vendorlibdir
|
||||
+ Gem::ConfigMap[:vendorlibdir] = orig_sitelibdir
|
||||
end
|
||||
|
||||
def test_self_refresh
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: rubygem.mk,v 1.39 2008/09/15 08:42:37 taca Exp $
|
||||
# $NetBSD: rubygem.mk,v 1.40 2009/04/07 07:35:44 minskim Exp $
|
||||
#
|
||||
# This Makefile fragment is intended to be included by packages that build
|
||||
# and install Ruby gems.
|
||||
|
@ -156,7 +156,7 @@ GEM_SPECFILE?= ${WRKDIR}/${DISTNAME}.gemspec
|
|||
.PHONY: gem-extract
|
||||
post-extract: gem-extract
|
||||
.if !target(gem-extract)
|
||||
gem-extract:
|
||||
gem-extract: fake-home
|
||||
. for _gem_ in ${DISTFILES:M*.gem}
|
||||
${RUN} cd ${WRKDIR} && ${SETENV} ${MAKE_ENV} \
|
||||
${RUBYGEM} unpack ${_DISTDIR:Q}/${_gem_:Q}
|
||||
|
|
Loading…
Reference in a new issue