Update php56 to 5.6.14.

01 Oct 2015, PHP 5.6.14

- Core:
  . Fixed bug #70370 (Bundled libtool.m4 doesn't handle FreeBSD 10 when
    building extensions). (Adam)

- CLI server:
  . Fixed bug #68291 (404 on urls with '+'). (cmb)

- DOM:
  . Fixed bug #70001 (Assigning to DOMNode::textContent does additional entity
    encoding). (cmb)

- Mysqlnd:
  . Fixed bug #70456 (mysqlnd doesn't activate TCP keep-alive when connecting to
    a server). (Sergei Turchanov)

- OpenSSL:
  . Fixed bug #55259 (openssl extension does not get the DH parameters from
    DH key resource). (Jakub Zelenka)
  . Fixed bug #70395 (Missing ARG_INFO for openssl_seal()). (cmb)
  . Fixed bug #60632 (openssl_seal fails with AES). (Jakub Zelenka)
  . Fixed bug #68312 (Lookup for openssl.cnf causes a message box). (Anatol)

- PDO:
  . Fixed bug #70389 (PDO constructor changes unrelated variables). (Laruence)

- Phar:
  . Fixed bug #69720 (Null pointer dereference in phar_get_fp_offset()). (Stas)
  . FIxed bug #70433 (Uninitialized pointer in phar_make_dirstream when zip
    entry filename is "/"). (Stas)

- Phpdbg:
  . Fix phpdbg_break_next() sometimes not breaking. (Bob)

- Standard:
  . Fixed bug #67131 (setcookie() conditional for empty values not met). (cmb)

- Streams:
  . Fixed bug #70361 (HTTP stream wrapper doesn't close keep-alive connections).
    (Niklas Keller)

- Zip:
  . Fixed bug #70322 (ZipArchive::close() doesn't indicate errors). (cmb)
This commit is contained in:
taca 2015-10-02 14:37:39 +00:00
parent 844190e723
commit 360ea761dc
5 changed files with 17 additions and 90 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: phpversion.mk,v 1.113 2015/10/02 14:36:35 taca Exp $
# $NetBSD: phpversion.mk,v 1.114 2015/10/02 14:37:39 taca Exp $
#
# This file selects a PHP version, based on the user's preferences and
# the installed packages. It does not add a dependency on the PHP
@ -83,7 +83,7 @@ PHPVERSION_MK= defined
# Define each PHP's version.
PHP54_VERSION= 5.4.45
PHP55_VERSION= 5.5.30
PHP56_VERSION= 5.6.13
PHP56_VERSION= 5.6.14
# Define initial release of major version.
PHP54_RELDATE= 20120301

View file

@ -1,12 +1,10 @@
$NetBSD: distinfo,v 1.15 2015/09/06 12:27:43 taca Exp $
$NetBSD: distinfo,v 1.16 2015/10/02 14:37:39 taca Exp $
SHA1 (php-5.6.13.tar.bz2) = 0fc2f582a6670efc512dc872da6638796ed64525
RMD160 (php-5.6.13.tar.bz2) = a7f243e72b185f6da2a859bb80a59790c2c2aaba
Size (php-5.6.13.tar.bz2) = 14077633 bytes
SHA1 (php-5.6.14.tar.bz2) = 21706059790fb48db7e7105bf1734d7e677aa7cd
RMD160 (php-5.6.14.tar.bz2) = cb3c8a389d3b2d9c4a1ee88e6b5568de9182a347
Size (php-5.6.14.tar.bz2) = 14073920 bytes
SHA1 (patch-acinclude.m4) = b38fc34c3a3847dc317e8e286612b21ec8fd5ce8
SHA1 (patch-aclocal.m4) = 49117c42e03bd3ed57d967d33ba543f936013b4f
SHA1 (patch-build_libtool.m4) = f459cda09cbdad9780568d271091fb17bbc5d965
SHA1 (patch-configure) = d3d44c814deb0264fd4fc41908c2ff31fde00b0d
SHA1 (patch-configure) = a72aa43759c6f3d3ad350659397570582c3ca3ff
SHA1 (patch-ext_gd_config.m4) = 4b44853250eb4a638af4c663e618307ff25d2cbd
SHA1 (patch-ext_imap_config.m4) = 9c6ed6966366c4fe1b7cfd34b5910e2ff0e68577
SHA1 (patch-ext_mssql_php__mssql.c) = c4fa9231dc539ffb027f1beb6f182f21ddb94a3c

View file

@ -1,22 +0,0 @@
$NetBSD: patch-aclocal.m4,v 1.1 2014/11/24 15:37:08 taca Exp $
--- aclocal.m4.orig 2014-11-13 10:07:22.000000000 +0000
+++ aclocal.m4
@@ -4578,7 +4578,7 @@ freebsd* | dragonfly*)
objformat=`/usr/bin/objformat`
else
case $host_os in
- freebsd[[123]]*) objformat=aout ;;
+ freebsd[[123]]|freebsd[[123]].*) objformat=aout ;;
*) objformat=elf ;;
esac
fi
@@ -6195,7 +6195,7 @@ case $host_os in
;;
esac
;;
- freebsd[[12]]*)
+ freebsd[[12]]|freebsd[[12]].*)
# C++ shared libraries reported to be fairly broken before switch to ELF
_LT_AC_TAGVAR(ld_shlibs, $1)=no
;;

View file

@ -1,22 +0,0 @@
$NetBSD: patch-build_libtool.m4,v 1.1 2014/11/24 15:37:08 taca Exp $
--- build/libtool.m4.orig 2014-11-12 13:52:21.000000000 +0000
+++ build/libtool.m4
@@ -1545,7 +1545,7 @@ freebsd* | dragonfly*)
objformat=`/usr/bin/objformat`
else
case $host_os in
- freebsd[[123]]*) objformat=aout ;;
+ freebsd[[123]]|freebsd[[123]].*) objformat=aout ;;
*) objformat=elf ;;
esac
fi
@@ -3162,7 +3162,7 @@ case $host_os in
;;
esac
;;
- freebsd[[12]]*)
+ freebsd[[12]]|freebsd[[12]].*)
# C++ shared libraries reported to be fairly broken before switch to ELF
_LT_AC_TAGVAR(ld_shlibs, $1)=no
;;

View file

@ -1,8 +1,8 @@
$NetBSD: patch-configure,v 1.1 2014/11/24 15:37:08 taca Exp $
$NetBSD: patch-configure,v 1.2 2015/10/02 14:37:40 taca Exp $
--- configure.orig 2014-11-13 10:07:25.000000000 +0000
--- configure.orig 2015-09-30 07:18:32.000000000 +0000
+++ configure
@@ -8310,27 +8310,6 @@ EOF
@@ -8315,27 +8315,6 @@ EOF
;;
esac
@ -30,7 +30,7 @@ $NetBSD: patch-configure,v 1.1 2014/11/24 15:37:08 taca Exp $
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
@@ -9134,27 +9113,6 @@ EOF
@@ -9139,27 +9118,6 @@ EOF
;;
esac
@ -58,7 +58,7 @@ $NetBSD: patch-configure,v 1.1 2014/11/24 15:37:08 taca Exp $
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
@@ -24596,7 +24554,7 @@ fi
@@ -24712,7 +24670,7 @@ fi
if test "$found_openssl" = "no"; then
if test "$PHP_OPENSSL_DIR" = "yes"; then
@ -67,7 +67,7 @@ $NetBSD: patch-configure,v 1.1 2014/11/24 15:37:08 taca Exp $
fi
for i in $PHP_OPENSSL_DIR; do
@@ -26751,7 +26709,7 @@ $as_echo "yes" >&6; }
@@ -26868,7 +26826,7 @@ $as_echo "yes" >&6; }
PHP_SQLITE3_CFLAGS="-I@ext_srcdir@/libsqlite $other_flags $threadsafe_flags $debug_flags"
@ -76,7 +76,7 @@ $NetBSD: patch-configure,v 1.1 2014/11/24 15:37:08 taca Exp $
unique=`echo $header_file|$SED 's/[^a-zA-Z0-9]/_/g'`
@@ -37864,7 +37822,7 @@ fi
@@ -37981,7 +37939,7 @@ fi
if test "$found_openssl" = "no"; then
if test "$PHP_OPENSSL_DIR" = "yes"; then
@ -85,7 +85,7 @@ $NetBSD: patch-configure,v 1.1 2014/11/24 15:37:08 taca Exp $
fi
for i in $PHP_OPENSSL_DIR; do
@@ -49266,7 +49224,7 @@ fi
@@ -49593,7 +49551,7 @@ fi
if test "$found_openssl" = "no"; then
if test "$PHP_OPENSSL_DIR" = "yes"; then
@ -94,7 +94,7 @@ $NetBSD: patch-configure,v 1.1 2014/11/24 15:37:08 taca Exp $
fi
for i in $PHP_OPENSSL_DIR; do
@@ -66188,7 +66146,7 @@ rm -f core *.core core.conftest.* gmon.o
@@ -66618,7 +66576,7 @@ rm -f core *.core core.conftest.* gmon.o
fi
@ -103,7 +103,7 @@ $NetBSD: patch-configure,v 1.1 2014/11/24 15:37:08 taca Exp $
as_fn_error $? "Don't know how to define struct flock on this system, set --enable-opcache=no" "$LINENO" 5
fi
@@ -106720,12 +106678,7 @@ old_CC=$CC
@@ -107099,12 +107057,7 @@ old_CC=$CC
if test "$PHP_THREAD_SAFETY" = "yes" && test -n "$ac_cv_pthreads_cflags"; then
CXXFLAGS="$CXXFLAGS $ac_cv_pthreads_cflags"
INLINE_CFLAGS="$INLINE_CFLAGS $ac_cv_pthreads_cflags"
@ -117,30 +117,3 @@ $NetBSD: patch-configure,v 1.1 2014/11/24 15:37:08 taca Exp $
fi
if test "$PHP_THREAD_SAFETY" = "yes" && test "$PHP_MYSQL" = "yes"; then
@@ -110497,7 +110450,7 @@ freebsd* | dragonfly*)
objformat=`/usr/bin/objformat`
else
case $host_os in
- freebsd[123]*) objformat=aout ;;
+ freebsd[123]|freebsd[123].*) objformat=aout ;;
*) objformat=elf ;;
esac
fi
@@ -112577,7 +112530,7 @@ if test -z "$aix_libpath"; then aix_libp
;;
esac
;;
- freebsd[12]*)
+ freebsd[12]|freebsd[12].*)
# C++ shared libraries reported to be fairly broken before switch to ELF
ld_shlibs_CXX=no
;;
@@ -114130,7 +114083,7 @@ freebsd* | dragonfly*)
objformat=`/usr/bin/objformat`
else
case $host_os in
- freebsd[123]*) objformat=aout ;;
+ freebsd[123]|freebsd[123].*) objformat=aout ;;
*) objformat=elf ;;
esac
fi