* Update ncurses dependency.

* Use more extensible way of passing necessary -I flags to configure.
This commit is contained in:
jlam 1999-07-06 08:06:29 +00:00
parent a48bf91fc2
commit 368526047e
2 changed files with 21 additions and 13 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.9 1999/05/26 22:37:58 tron Exp $
# $NetBSD: Makefile,v 1.10 1999/07/06 08:06:29 jlam Exp $
DISTNAME= ntop-1.0
CATEGORIES= net
@ -6,25 +6,19 @@ MASTER_SITES= ftp://ftp.unipi.it/pub/local/ntop/source/
EXTRACT_SUFX= .src.tar.gz
MAINTAINER= kim@tac.nyc.ny.us
BUILD_DEPENDS= autoconf:../../devel/autoconf
DEPENDS= ncurses-1.9.9g:../../devel/ncurses
HOMEPAGE= http://www-serra.unipi.it/~ntop/
NOT_FOR_PLATFORM= *-*-alpha *-*-mips # elf problems WRT libcurses
BUILD_DEPENDS+= autoconf:../../devel/autoconf
DEPENDS+= ncurses-4.2:../../devel/ncurses
HAS_CONFIGURE= yes
GNU_CONFIGURE= yes
CFLAGS+= -I${PREFIX}/include
LDFLAGS+= -L${PREFIX}/lib
CONFIGURE_ENV+= CPPFLAGS=-I${PREFIX}/include
CONFIGURE_ENV+= CFLAGS=-I${PREFIX}/include
CONFIGURE_ENV+= LDFLAGS=-L${PREFIX}/lib
CPPFLAGS+= -I${LOCALBASE}/include # for ncurses.h
LDFLAGS+= -L${LOCALBASE}/lib # for -lncurses
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
pre-configure:
(cd ${WRKSRC}; autoconf)
( cd ${WRKSRC}; autoconf )
.include "../../mk/bsd.pkg.mk"

14
net/ntop/patches/patch-ag Normal file
View file

@ -0,0 +1,14 @@
$NetBSD: patch-ag,v 1.1 1999/07/06 08:06:30 jlam Exp $
--- Makefile.in.orig Tue Oct 6 11:27:31 1998
+++ Makefile.in Fri Jul 2 14:19:28 1999
@@ -42,7 +42,8 @@
DEFS = @DEFS@
# Standard CFLAGS
-CFLAGS = $(CCOPT) $(DEFS) $(INCLS)
+CPPFLAGS = @CPPFLAGS@
+CFLAGS = $(CCOPT) $(CPPFLAGS) $(DEFS) $(INCLS)
# Standard LDFLAGS
LDFLAGS = @LDFLAGS@