The pth-current pkg has been obsoleted by the pth package.
This commit is contained in:
parent
5e36361531
commit
368610fea8
9 changed files with 1 additions and 102 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.116 2000/05/24 05:56:10 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.117 2000/06/18 09:22:48 soren Exp $
|
||||
# FreeBSD Id: Makefile,v 1.78 1997/10/01 08:32:59 cracauer Exp
|
||||
#
|
||||
|
||||
|
@ -96,7 +96,6 @@
|
|||
SUBDIR += pcre
|
||||
SUBDIR += prcs
|
||||
SUBDIR += pth
|
||||
# SUBDIR += pth-current
|
||||
SUBDIR += ptl2
|
||||
SUBDIR += py-curses
|
||||
SUBDIR += rcs
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.10 2000/06/01 11:23:24 rh Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pth-1.3b1
|
||||
PKGNAME= ${DISTNAME:S/-/-current-/}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://alpha.gnu.org/gnu/pth/
|
||||
|
||||
MAINTAINER= wiz@netbsd.org
|
||||
HOMEPAGE= http://www.gnu.org/software/pth/pth.html
|
||||
|
||||
IGNORE= "superseded by pth package"
|
||||
|
||||
CONFLICTS= pth-*
|
||||
|
||||
USE_PKGLIBTOOL= YES
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --enable-pthread
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/pth/
|
||||
${INSTALL_DATA} ${WRKSRC}/pthread.ps ${PREFIX}/share/doc/pth/
|
||||
${INSTALL_DATA} ${WRKSRC}/rse-pmt.ps ${PREFIX}/share/doc/pth/
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,3 +0,0 @@
|
|||
$NetBSD: md5,v 1.5 2000/02/05 14:58:30 wiz Exp $
|
||||
|
||||
MD5 (pth-1.3b1.tar.gz) = 217fd858217143c5b9ae5b8bd0349884
|
|
@ -1,4 +0,0 @@
|
|||
$NetBSD: patch-sum,v 1.3 2000/01/21 01:30:57 wiz Exp $
|
||||
|
||||
MD5 (patch-aa) = 6ebbd4c02edc467da6f2e3f608c289e2
|
||||
MD5 (patch-ab) = 09b3e6c704dca512ab3979a20c78596c
|
|
@ -1,33 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2000/01/06 04:18:39 wiz Exp $
|
||||
|
||||
--- Makefile.in.orig Thu Dec 30 22:57:25 1999
|
||||
+++ Makefile.in Thu Jan 6 04:53:19 2000
|
||||
@@ -53,10 +53,10 @@
|
||||
CC = @CC@
|
||||
CPPFLAGS = @CPPFLAGS@ -I.
|
||||
CFLAGS = @CFLAGS@
|
||||
-LDFLAGS = @LDFLAGS@ -L.
|
||||
+LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
||||
SHTOOL = $(srcdir)/shtool
|
||||
-LIBTOOL = $(C)libtool
|
||||
+LIBTOOL = @LIBTOOL@
|
||||
RM = rm -f
|
||||
RMDIR = rmdir
|
||||
TRUE = true
|
||||
@@ -226,13 +226,13 @@
|
||||
$(SHTOOL) install -c -m 644 $(S)pth.3 $(mandir)/man3/pth.3
|
||||
$(SHTOOL) install -c -m 644 pth.m4 $(datadir)/aclocal/pth.m4
|
||||
$(SHTOOL) install -c -m 644 pth.h $(includedir)/pth.h
|
||||
- @$(LIBTOOL) --mode=install $(SHTOOL) install -c -m 644 libpth.la $(libdir)/libpth.la
|
||||
+ @$(LIBTOOL) --mode=install install -c -m 644 libpth.la $(libdir)/libpth.la
|
||||
install-pthread:
|
||||
$(SHTOOL) install -c -m 755 pthread-config $(bindir)/pthread-config
|
||||
$(SHTOOL) install -c -m 644 $(S)pthread-config.1 $(mandir)/man1/pthread-config.1
|
||||
$(SHTOOL) install -c -m 644 pthread.h $(includedir)/pthread.h
|
||||
$(SHTOOL) install -c -m 644 $(S)pthread.3 $(mandir)/man3/pthread.3
|
||||
- @$(LIBTOOL) --mode=install $(SHTOOL) install -c -m 644 libpthread.la $(libdir)/libpthread.la
|
||||
+ @$(LIBTOOL) --mode=install install -c -m 644 libpthread.la $(libdir)/libpthread.la
|
||||
|
||||
# uninstall the package
|
||||
uninstall:
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.4 2000/01/21 01:30:57 wiz Exp $
|
||||
|
||||
--- configure.orig Thu Jan 6 16:50:11 2000
|
||||
+++ configure Fri Jan 21 02:08:19 2000
|
||||
@@ -5606,6 +5606,7 @@
|
||||
s%@PTHREAD_O@%$PTHREAD_O%g
|
||||
s%@LIBPTHREAD_A@%$LIBPTHREAD_A%g
|
||||
s%@LIBPTHREAD_LA@%$LIBPTHREAD_LA%g
|
||||
+s%@LIBTOOL@%$LIBTOOL%g
|
||||
s%@PTHREAD_CONFIG_1@%$PTHREAD_CONFIG_1%g
|
||||
s%@PTHREAD_3@%$PTHREAD_3%g
|
||||
s%@INSTALL_PTHREAD@%$INSTALL_PTHREAD%g
|
|
@ -1 +0,0 @@
|
|||
GNU Portable Thread library
|
|
@ -1,5 +0,0 @@
|
|||
PTH is a very portable POSIX/ANSI-C based library for Unix platforms which
|
||||
provides non-preemptive scheduling for multiple threads of execution
|
||||
("multithreading") inside server applications. All threads run in the same
|
||||
address space of the server application, but each thread has its own
|
||||
individual program-counter, run-time stack, signal mask and errno variable.
|
|
@ -1,17 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2000/01/21 03:09:36 wiz Exp $
|
||||
bin/pth-config
|
||||
bin/pthread-config
|
||||
include/pth.h
|
||||
include/pthread.h
|
||||
lib/libpth.a
|
||||
lib/libpth.so.13.0
|
||||
lib/libpthread.a
|
||||
lib/libpthread.so.13.0
|
||||
man/man1/pth-config.1
|
||||
man/man1/pthread-config.1
|
||||
man/man3/pth.3
|
||||
man/man3/pthread.3
|
||||
share/aclocal/pth.m4
|
||||
share/doc/pth/pthread.ps
|
||||
share/doc/pth/rse-pmt.ps
|
||||
@dirrm share/doc/pth
|
Loading…
Reference in a new issue