Delete ruby14-readline package. It is time to retire now.

This commit is contained in:
taca 2002-06-09 11:20:56 +00:00
parent 4d086eca9e
commit 369f5605f0
7 changed files with 1 additions and 109 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.291 2002/06/08 17:34:09 cjep Exp $
# $NetBSD: Makefile,v 1.292 2002/06/09 11:20:56 taca Exp $
#
COMMENT= Development utilities
@ -276,7 +276,6 @@ SUBDIR+= ruby-ri
SUBDIR+= ruby-strscan
SUBDIR+= ruby-textbuf
SUBDIR+= ruby-unit
#SUBDIR+= ruby14-readline # only needed for ruby-1.4 package
SUBDIR+= rvm
SUBDIR+= rx
SUBDIR+= sdcc

View file

@ -1,2 +0,0 @@
This is a Ruby extension to the readline library, which is actually a
part of the Ruby distribution.

View file

@ -1,28 +0,0 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/06/30 08:27:40 taca Exp $
#
DISTNAME= ${RUBY_DISTNAME}
PKGNAME= ${RUBY_PKGNAMEPREFIX}readline-${RUBY_VERSION}
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_RUBY}
MAINTAINER= taca@netbsd.org
HOMEPAGE= http://www.ruby-lang.org/en/
COMMENT= Ruby 1.4 extension to readline library
DEPENDS+= readline>=4.0:../../devel/readline
DIST_SUBDIR= ruby
WRKSRC= ${RUBY_WRKSRC}/ext/readline
EXTRACT_ELEMENTS= ${RUBY_DISTNAME}/ext/readline
USE_RUBY_EXTCONF= yes
RUBY_VER= 1.4
post-install:
${INSTALL_DATA_DIR} ${RUBY_DOCDIR}/readline/ja
${INSTALL_DATA} ${RUBY_WRKSRC}/ext/readline/README \
${RUBY_DOCDIR}/readline/ja
.include "../../lang/ruby-base/Makefile.common"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +0,0 @@
@comment $NetBSD: PLIST,v 1.1 2001/11/01 01:26:36 zuntum Exp $
${RUBY_ARCHLIBDIR}/readline.so
${RUBY_DOCDIR}/readline/ja/README
@dirrm ${RUBY_DOCDIR}/readline/ja
@dirrm ${RUBY_DOCDIR}/readline

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.2 2002/01/22 16:46:59 taca Exp $
SHA1 (ruby/ruby-1.4.6.tar.gz) = 662e21cd2f6bf521a77ab179e11b669738579cc5
Size (ruby/ruby-1.4.6.tar.gz) = 775123 bytes
SHA1 (patch-aa) = 4ccf50dcbcb7ba752f63e548d31d22db7bf01e2d
SHA1 (patch-ab) = 6d530e2aa5e402961f4dae0e15c5b00d039c3d8b

View file

@ -1,21 +0,0 @@
$NetBSD: patch-aa,v 1.2 2002/01/22 16:47:00 taca Exp $
--- extconf.rb.orig Fri Jun 2 22:28:04 2000
+++ extconf.rb
@@ -2,12 +2,14 @@
dir_config("readline")
have_library("user32", nil) if /cygwin/ === RUBY_PLATFORM
-have_library("ncurses", "tgetnum") or
- have_library("termcap", "tgetnum") or
+have_library("termcap", "tgetnum") or
have_library("curses", "tgetnum")
if have_header("readline/readline.h") and
have_header("readline/history.h") and
have_library("readline", "readline")
+ if have_func("rl_filename_completion_function")
+ $CFLAGS += " -DREADLINE_42_OR_LATER"
+ end
create_makefile("readline")
end

View file

@ -1,45 +0,0 @@
$NetBSD: patch-ab,v 1.1 2002/01/22 16:47:00 taca Exp $
--- readline.c.orig Fri Aug 13 14:37:50 1999
+++ readline.c
@@ -15,11 +15,18 @@
#define COMPLETION_PROC "completion_proc"
#define COMPLETION_CASE_FOLD "completion_case_fold"
+#ifndef READLINE_42_OR_LATER
+# define rl_filename_completion_function filename_completion_function
+# define rl_username_completion_function username_completion_function
+# define rl_completion_matches completion_matches
+#endif
+
static int
readline_event()
{
CHECK_INTS;
rb_thread_schedule();
+ return 0;
}
static VALUE
@@ -321,8 +328,8 @@
char **matches;
int i;
- matches = completion_matches(STR2CSTR(str),
- filename_completion_function);
+ matches = rl_completion_matches(STR2CSTR(str),
+ rl_filename_completion_function);
if (matches) {
result = rb_ary_new();
for (i = 0; matches[i]; i++) {
@@ -348,8 +355,8 @@
char **matches;
int i;
- matches = completion_matches(STR2CSTR(str),
- username_completion_function);
+ matches = rl_completion_matches(STR2CSTR(str),
+ rl_username_completion_function);
if (matches) {
result = rb_ary_new();
for (i = 0; matches[i]; i++) {