New "wwwoffle-2.1c" package made by Mario Kemper:

WWW proxy with support for offline browsing
This commit is contained in:
tron 1998-06-06 17:03:58 +00:00
parent 0c5b977ef7
commit 36e6c1efcf
8 changed files with 84 additions and 0 deletions

29
www/wwwoffle/Makefile Normal file
View file

@ -0,0 +1,29 @@
# $NetBSD: Makefile,v 1.1 1998/06/06 17:03:58 tron Exp $
DISTNAME= wwwoffle-2.1c
CATEGORIES= www
MASTER_SITES= http://www.gedanken.demon.co.uk/wwwoffle/version-2.1/
EXTRACT_SUFX= .tgz
MAINTAINER= magick@bundy.lip.owl.de
USE_GMAKE= yes
NO_CONFIGURE= yes
MAN1= wwwoffle.1
MAN5= wwwoffle.conf.5
MAN8= wwwoffled.8
post-build:
${SED} s#@PREFIX@#${PREFIX}#g <${FILESDIR}/wwwoffle.sh \
>${WRKDIR}/wwwoffle.sh
pre-install:
${MKDIR} ${PREFIX}/etc/wwwoffle
post-install:
${CP} ${PREFIX}/etc/wwwoffle/wwwoffle.conf \
${PREFIX}/etc/wwwoffle/wwwoffle.conf.default
${INSTALL_SCRIPT} ${WRKDIR}/wwwoffle.sh ${PREFIX}/etc/rc.d
.include "../../mk/bsd.pkg.mk"

1
www/wwwoffle/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (wwwoffle-2.1c.tgz) = d55e936eabd30ee0d1ab0eb6948d4dd3

View file

@ -0,0 +1,10 @@
#!/bin/sh
#
# $NetBSD: wwwoffle.sh,v 1.1 1998/06/06 17:03:58 tron Exp $
#
if [ -x @PREFIX@/sbin/wwwoffled -a -f @PREFIX@/etc/wwwoffle/wwwoffle.conf ];
then
@PREFIX@/sbin/wwwoffled -c @PREFIX@/etc/wwwoffle/wwwoffle.conf >/dev/null 2>&1 &
echo -n ' wwwoffled'
fi
exit 0

View file

@ -0,0 +1,24 @@
--- Makefile.orig Sat Jun 6 18:02:38 1998
+++ Makefile Sat Jun 6 18:05:01 1998
@@ -14,17 +14,17 @@
########
-INSTDIR=/usr/local
+INSTDIR=${PREFIX}
SPOOLDIR=/var/spool/wwwoffle
-CONFDIR=/var/spool/wwwoffle
+CONFDIR=${PREFIX}/etc/wwwoffle
########
CC=gcc
-CFLAGS=-O2 -Wall -g
+CFLAGS=-O2 -Wall
LD=gcc
-LDFLAGS=-g
+LDFLAGS=-s
LEX=flex -i -L

1
www/wwwoffle/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
WWW proxy with support for offline browsing

3
www/wwwoffle/pkg/DESCR Normal file
View file

@ -0,0 +1,3 @@
The wwwoffled program is a simple proxy server with special features for use
with dial-up internet links. This means that it is possible to browse web
pages and read them without having to remain connected.

1
www/wwwoffle/pkg/MESSAGE Normal file
View file

@ -0,0 +1 @@
Please add "${PREFIX}/etc/rc.d/wwwoffle.sh" to "/etc/rc.local".

15
www/wwwoffle/pkg/PLIST Normal file
View file

@ -0,0 +1,15 @@
@comment $NetBSD: PLIST,v 1.1 1998/06/06 17:03:59 tron Exp $
bin/wwwoffle
bin/wwwoffle-tools
bin/wwwoffle-ls
bin/wwwoffle-mv
bin/wwwoffle-rm
etc/rc.d/wwwoffle.sh
man/man1/wwwoffle.1
man/man5/wwwoffle.conf.5
man/man8/wwwoffled.8
sbin/wwwoffled
etc/wwwoffle/wwwoffle.conf.default
@exec cp %F %D/etc/wwwoffle/wwwoffle.conf
@unexec rm -f %D/etc/wwwoffle/wwwoffle.conf
@dirrm etc/wwwoffle