Update to 0.99.13. From the changelog:
* GNUTLS support hasn't been working for a while, so it's not even tried to be used anymore unless explicitly wanted. + Added CRAM-MD5 authentication mechanism. Patch by Joshua Goodall + Added SMD5 and LDAP-MD5 password schemes and changed MD5 scheme to use LDAP-MD5 if the password isn't in MD5crypt format. Patch by Joshua Goodall + Workaround for some POP3 client bugs: if message doesn't contain the "end of headers" empty line, add it automatically. + vpopmail supports now all password schemes, most importantly MD5crypt works now without support from libc's crypt() - SQL and LDAP authentication was broken - SEARCH UNKEYWORD wasn't working pkgsrc changes: * Disable GNU TLS support for the time being. * Move the workaround for the gcc2 sparc64 ICE into hacks.mk. * Format DESCR.
This commit is contained in:
parent
a803ed79fc
commit
371dbaab81
8 changed files with 49 additions and 54 deletions
|
@ -1,3 +1,4 @@
|
|||
Dovecot is a secure and compact IMAP/POP3 server which is in the early stages
|
||||
of development. It supports Maildirs and mbox formats and much of the IMAP
|
||||
v4 protocol including SSL/TLS. IPv6 support is also included.
|
||||
Dovecot is a secure and compact IMAP/POP3 server which is in the
|
||||
early stages of development. It supports Maildirs and mbox formats
|
||||
and much of the IMAP v4 protocol including SSL/TLS. IPv6 support
|
||||
is also included.
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.30 2004/12/28 02:47:44 reed Exp $
|
||||
# $NetBSD: Makefile,v 1.31 2005/01/08 19:58:16 schmonz Exp $
|
||||
|
||||
DISTNAME= dovecot-0.99.12.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= dovecot-0.99.13
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.dovecot.org/releases/
|
||||
|
||||
|
@ -18,18 +17,15 @@ COMMENT= Secure IMAP and POP3 server
|
|||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/.1$//}
|
||||
USE_BUILDLINK3= YES
|
||||
USE_LIBTOOL= YES
|
||||
USE_PKGINSTALL= YES
|
||||
GNU_CONFIGURE= YES
|
||||
USE_BUILDLINK3= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_PKGINSTALL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
|
||||
CONFIGURE_ARGS+= --with-ssldir=${SSLCERTS}
|
||||
|
||||
# Avoid an ICE in gcc2 on sparc64
|
||||
CONFIGURE_ENV+= F77=${FALSE}
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.include "options.mk"
|
||||
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2004/05/29 15:42:51 cube Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2005/01/08 19:58:16 schmonz Exp $
|
||||
libexec/dovecot/dovecot-auth
|
||||
libexec/dovecot/imap
|
||||
libexec/dovecot/imap-login
|
||||
libexec/dovecot/pop3
|
||||
libexec/dovecot/pop3-login
|
||||
sbin/dovecot
|
||||
share/doc/dovecot/USE-WIKI-INSTEAD
|
||||
share/doc/dovecot/auth.txt
|
||||
share/doc/dovecot/configuration.txt
|
||||
share/doc/dovecot/design.txt
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.15 2004/12/21 00:00:34 xtraeme Exp $
|
||||
$NetBSD: distinfo,v 1.16 2005/01/08 19:58:16 schmonz Exp $
|
||||
|
||||
SHA1 (dovecot-0.99.12.1.tar.gz) = a587ffdefbf9a90fa91ed506645c9d962112f1b0
|
||||
Size (dovecot-0.99.12.1.tar.gz) = 864722 bytes
|
||||
SHA1 (patch-aa) = 862a27a1fe59108a519a59e14341ca418ba39ec5
|
||||
SHA1 (patch-ab) = 00f9e92824af89ce15c2493e0a92046e8db18fac
|
||||
SHA1 (dovecot-0.99.13.tar.gz) = 2f13ca61d492b9672dc64434c3dd3b9c3bb37f30
|
||||
Size (dovecot-0.99.13.tar.gz) = 867787 bytes
|
||||
SHA1 (patch-aa) = c1079f49bdaa2e6cf648afad2c7bda025e2c1ac8
|
||||
SHA1 (patch-ab) = 75c8560479dcec3cb7e5c08030303959fcee30ea
|
||||
|
|
9
mail/dovecot/hacks.mk
Normal file
9
mail/dovecot/hacks.mk
Normal file
|
@ -0,0 +1,9 @@
|
|||
# $NetBSD: hacks.mk,v 1.1 2005/01/08 19:58:16 schmonz Exp $
|
||||
|
||||
.include "../../mk/compiler.mk"
|
||||
|
||||
# Avoid an ICE in gcc2 on sparc64
|
||||
.if !empty(CC_VERSION:Mgcc-*)
|
||||
PKG_HACKS+= sparc64-gcc2-ice
|
||||
CONFIGURE_ENV+= F77=${FALSE}
|
||||
.endif
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.5 2004/11/17 19:56:49 xtraeme Exp $
|
||||
# $NetBSD: options.mk,v 1.6 2005/01/08 19:58:16 schmonz Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.dovecot
|
||||
PKG_SUPPORTED_OPTIONS= gnutls inet6 ldap mysql pgsql sasl
|
||||
|
@ -8,6 +8,7 @@ PKG_SUPPORTED_OPTIONS= gnutls inet6 ldap mysql pgsql sasl
|
|||
### Build with GNU TLS or OpenSSL as the underlying crypto library.
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mgnutls)
|
||||
PKG_FAIL_REASON+= "GNU TLS support is currently broken."
|
||||
CONFIGURE_ARGS+= --enable-ssl=gnutls
|
||||
. include "../../security/gnutls/buildlink3.mk"
|
||||
.else
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.3 2004/08/01 05:17:19 schmonz Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2005/01/08 19:58:16 schmonz Exp $
|
||||
|
||||
--- Makefile.in.orig 2004-07-30 20:04:57.000000000 -0400
|
||||
--- Makefile.in.orig 2005-01-06 13:28:47.000000000 -0500
|
||||
+++ Makefile.in
|
||||
@@ -101,7 +101,7 @@ ssldir = @ssldir@
|
||||
SUBDIRS = src doc
|
||||
|
||||
confdir = $(sysconfdir)
|
||||
-conf_DATA = dovecot-example.conf
|
||||
+conf_DATA =
|
||||
+conf_DATA =
|
||||
|
||||
EXTRA_DIST = config.rpath dovecot.spec dovecot.spec.in COPYING.LGPL $(conf_DATA)
|
||||
|
||||
|
|
|
@ -1,20 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.6 2004/08/01 05:17:19 schmonz Exp $
|
||||
$NetBSD: patch-ab,v 1.7 2005/01/08 19:58:16 schmonz Exp $
|
||||
|
||||
--- dovecot-example.conf.orig 2004-07-13 06:56:55.000000000 -0400
|
||||
--- dovecot-example.conf.orig 2004-12-29 13:00:24.000000000 -0500
|
||||
+++ dovecot-example.conf
|
||||
@@ -1,17 +1,15 @@
|
||||
## Dovecot 1.0 configuration file
|
||||
|
||||
# Default values are shown after each value, it's not required to uncomment
|
||||
-# any of the lines. Exception to this are paths, they're just examples
|
||||
-# with real defaults being based on configure options. The paths listed here
|
||||
-# are for configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
|
||||
-# --with-ssldir=/etc/ssl
|
||||
+# any of the lines. Exception to this are paths, they're just examples with
|
||||
+# real defaults being based on configure options.
|
||||
|
||||
# Base directory where to store runtime data.
|
||||
#base_dir = /var/run/dovecot/
|
||||
@@ -11,7 +11,7 @@
|
||||
|
||||
# Protocols we want to be serving:
|
||||
# imap imaps pop3 pop3s
|
||||
|
@ -23,7 +11,7 @@ $NetBSD: patch-ab,v 1.6 2004/08/01 05:17:19 schmonz Exp $
|
|||
|
||||
# IP or host address where to listen in for connections. It's not currently
|
||||
# possible to specify multiple addresses. "*" listens in all IPv4 interfaces.
|
||||
@@ -27,7 +25,7 @@
|
||||
@@ -27,7 +27,7 @@
|
||||
#pop3s_listen =
|
||||
|
||||
# Disable SSL/TLS support.
|
||||
|
@ -32,39 +20,39 @@ $NetBSD: patch-ab,v 1.6 2004/08/01 05:17:19 schmonz Exp $
|
|||
|
||||
# PEM encoded X.509 SSL/TLS certificate and private key. They're opened before
|
||||
# dropping root privileges, so keep the key file unreadable by anyone but
|
||||
@@ -82,7 +80,7 @@
|
||||
@@ -85,7 +85,7 @@
|
||||
login = imap
|
||||
|
||||
# Executable location.
|
||||
-#login_executable = /usr/libexec/dovecot/imap-login
|
||||
+login_executable = @PREFIX@/libexec/dovecot/imap-login
|
||||
+#login_executable = @PREFIX@/libexec/dovecot/imap-login
|
||||
|
||||
# User to use for the login process. Create a completely new user for this,
|
||||
# and don't use it anywhere else. The user must also belong to a group where
|
||||
@@ -127,7 +125,7 @@ login = imap
|
||||
@@ -132,7 +132,7 @@ login = imap
|
||||
login = pop3
|
||||
|
||||
# Exception to above rule being the executable location.
|
||||
-#login_executable = /usr/libexec/dovecot/pop3-login
|
||||
+login_executable = @PREFIX@/libexec/dovecot/pop3-login
|
||||
+#login_executable = @PREFIX@/libexec/dovecot/pop3-login
|
||||
|
||||
##
|
||||
## Mail processes
|
||||
@@ -333,7 +331,7 @@ login = pop3
|
||||
@@ -338,7 +338,7 @@ login = pop3
|
||||
##
|
||||
|
||||
# Executable location
|
||||
-#imap_executable = /usr/libexec/dovecot/imap
|
||||
+imap_executable = @PREFIX@/libexec/dovecot/imap
|
||||
+#imap_executable = @PREFIX@/libexec/dovecot/imap
|
||||
|
||||
# Set max. process size in megabytes. Most of the memory goes to mmap()ing
|
||||
# files, so it shouldn't harm much even if this limit is set pretty high.
|
||||
@@ -341,14 +339,14 @@ login = pop3
|
||||
@@ -346,14 +346,14 @@ login = pop3
|
||||
|
||||
# Support for dynamically loadable modules.
|
||||
#imap_use_modules = no
|
||||
-#imap_modules = /usr/lib/dovecot/imap
|
||||
+imap_modules = @PREFIX@/lib/dovecot/imap
|
||||
+#imap_modules = @PREFIX@/lib/dovecot/imap
|
||||
|
||||
##
|
||||
## POP3 process
|
||||
|
@ -72,29 +60,28 @@ $NetBSD: patch-ab,v 1.6 2004/08/01 05:17:19 schmonz Exp $
|
|||
|
||||
# Executable location
|
||||
-#pop3_executable = /usr/libexec/dovecot/pop3
|
||||
+pop3_executable = @PREFIX@/libexec/dovecot/pop3
|
||||
+#pop3_executable = @PREFIX@/libexec/dovecot/pop3
|
||||
|
||||
# Set max. process size in megabytes. Most of the memory goes to mmap()ing
|
||||
# files, so it shouldn't harm much even if this limit is set pretty high.
|
||||
@@ -356,7 +354,7 @@ login = pop3
|
||||
@@ -361,7 +361,7 @@ login = pop3
|
||||
|
||||
# Support for dynamically loadable modules.
|
||||
#pop3_use_modules = no
|
||||
-#pop3_modules = /usr/lib/dovecot/pop3
|
||||
+pop3_modules = @PREFIX@/lib/dovecot/pop3
|
||||
+#pop3_modules = @PREFIX@/lib/dovecot/pop3
|
||||
|
||||
##
|
||||
## Authentication processes
|
||||
@@ -406,9 +404,10 @@ auth_userdb = passwd
|
||||
@@ -438,9 +438,9 @@ auth_userdb = passwd
|
||||
# vpopmail: vpopmail authentication
|
||||
# ldap <config path>: LDAP, see doc/dovecot-ldap.conf
|
||||
# pgsql <config path>: a PostgreSQL database, see doc/dovecot-pgsql.conf
|
||||
-auth_passdb = pgsql /usr/local/etc/dovecot-pgsql.conf
|
||||
+#auth_passdb = pgsql /usr/local/etc/dovecot-pgsql.conf
|
||||
-auth_passdb = pam
|
||||
+auth_passdb = passwd
|
||||
|
||||
-#auth_executable = /usr/libexec/dovecot/dovecot-auth
|
||||
+auth_executable = @PREFIX@/libexec/dovecot/dovecot-auth
|
||||
+#auth_executable = @PREFIX@/libexec/dovecot/dovecot-auth
|
||||
|
||||
# Set max. process size in megabytes.
|
||||
#auth_process_size = 256
|
||||
|
|
Loading…
Reference in a new issue