Update to 1.2.1:
* Version 1.2.1 (2005-04-04) - gnutls_bye() will no longer fail when RDWR is used and application data are available for reading. - Added more strict checks for the SRP parameters (g,n), when they are not in the included list. - Added warning to certtool when MD5 is being used for digital signatures. - Optimizations ("-O2 -finline-functions") are not enabled by default, instead the standard autoconf defaults are used. Use `./configure CFLAGS="-O2 -finline-functions"' to get the old optimizations. - Added the option --get-dh-params to certtool, in order to get the included in the library primes and generators. - Improved the semantics of GNUTLS_VERIFY_ALLOW_X509_V1_CA_CRT, to allow only trusted Version 1 CAs and introduced GNUTLS_VERIFY_ALLOW_ANY_X509_V1_CA_CRT which has the old semantics. - Nettle self tests now build properly, reported by Pierre - Eliminated some memory leaks in DHE and RSA-EXPORT cipher suites. Reported by Yoann Vandoorselaere - Added the functions: gnutls_x509_crt_list_import(), gnutls_x509_crq_get_attribute_by_oid(), gnutls_x509_crq_set_attribute_by_oid() and gnutls_x509_crt_set_extension_by_oid(). - If the library has been compiled with features disabled, a warning is issued during the compilation of any program.
This commit is contained in:
parent
6791d8d836
commit
373dc70217
4 changed files with 12 additions and 22 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.25 2005/02/25 15:23:24 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.26 2005/04/08 15:50:41 wiz Exp $
|
||||
|
||||
DISTNAME= gnutls-1.2.0
|
||||
DISTNAME= gnutls-1.2.1
|
||||
CATEGORIES= security devel
|
||||
MASTER_SITES= http://josefsson.org/gnutls/releases/ \
|
||||
ftp://ftp.gnutls.org/pub/gnutls/ \
|
||||
|
@ -18,6 +18,7 @@ PKG_INSTALLATION_TYPES= overwrite pkgviews
|
|||
USE_BUILDLINK3= YES
|
||||
USE_LIBTOOL= YES
|
||||
GNU_CONFIGURE= YES
|
||||
TEST_TARGET= check
|
||||
|
||||
INFO_FILES= gnutls.info
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.12 2005/02/19 00:14:23 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.13 2005/04/08 15:50:41 wiz Exp $
|
||||
bin/certtool
|
||||
bin/gnutls-cli
|
||||
bin/gnutls-cli-debug
|
||||
|
@ -23,8 +23,6 @@ man/man1/gnutls-cli-debug.1
|
|||
man/man1/gnutls-cli.1
|
||||
man/man1/gnutls-serv.1
|
||||
man/man1/srptool.1
|
||||
man/man3/_gnutls_x509_get_raw_crt_activation_time.3
|
||||
man/man3/_gnutls_x509_get_raw_crt_expiration_time.3
|
||||
man/man3/gnutls_alert_get.3
|
||||
man/man3/gnutls_alert_get_name.3
|
||||
man/man3/gnutls_alert_send.3
|
||||
|
@ -286,6 +284,7 @@ man/man3/gnutls_x509_crl_sign2.3
|
|||
man/man3/gnutls_x509_crl_verify.3
|
||||
man/man3/gnutls_x509_crq_deinit.3
|
||||
man/man3/gnutls_x509_crq_export.3
|
||||
man/man3/gnutls_x509_crq_get_attribute_by_oid.3
|
||||
man/man3/gnutls_x509_crq_get_challenge_password.3
|
||||
man/man3/gnutls_x509_crq_get_dn.3
|
||||
man/man3/gnutls_x509_crq_get_dn_by_oid.3
|
||||
|
@ -294,6 +293,7 @@ man/man3/gnutls_x509_crq_get_pk_algorithm.3
|
|||
man/man3/gnutls_x509_crq_get_version.3
|
||||
man/man3/gnutls_x509_crq_import.3
|
||||
man/man3/gnutls_x509_crq_init.3
|
||||
man/man3/gnutls_x509_crq_set_attribute_by_oid.3
|
||||
man/man3/gnutls_x509_crq_set_challenge_password.3
|
||||
man/man3/gnutls_x509_crq_set_dn_by_oid.3
|
||||
man/man3/gnutls_x509_crq_set_key.3
|
||||
|
@ -333,6 +333,7 @@ man/man3/gnutls_x509_crt_get_subject_key_id.3
|
|||
man/man3/gnutls_x509_crt_get_version.3
|
||||
man/man3/gnutls_x509_crt_import.3
|
||||
man/man3/gnutls_x509_crt_init.3
|
||||
man/man3/gnutls_x509_crt_list_import.3
|
||||
man/man3/gnutls_x509_crt_list_verify.3
|
||||
man/man3/gnutls_x509_crt_set_activation_time.3
|
||||
man/man3/gnutls_x509_crt_set_authority_key_id.3
|
||||
|
@ -341,6 +342,7 @@ man/man3/gnutls_x509_crt_set_crl_dist_points.3
|
|||
man/man3/gnutls_x509_crt_set_crq.3
|
||||
man/man3/gnutls_x509_crt_set_dn_by_oid.3
|
||||
man/man3/gnutls_x509_crt_set_expiration_time.3
|
||||
man/man3/gnutls_x509_crt_set_extension_by_oid.3
|
||||
man/man3/gnutls_x509_crt_set_issuer_dn_by_oid.3
|
||||
man/man3/gnutls_x509_crt_set_key.3
|
||||
man/man3/gnutls_x509_crt_set_key_purpose_oid.3
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.14 2005/04/03 04:50:21 minskim Exp $
|
||||
$NetBSD: distinfo,v 1.15 2005/04/08 15:50:41 wiz Exp $
|
||||
|
||||
SHA1 (gnutls-1.2.0.tar.bz2) = 618d502fc872530b726e791a818af5a95ee39d00
|
||||
RMD160 (gnutls-1.2.0.tar.bz2) = 1f03385047112721173f116821dc92680d60b687
|
||||
Size (gnutls-1.2.0.tar.bz2) = 2417909 bytes
|
||||
SHA1 (gnutls-1.2.1.tar.bz2) = 6445383421a06b9db3fa83bf6802677e809f2440
|
||||
RMD160 (gnutls-1.2.1.tar.bz2) = fa02b6b342adf07d47e7dad1ede1d7a49560e59d
|
||||
Size (gnutls-1.2.1.tar.bz2) = 2436304 bytes
|
||||
SHA1 (patch-aa) = 3b4adf0b6acde5a56c0a7f3003a0a1e90bfbd672
|
||||
SHA1 (patch-ab) = a3327de3052375acd569ee8541c90e2555e73f2d
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2005/02/19 00:14:23 wiz Exp $
|
||||
|
||||
--- configure.orig 2005-01-27 14:16:39.000000000 +0100
|
||||
+++ configure
|
||||
@@ -3651,8 +3651,6 @@ rm -f conftest.err conftest.$ac_objext c
|
||||
if test $ac_cv_c_compiler_gnu != no; then
|
||||
if test x$opt_developer_mode = xyes; then
|
||||
CFLAGS="${CFLAGS} -g -Wno-format-y2k -Wall -Wcast-align -W -Wpointer-arith -Wchar-subscripts -Wformat-security -Wmissing-braces -Winline -Wstrict-prototypes"
|
||||
- else
|
||||
- CFLAGS="${CFLAGS} -O2 -finline-functions"
|
||||
fi
|
||||
|
||||
if test x$opt_dmalloc_mode = xyes; then
|
Loading…
Reference in a new issue