Fix build with automake-1.2.

While here, add missing INSTALLATION_DIRS line (or perhaps it's a
Makefile dependency issue, but this fixes it).
This commit is contained in:
wiz 2012-05-10 10:49:49 +00:00
parent 12ad0b558d
commit 377aabb57a
3 changed files with 16 additions and 8 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.3 2011/07/13 06:36:58 tron Exp $
# $NetBSD: Makefile,v 1.4 2012/05/10 10:49:49 wiz Exp $
DISTNAME= fuse-ext2-0.0.7
PKGREVISION= 1
@ -18,6 +18,7 @@ GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= autoheader automake autoreconf gmake pkg-config
USE_LANGUAGES= c c++
INSTALLATION_DIRS= lib/umview/modules
pre-configure:
cd ${WRKSRC} && autoreconf --verbose --install --force

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.2 2011/07/09 17:22:43 tron Exp $
$NetBSD: distinfo,v 1.3 2012/05/10 10:49:49 wiz Exp $
SHA1 (fuse-ext2-0.0.7.tar.gz) = cdfef525838d2de07a4da6d60b65efce5a1cffa0
RMD160 (fuse-ext2-0.0.7.tar.gz) = 29cb85f033b65fba4d82d14de907dd4458173c2b
Size (fuse-ext2-0.0.7.tar.gz) = 570156 bytes
SHA1 (patch-aa) = e8dc764411ea62f2c714df71bee7ea06a84c337b
SHA1 (patch-aa) = 51605e31f82da8919ec5a01e10298a2f1784dc56
SHA1 (patch-ab) = 830bc968c55b13125700a6fbeff9808610d065f0
SHA1 (patch-ac) = 253561f1e6a67b5d66d7409af3bf26477ad57b2c
SHA1 (patch-af) = ced88c0a278c4924ee9fb6585271093742f0eb09

View file

@ -1,10 +1,17 @@
$NetBSD: patch-aa,v 1.1.1.1 2011/07/09 15:27:11 tron Exp $
$NetBSD: patch-aa,v 1.2 2012/05/10 10:49:49 wiz Exp $
Make automake-1.12 happy.
Add NetBSD support.
--- configure.ac.orig 2009-12-24 12:38:06.000000000 +0000
+++ configure.ac 2011-07-09 13:54:03.000000000 +0100
@@ -15,6 +15,7 @@
+++ configure.ac
@@ -11,10 +11,13 @@ AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_LIBTOOL
AC_PATH_PROG(CHMOD, chmod, :)
+AM_PROG_AR
+AM_PROG_CC_C_O
case $target_os in
*linux*) arch=linux;;
*darwin*) arch=darwin;;
@ -12,7 +19,7 @@ Add NetBSD support.
*) arch=unknown;;
esac
@@ -137,7 +138,7 @@
@@ -137,7 +140,7 @@ AC_CHECK_FUNCS([ \
])
# Checks for libraries
@ -21,7 +28,7 @@ Add NetBSD support.
AC_MSG_CHECKING([if FUSE on this system is too new for us])
AC_EGREP_CPP([fuse_version_yes], [
@@ -193,6 +194,7 @@
@@ -193,6 +196,7 @@ AC_SUBST(pkgconfigdir)
AM_CONDITIONAL(LINUX, test "$arch" = linux)
AM_CONDITIONAL(DARWIN, test "$arch" = darwin)