Build libgs as a shared library as increasingly other packages expect it
to be there and want to link with it. Bump PKGREVISION.
This commit is contained in:
parent
acacb29310
commit
377be88032
6 changed files with 80 additions and 4 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.50 2008/08/07 18:21:40 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.51 2008/09/03 21:31:12 markd Exp $
|
||||
|
||||
DISTNAME= ghostscript-8.63
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ghostscript/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -23,6 +24,10 @@ GNU_CONFIGURE= yes
|
|||
MAKE_JOBS_SAFE= no
|
||||
UNLIMIT_RESOURCES+= datasize # gsromfs1.c
|
||||
|
||||
BUILD_TARGET= so
|
||||
INSTALL_TARGET= soinstall
|
||||
CONFIGURE_ARGS+= -with-omni=no # otherwise pulls in libstdc++
|
||||
|
||||
REPLACE_PERL+= lib/fixmswrd.pl
|
||||
|
||||
GS_RESOURCEDIR= ${PREFIX}/share/ghostscript/Resource
|
||||
|
@ -58,6 +63,9 @@ post-extract:
|
|||
${MV} ${WRKSRC}/libpng ${WRKSRC}/libpng.dontuse
|
||||
# ${MV} ${WRKSRC}/zlib ${WRKSRC}/zlib.dontuse
|
||||
|
||||
post-install:
|
||||
${LN} -sf gsc ${DESTDIR}${PREFIX}/bin/gs
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.11 2008/08/07 18:21:40 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.12 2008/09/03 21:31:12 markd Exp $
|
||||
bin/bdftops
|
||||
bin/dumphint
|
||||
bin/dvipdf
|
||||
|
@ -8,10 +8,12 @@ bin/font2c
|
|||
bin/gs
|
||||
bin/gsbj
|
||||
bin/gsdj
|
||||
bin/gsc
|
||||
bin/gsdj500
|
||||
bin/gslj
|
||||
bin/gslp
|
||||
bin/gsnd
|
||||
bin/gsx
|
||||
bin/lprsetup.sh
|
||||
bin/pdf2dsc
|
||||
bin/pdf2ps
|
||||
|
@ -31,6 +33,12 @@ bin/ps2ps2
|
|||
bin/pv.sh
|
||||
bin/unix-lpr.sh
|
||||
bin/wftopfa
|
||||
include/ghostscript/gdevdsp.h
|
||||
include/ghostscript/iapi.h
|
||||
include/ghostscript/ierrors.h
|
||||
lib/libgs.so
|
||||
lib/libgs.so.8
|
||||
lib/libgs.so.${PKGVERSION}
|
||||
${PLIST.cups}libexec/cups/filter/pstopxl
|
||||
${PLIST.cups}libexec/cups/filter/pstoraster
|
||||
man/de/man1/dvipdf.1
|
||||
|
@ -687,3 +695,4 @@ share/ghostscript/${PKGVERSION}/lib/zeroline.ps
|
|||
@dirrm share/ghostscript/${PKGVERSION}/Resource
|
||||
@dirrm share/ghostscript/${PKGVERSION}
|
||||
@unexec ${RMDIR} %D/share/ghostscript 2>/dev/null || ${TRUE}
|
||||
@dirrm include/ghostscript
|
||||
|
|
39
print/ghostscript/buildlink3.mk
Normal file
39
print/ghostscript/buildlink3.mk
Normal file
|
@ -0,0 +1,39 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2008/09/03 21:31:12 markd Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
GHOSTSCRIPT_BUILDLINK3_MK:= ${GHOSTSCRIPT_BUILDLINK3_MK}+
|
||||
|
||||
.if ${BUILDLINK_DEPTH} == "+"
|
||||
BUILDLINK_DEPENDS+= ghostscript
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nghostscript}
|
||||
BUILDLINK_PACKAGES+= ghostscript
|
||||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}ghostscript
|
||||
|
||||
.if ${GHOSTSCRIPT_BUILDLINK3_MK} == "+"
|
||||
BUILDLINK_API_DEPENDS.ghostscript+= ghostscript>=8.63nb1
|
||||
BUILDLINK_PKGSRCDIR.ghostscript?= ../../print/ghostscript
|
||||
.endif # GHOSTSCRIPT_BUILDLINK3_MK
|
||||
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
|
||||
pkgbase := ghostscript
|
||||
.include "../../mk/pkg-build-options.mk"
|
||||
|
||||
.if !empty(PKG_BUILD_OPTIONS.ghostscript:Mcups)
|
||||
.include "../../print/cups/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_BUILD_OPTIONS.ghostscript:Mfontconfig)
|
||||
.include "../../fonts/fontconfig/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_BUILD_OPTIONS.ghostscript:Mx11)
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../x11/libXt/buildlink3.mk"
|
||||
.include "../../x11/libXext/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.16 2008/08/07 18:21:40 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.17 2008/09/03 21:31:12 markd Exp $
|
||||
|
||||
SHA1 (ghostscript-8.63.tar.bz2) = c97159d3cccb0b1b5fc409715c6321a7256717ec
|
||||
RMD160 (ghostscript-8.63.tar.bz2) = 817d5c1539d88be979c42f67a9246f690328da33
|
||||
|
@ -6,3 +6,4 @@ Size (ghostscript-8.63.tar.bz2) = 15017410 bytes
|
|||
SHA1 (patch-ab) = 2477242c4c5f6b6feaaa217deb1aa37485f2fac5
|
||||
SHA1 (patch-ad) = 8b3b743b2d6405ea35bfb16970942ecd55702401
|
||||
SHA1 (patch-ae) = df329ac87f9ed97b76f0a7fff738050e8c35794a
|
||||
SHA1 (patch-af) = 03c517d7af0546aef8688e8c153f155be9f913f0
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.7 2008/04/12 22:43:09 jlam Exp $
|
||||
# $NetBSD: options.mk,v 1.8 2008/09/03 21:31:12 markd Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.ghostscript
|
||||
PKG_SUPPORTED_OPTIONS= x11 cups fontconfig
|
||||
|
@ -19,6 +19,7 @@ PLIST_VARS+= cups
|
|||
.if !empty(PKG_OPTIONS:Mcups)
|
||||
CONFIGURE_ARGS+= --enable-cups
|
||||
PLIST.cups= yes
|
||||
INSTALL_TARGET+= install-cups
|
||||
|
||||
CUPS_CONFDIR?= ${PKG_SYSCONFBASEDIR}/cups
|
||||
CUPS_EGDIR= ${PREFIX}/share/examples/cups
|
||||
|
|
18
print/ghostscript/patches/patch-af
Normal file
18
print/ghostscript/patches/patch-af
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-af,v 1.3 2008/09/03 21:31:12 markd Exp $
|
||||
|
||||
--- src/unix-dll.mak.orig 2007-11-28 11:58:40.000000000 +1300
|
||||
+++ src/unix-dll.mak
|
||||
@@ -79,11 +79,11 @@ $(GS_SO_MAJOR): $(GS_SO_MAJOR_MINOR)
|
||||
# Build the small Ghostscript loaders, with Gtk+ and without
|
||||
|
||||
$(GSSOC_XE): $(GS_SO) $(GLSRC)$(SOC_LOADER)
|
||||
- $(GLCC) -g -o $(GSSOC_XE) $(GLSRC)dxmainc.c -L$(BINDIR) -l$(GS)
|
||||
+ $(GLCC) -g -o $(GSSOC_XE) $(GLSRC)dxmainc.c -L$(BINDIR) -Wl,-R$(PREFIX)/lib -l$(GS)
|
||||
|
||||
$(GSSOX_XE): $(GS_SO) $(GLSRC)$(SOC_LOADER)
|
||||
$(GLCC) -g $(SOC_CFLAGS) -o $(GSSOX_XE) $(GLSRC)$(SOC_LOADER) \
|
||||
- -L$(BINDIR) -l$(GS) $(SOC_LIBS)
|
||||
+ -L$(BINDIR) -Wl,-R$(PREFIX)/lib -l$(GS) $(SOC_LIBS)
|
||||
|
||||
# ------------------------- Recursive make targets ------------------------- #
|
||||
|
Loading…
Reference in a new issue