Changes 1.12.2:
After such a long gestation period for the release of Cairo 1.12, we inevitably accumulated a few bugs that were flushed out by broadening the test base. Thanks to everybody who tried the release, apologies to any one unfortunate enough to encounter a bug and many thanks for reporting it.
This commit is contained in:
parent
0e5120cd94
commit
37acb4840d
11 changed files with 50 additions and 133 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.7 2012/03/03 00:12:05 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2012/09/07 15:24:03 adam Exp $
|
||||
|
||||
DISTNAME= cairo-1.10.2
|
||||
PKGNAME= cairo-gobject-1.10.2
|
||||
PKGREVISION= 4
|
||||
DISTNAME= cairo-1.12.2
|
||||
PKGNAME= ${DISTNAME:S/-/-gobject-/}
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://cairographics.org/releases/
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://cairographics.org/
|
||||
|
|
|
@ -9,7 +9,7 @@ available (eg. through the X Render Extension).
|
|||
|
||||
The cairo API provides operations similar to the drawing operators
|
||||
of PostScript and PDF. Operations in cairo including stroking and
|
||||
filling cubic Bézier splines, transforming and compositing
|
||||
filling cubic Bezier splines, transforming and compositing
|
||||
translucent images, and antialiased text rendering. All drawing
|
||||
operations can be transformed by any affine transformation (scale,
|
||||
rotation, shear, etc.)
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.100 2012/06/14 19:53:07 bsiegert Exp $
|
||||
# $NetBSD: Makefile,v 1.101 2012/09/07 15:24:03 adam Exp $
|
||||
|
||||
DISTNAME= cairo-1.10.2
|
||||
PKGREVISION= 5
|
||||
DISTNAME= cairo-1.12.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://cairographics.org/releases/
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://cairographics.org/
|
||||
|
@ -12,29 +12,27 @@ LICENSE= gnu-lgpl-v2.1 AND mpl-1.1
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_LANGUAGES+= c99
|
||||
USE_LANGUAGES= c99
|
||||
USE_LIBTOOL= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
PKGCONFIG_OVERRIDE+= src/cairo.pc.in \
|
||||
src/cairo-features.pc.in
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --enable-gl
|
||||
CONFIGURE_ARGS+= --enable-pdf
|
||||
CONFIGURE_ARGS+= --enable-ps
|
||||
CONFIGURE_ARGS+= --enable-tee
|
||||
|
||||
PLIST_VARS+= carbon
|
||||
PKGCONFIG_OVERRIDE+= src/cairo.pc.in
|
||||
PKGCONFIG_OVERRIDE+= src/cairo-features.pc.in
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.if exists(/System/Library/Frameworks/Carbon.framework)
|
||||
CONFIGURE_ARGS+= --enable-quartz
|
||||
CONFIGURE_ARGS+= --enable-quartz-font
|
||||
CONFIGURE_ARGS+= --enable-quartz-image
|
||||
PLIST.carbon= yes
|
||||
.endif
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
# For snprintf() and ctime_r()
|
||||
CPPFLAGS.SunOS+= -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS
|
||||
|
||||
|
@ -54,6 +52,5 @@ BUILDLINK_API_DEPENDS.freetype2+= freetype2>=2.1.9
|
|||
# include?
|
||||
#.include "../../print/libspectre/buildlink3.mk"
|
||||
.include "../../x11/pixman/buildlink3.mk"
|
||||
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.31 2012/02/23 14:00:43 ryoon Exp $
|
||||
@comment $NetBSD: PLIST,v 1.32 2012/09/07 15:24:03 adam Exp $
|
||||
bin/cairo-trace
|
||||
include/cairo/cairo-deprecated.h
|
||||
include/cairo/cairo-features.h
|
||||
|
@ -9,6 +9,7 @@ include/cairo/cairo-ps.h
|
|||
${PLIST.carbon}include/cairo/cairo-quartz.h
|
||||
${PLIST.carbon}include/cairo/cairo-quartz-image.h
|
||||
include/cairo/cairo-script-interpreter.h
|
||||
include/cairo/cairo-script.h
|
||||
include/cairo/cairo-svg.h
|
||||
include/cairo/cairo-tee.h
|
||||
include/cairo/cairo-version.h
|
||||
|
@ -16,6 +17,7 @@ ${PLIST.xcb}include/cairo/cairo-xcb.h
|
|||
${PLIST.x11}include/cairo/cairo-xlib-xrender.h
|
||||
${PLIST.x11}include/cairo/cairo-xlib.h
|
||||
include/cairo/cairo.h
|
||||
lib/cairo/cairo-fdr.la
|
||||
lib/cairo/libcairo-trace.la
|
||||
lib/libcairo-script-interpreter.la
|
||||
lib/libcairo.la
|
||||
|
@ -29,6 +31,7 @@ lib/pkgconfig/cairo-ps.pc
|
|||
${PLIST.carbon}lib/pkgconfig/cairo-quartz-font.pc
|
||||
${PLIST.carbon}lib/pkgconfig/cairo-quartz-image.pc
|
||||
${PLIST.carbon}lib/pkgconfig/cairo-quartz.pc
|
||||
lib/pkgconfig/cairo-script.pc
|
||||
lib/pkgconfig/cairo-svg.pc
|
||||
lib/pkgconfig/cairo-tee.pc
|
||||
${PLIST.xcb}lib/pkgconfig/cairo-xcb-shm.pc
|
||||
|
@ -54,16 +57,19 @@ share/gtk-doc/html/cairo/cairo-Paths.html
|
|||
share/gtk-doc/html/cairo/cairo-PostScript-Surfaces.html
|
||||
share/gtk-doc/html/cairo/cairo-Quartz-(CGFont)-Fonts.html
|
||||
share/gtk-doc/html/cairo/cairo-Quartz-Surfaces.html
|
||||
share/gtk-doc/html/cairo/cairo-Raster-Sources.html
|
||||
share/gtk-doc/html/cairo/cairo-Recording-Surfaces.html
|
||||
share/gtk-doc/html/cairo/cairo-Regions.html
|
||||
share/gtk-doc/html/cairo/cairo-SVG-Surfaces.html
|
||||
share/gtk-doc/html/cairo/cairo-Script-Surfaces.html
|
||||
share/gtk-doc/html/cairo/cairo-Transformations.html
|
||||
share/gtk-doc/html/cairo/cairo-Types.html
|
||||
share/gtk-doc/html/cairo/cairo-User-Fonts.html
|
||||
share/gtk-doc/html/cairo/cairo-Version-Information.html
|
||||
share/gtk-doc/html/cairo/cairo-Win32-Fonts.html
|
||||
share/gtk-doc/html/cairo/cairo-Win32-Surfaces.html
|
||||
share/gtk-doc/html/cairo/cairo-XCB-Surfaces.html
|
||||
share/gtk-doc/html/cairo/cairo-XLib-Surfaces.html
|
||||
share/gtk-doc/html/cairo/cairo-XLib-XRender-Backend.html
|
||||
share/gtk-doc/html/cairo/cairo-cairo-device-t.html
|
||||
share/gtk-doc/html/cairo/cairo-cairo-font-face-t.html
|
||||
share/gtk-doc/html/cairo/cairo-cairo-font-options-t.html
|
||||
|
@ -77,10 +83,10 @@ share/gtk-doc/html/cairo/cairo-fonts.html
|
|||
share/gtk-doc/html/cairo/cairo-support.html
|
||||
share/gtk-doc/html/cairo/cairo-surfaces.html
|
||||
share/gtk-doc/html/cairo/cairo-text.html
|
||||
share/gtk-doc/html/cairo/cairo.devhelp
|
||||
share/gtk-doc/html/cairo/cairo.devhelp2
|
||||
share/gtk-doc/html/cairo/home.png
|
||||
share/gtk-doc/html/cairo/index-1.10.html
|
||||
share/gtk-doc/html/cairo/index-1.12.html
|
||||
share/gtk-doc/html/cairo/index-1.2.html
|
||||
share/gtk-doc/html/cairo/index-1.4.html
|
||||
share/gtk-doc/html/cairo/index-1.6.html
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.39 2011/11/01 06:01:26 sbd Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.40 2012/09/07 15:24:03 adam Exp $
|
||||
|
||||
BUILDLINK_TREE+= cairo
|
||||
|
||||
|
@ -6,7 +6,7 @@ BUILDLINK_TREE+= cairo
|
|||
CAIRO_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.cairo+= cairo>=1.0.0nb2
|
||||
BUILDLINK_ABI_DEPENDS.cairo+= cairo>=1.10.2nb2
|
||||
BUILDLINK_ABI_DEPENDS.cairo+= cairo>=1.12.2
|
||||
BUILDLINK_PKGSRCDIR.cairo?= ../../graphics/cairo
|
||||
|
||||
BUILDLINK_API_DEPENDS.Xrender+= Xrender>=0.8
|
||||
|
|
|
@ -1,10 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.59 2012/06/16 20:52:18 tron Exp $
|
||||
$NetBSD: distinfo,v 1.60 2012/09/07 15:24:03 adam Exp $
|
||||
|
||||
SHA1 (cairo-1.10.2.tar.gz) = ccce5ae03f99c505db97c286a0c9a90a926d3c6e
|
||||
RMD160 (cairo-1.10.2.tar.gz) = 8c8de00120398fe2b3a60a08ff59a464b2eebf47
|
||||
Size (cairo-1.10.2.tar.gz) = 23558405 bytes
|
||||
SHA1 (patch-aa) = f211b2a5fce4ff65f280f79fbb78e1a530b9b165
|
||||
SHA1 (patch-ab) = 03a6199a0e0de1fe3701900ea76ce3f0bfdddca0
|
||||
SHA1 (cairo-1.12.2.tar.xz) = bc2ee50690575f16dab33af42a2e6cdc6451e3f9
|
||||
RMD160 (cairo-1.12.2.tar.xz) = 0174a5110f5f4c9ff15da984e0602dfd04643a63
|
||||
Size (cairo-1.12.2.tar.xz) = 42051584 bytes
|
||||
SHA1 (patch-aa) = 474f44c1c8d4017137fe59b160afca8f16ad7287
|
||||
SHA1 (patch-ab) = 62ff361d52742bba0f49c6a32149269b958fa24a
|
||||
SHA1 (patch-ac) = 151c682245004902cf42ba141e3743592691dfb9
|
||||
SHA1 (patch-src_cairo-quartz-font.c) = 0a4bb75c3d2382020e1f491ff99985993a02bbc6
|
||||
SHA1 (patch-src_cairo-quartz.h) = 089ce2fe351724a06986512b2080ae4dc2543b9a
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.6 2010/10/13 00:11:21 spz Exp $
|
||||
# $NetBSD: options.mk,v 1.7 2012/09/07 15:24:03 adam Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.cairo
|
||||
PKG_SUPPORTED_OPTIONS= x11 xcb
|
||||
|
@ -6,13 +6,15 @@ PKG_SUGGESTED_OPTIONS= x11 xcb
|
|||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
PLIST_VARS+= x11 xcb
|
||||
PLIST_VARS+= carbon x11 xcb
|
||||
|
||||
###
|
||||
### X11 and XCB support (XCB implies X11)
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mx11) || !empty(PKG_OPTIONS:Mxcb)
|
||||
CONFIGURE_ARGS+= --enable-xlib --enable-xlib-xrender
|
||||
CONFIGURE_ARGS+= --enable-xlib
|
||||
CONFIGURE_ARGS+= --enable-xlib-xrender
|
||||
PLIST.gl= yes
|
||||
PLIST.x11= yes
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../x11/libXext/buildlink3.mk"
|
||||
|
@ -22,12 +24,14 @@ PLIST.x11= yes
|
|||
BUILDLINK_DEPMETHOD.libXt?= build # only for configure
|
||||
.include "../../x11/libXt/buildlink3.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mxcb)
|
||||
. if !empty(PKG_OPTIONS:Mxcb)
|
||||
CONFIGURE_ARGS+= --enable-xcb
|
||||
PLIST.xcb= yes
|
||||
.include "../../x11/libxcb/buildlink3.mk"
|
||||
.endif
|
||||
. include "../../x11/libxcb/buildlink3.mk"
|
||||
. endif
|
||||
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-xlib --disable-xlib-xrender --disable-gl
|
||||
CONFIGURE_ARGS+= --disable-gl
|
||||
CONFIGURE_ARGS+= --disable-xlib
|
||||
CONFIGURE_ARGS+= --disable-xlib-xrender
|
||||
.endif
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: patch-aa,v 1.14 2010/09/13 12:23:01 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.15 2012/09/07 15:24:03 adam Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2010-09-06 16:16:41.000000000 +0000
|
||||
--- src/Makefile.in.orig 2012-04-29 18:49:55.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -821,9 +821,9 @@ AWK = @AWK@
|
||||
@@ -928,9 +928,9 @@ AUTOMAKE = @AUTOMAKE@
|
||||
AWK = @AWK@
|
||||
BFD_LIBS = @BFD_LIBS@
|
||||
CAIROBOILERPLATE_LIBS = @CAIROBOILERPLATE_LIBS@
|
||||
CAIROPERF_LIBS = @CAIROPERF_LIBS@
|
||||
-CAIRO_CFLAGS = @CAIRO_CFLAGS@
|
||||
+CAIRO_CFLAGS = @CAIRO_CFLAGS@ ${PTHREAD_CFLAGS}
|
||||
CAIRO_LDFLAGS = @CAIRO_LDFLAGS@
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.15 2011/02/12 13:40:53 drochner Exp $
|
||||
$NetBSD: patch-ab,v 1.16 2012/09/07 15:24:03 adam Exp $
|
||||
|
||||
--- util/cairo-gobject/Makefile.in.orig 2010-12-25 14:22:55.000000000 +0000
|
||||
--- util/cairo-gobject/Makefile.in.orig 2012-04-29 18:49:57.000000000 +0000
|
||||
+++ util/cairo-gobject/Makefile.in
|
||||
@@ -91,7 +91,7 @@ am__base_list = \
|
||||
@@ -114,7 +114,7 @@ am__uninstall_files_from_dir = { \
|
||||
am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(cairoincludedir)"
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
am__DEPENDENCIES_1 =
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-ab,v 1.15 2011/02/12 13:40:53 drochner Exp $
|
|||
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
|
||||
am_libcairo_gobject_la_OBJECTS = \
|
||||
libcairo_gobject_la-cairo-gobject-enums.lo \
|
||||
@@ -357,7 +357,7 @@ libcairo_gobject_la_SOURCES = \
|
||||
@@ -385,7 +385,7 @@ libcairo_gobject_la_SOURCES = \
|
||||
|
||||
libcairo_gobject_la_CFLAGS = $(CAIRO_CFLAGS) $(GOBJECT_CFLAGS)
|
||||
libcairo_gobject_la_LDFLAGS = -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols)
|
||||
|
|
|
@ -1,69 +0,0 @@
|
|||
$NetBSD: patch-src_cairo-quartz-font.c,v 1.1 2012/06/16 20:52:18 tron Exp $
|
||||
|
||||
Fix 32 bit build under Mac OS X Lion. Patch taken from here:
|
||||
|
||||
http://cgit.freedesktop.org/cairo/commit/?id=8664df767cb9dbe48647f9853e3dcf551701d3ca
|
||||
|
||||
--- src/cairo-quartz-font.c.orig 2010-12-25 14:21:34.000000000 +0000
|
||||
+++ src/cairo-quartz-font.c 2012-06-16 21:46:19.000000000 +0100
|
||||
@@ -90,6 +90,9 @@
|
||||
static int (*CGFontGetDescentPtr) (CGFontRef fontRef) = NULL;
|
||||
static int (*CGFontGetLeadingPtr) (CGFontRef fontRef) = NULL;
|
||||
|
||||
+/* Not public anymore in 64-bits nor in 10.7 */
|
||||
+static ATSFontRef (*FMGetATSFontRefFromFontPtr) (FMFont iFont) = NULL;
|
||||
+
|
||||
static cairo_bool_t _cairo_quartz_font_symbol_lookup_done = FALSE;
|
||||
static cairo_bool_t _cairo_quartz_font_symbols_present = FALSE;
|
||||
|
||||
@@ -127,6 +130,8 @@
|
||||
CGContextGetAllowsFontSmoothingPtr = dlsym(RTLD_DEFAULT, "CGContextGetAllowsFontSmoothing");
|
||||
CGContextSetAllowsFontSmoothingPtr = dlsym(RTLD_DEFAULT, "CGContextSetAllowsFontSmoothing");
|
||||
|
||||
+ FMGetATSFontRefFromFontPtr = dlsym(RTLD_DEFAULT, "FMGetATSFontRefFromFont");
|
||||
+
|
||||
if ((CGFontCreateWithFontNamePtr || CGFontCreateWithNamePtr) &&
|
||||
CGFontGetGlyphBBoxesPtr &&
|
||||
CGFontGetGlyphsForUnicharsPtr &&
|
||||
@@ -777,7 +782,6 @@
|
||||
return ffont->cgFont;
|
||||
}
|
||||
|
||||
-#ifndef __LP64__
|
||||
/*
|
||||
* compat with old ATSUI backend
|
||||
*/
|
||||
@@ -798,15 +802,22 @@
|
||||
cairo_font_face_t *
|
||||
cairo_quartz_font_face_create_for_atsu_font_id (ATSUFontID font_id)
|
||||
{
|
||||
- ATSFontRef atsFont = FMGetATSFontRefFromFont (font_id);
|
||||
- CGFontRef cgFont = CGFontCreateWithPlatformFont (&atsFont);
|
||||
- cairo_font_face_t *ff;
|
||||
+ quartz_font_ensure_symbols();
|
||||
|
||||
- ff = cairo_quartz_font_face_create_for_cgfont (cgFont);
|
||||
+ if (FMGetATSFontRefFromFontPtr != NULL) {
|
||||
+ ATSFontRef atsFont = FMGetATSFontRefFromFontPtr (font_id);
|
||||
+ CGFontRef cgFont = CGFontCreateWithPlatformFont (&atsFont);
|
||||
+ cairo_font_face_t *ff;
|
||||
|
||||
- CGFontRelease (cgFont);
|
||||
+ ff = cairo_quartz_font_face_create_for_cgfont (cgFont);
|
||||
+
|
||||
+ CGFontRelease (cgFont);
|
||||
|
||||
- return ff;
|
||||
+ return ff;
|
||||
+ } else {
|
||||
+ _cairo_error_throw (CAIRO_STATUS_NO_MEMORY);
|
||||
+ return (cairo_font_face_t *)&_cairo_font_face_nil;
|
||||
+ }
|
||||
}
|
||||
|
||||
/* This is the old name for the above function, exported for compat purposes */
|
||||
@@ -817,4 +828,3 @@
|
||||
{
|
||||
return cairo_quartz_font_face_create_for_atsu_font_id (font_id);
|
||||
}
|
||||
-#endif
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-src_cairo-quartz.h,v 1.1 2012/06/16 20:52:18 tron Exp $
|
||||
|
||||
Fix 32 bit build under Mac OS X Lion. Patch taken from here:
|
||||
|
||||
http://cgit.freedesktop.org/cairo/commit/?id=8664df767cb9dbe48647f9853e3dcf551701d3ca
|
||||
|
||||
--- src/cairo-quartz.h.orig 2010-06-18 12:47:13.000000000 +0100
|
||||
+++ src/cairo-quartz.h 2012-06-16 21:46:19.000000000 +0100
|
||||
@@ -66,10 +66,8 @@
|
||||
cairo_public cairo_font_face_t *
|
||||
cairo_quartz_font_face_create_for_cgfont (CGFontRef font);
|
||||
|
||||
-#ifndef __LP64__
|
||||
cairo_public cairo_font_face_t *
|
||||
cairo_quartz_font_face_create_for_atsu_font_id (ATSUFontID font_id);
|
||||
-#endif
|
||||
|
||||
#endif /* CAIRO_HAS_QUARTZ_FONT */
|
||||
|
Loading…
Reference in a new issue