ibus: fix build on non-wayland platforms, fix missing declaration of index(3)

ibus breaks on non-wayland platforms since configure looks for
wayland and xkbcommon, disable wayland on non-wayland platforms.
index(3) was reported to not have a function declaration on SunOS.
Include strings.h to fix this.
This commit is contained in:
nros 2023-12-17 09:04:10 +00:00
parent 941ac06255
commit 37b8ec8fb0
4 changed files with 30 additions and 5 deletions

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.102 2023/11/18 07:13:42 tsutsui Exp $
# $NetBSD: Makefile,v 1.103 2023/12/17 09:04:10 nros Exp $
.include "Makefile.common"
@ -57,6 +57,16 @@ CONF_FILES+= ${PREFIX}/share/examples/ibus/dconf/profile/ibus \
BUILDLINK_TRANSFORM+= rm:-Wno-unused-but-set-variable
.endif
# wayland or not
PLIST_VARS+= wayland
.include "../../devel/wayland/platform.mk"
.if ${PLATFORM_SUPPORTS_WAYLAND} == "yes"
CONFIGURE_ARGS+= --enable-wayland
PLIST.wayland= yes
.else
CONFIGURE_ARGS+= --disable-wayland
.endif
# Trigger .vala->.c regeneration of files that contain
# "#if USE_GDK_WAYLAND" preprocessing directives since we
# might be on a platform where gtk3 is not built with Wayland.

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.23 2023/11/18 07:13:42 tsutsui Exp $
@comment $NetBSD: PLIST,v 1.24 2023/12/17 09:04:10 nros Exp $
bin/ibus
bin/ibus-daemon
bin/ibus-setup
@ -53,7 +53,7 @@ libexec/ibus-extension-gtk3
libexec/ibus-portal
libexec/ibus-ui-emojier
libexec/ibus-ui-gtk3
libexec/ibus-wayland
${PLIST.wayland}libexec/ibus-wayland
libexec/ibus-x11
man/man1/ibus-daemon.1
man/man1/ibus-setup.1
@ -64,7 +64,7 @@ man/man7/ibus-emoji.7
share/GConf/gsettings/ibus.convert
share/applications/org.freedesktop.IBus.Panel.Emojier.desktop
share/applications/org.freedesktop.IBus.Panel.Extension.Gtk3.desktop
share/applications/org.freedesktop.IBus.Panel.Wayland.Gtk3.desktop
${PLIST.wayland}share/applications/org.freedesktop.IBus.Panel.Wayland.Gtk3.desktop
share/applications/org.freedesktop.IBus.Setup.desktop
share/bash-completion/completions/ibus.bash
share/dbus-1/services/org.freedesktop.IBus.service

View File

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.32 2023/11/18 07:13:42 tsutsui Exp $
$NetBSD: distinfo,v 1.33 2023/12/17 09:04:10 nros Exp $
BLAKE2s (ibus-1.5.29-rc2.tar.gz) = 645fbfb3f779426119a276520486df7f594cfc9a41a91e1b02ff4ad0a931df6f
SHA512 (ibus-1.5.29-rc2.tar.gz) = 47dd39c9615783b6c157a25e8a2506dc2e1f440d56aa649ee8cb95a390cb4efab9c95e72ac84b5d042c25e350599b4d352ddc66f1385af6660d4a7a296e44ca7
Size (ibus-1.5.29-rc2.tar.gz) = 3991416 bytes
SHA1 (patch-client_gtk2_ibusimcontext.c) = 8dcbb38404e599618891de6a406bc1a07db634d4
SHA1 (patch-client_gtk3_ibusimcontext.c) = 105a2560014f8bd9699393bef3dda00a6c925c6a
SHA1 (patch-src_ibuscomposetable.c) = 4a0f2feb9f58e04199fec08433559a2701ddb69c
SHA1 (patch-ui_gtk3_Makefile.am) = e0b74afa665b395bb5ac5da678c57e8646bbb71a
SHA1 (patch-ui_gtk3_Makefile.in) = e52d7d60e975bbc8d1c2807deaef8f0d09b46548

View File

@ -0,0 +1,14 @@
$NetBSD: patch-src_ibuscomposetable.c,v 1.1 2023/12/17 09:04:10 nros Exp $
include strings.h for index(3)
--- src/ibuscomposetable.c.orig 2023-12-17 09:46:36.902795436 +0000
+++ src/ibuscomposetable.c
@@ -26,6 +26,7 @@
#include <glib/gstdio.h>
#include <stdlib.h>
#include <string.h>
+#include <strings.h>
#include "ibuscomposetable.h"
#include "ibuserror.h"