Update to 1.3.4:

I'm happy to announce xtrans-1.3.4

Hans de Goede (2):
      configure: Also add -D_DEFAULT_SOURCE to .pc cflags to shut up glibc warnings
      xtrans 1.3.4

Mark Kettenis (1):
      Increase UNIX socket buffer size

Thomas Klausner (2):
      Cast ctype(3) function arguments to unsigned char.
      Add missing headers for free() and strlen().
This commit is contained in:
wiz 2014-03-31 10:51:05 +00:00
parent 6c2028681e
commit 37d2908d73
3 changed files with 6 additions and 22 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.23 2014/02/03 16:40:58 wiz Exp $
# $NetBSD: Makefile,v 1.24 2014/03/31 10:51:05 wiz Exp $
DISTNAME= xtrans-1.3.3
DISTNAME= xtrans-1.3.4
CATEGORIES= x11 net
MASTER_SITES= ${MASTER_SITE_XORG:=lib/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.23 2014/02/03 16:40:58 wiz Exp $
$NetBSD: distinfo,v 1.24 2014/03/31 10:51:05 wiz Exp $
SHA1 (xtrans-1.3.3.tar.bz2) = 6c9f3db41ebabcb78a94a714e19125f9a68567ea
RMD160 (xtrans-1.3.3.tar.bz2) = 6cc6468edf0c703da698240fdaf2b199d5bdd5c8
Size (xtrans-1.3.3.tar.bz2) = 177244 bytes
SHA1 (patch-ab) = dd2cf693831270fc15ff89eb81cdf43d3916d721
SHA1 (xtrans-1.3.4.tar.bz2) = beb2cecc4ceb8fab0557a8c37e2d41e63cbaa5ed
RMD160 (xtrans-1.3.4.tar.bz2) = 9045cb7d77f96586a9c52a35fb162b1ab9cba541
Size (xtrans-1.3.4.tar.bz2) = 182341 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.3 2013/11/08 13:10:16 wiz Exp $
--- Xtrans.c.orig 2013-11-03 02:10:11.000000000 +0000
+++ Xtrans.c
@@ -162,8 +162,8 @@ TRANS(SelectTransport) (const char *prot
protobuf[PROTOBUFSIZE-1] = '\0';
for (i = 0; i < PROTOBUFSIZE && protobuf[i] != '\0'; i++)
- if (isupper (protobuf[i]))
- protobuf[i] = tolower (protobuf[i]);
+ if (isupper ((unsigned char)protobuf[i]))
+ protobuf[i] = tolower ((unsigned char)protobuf[i]);
/* Look at all of the configured protocols */