aubio: update to 0.4.9
fixes at least the following bugs: CVE-2018-19800 prevent a possible buffer overflow in new_aubio_tempo CVE-2018-19801 prevent a null-pointer dereference in new_aubio_filterbank CVE-2018-19802 prevent a null-pointer dereference in new_aubio_onset
This commit is contained in:
parent
d0a631bfab
commit
37e9e3a8d1
6 changed files with 103 additions and 176 deletions
|
@ -1,34 +1,40 @@
|
|||
# $NetBSD: Makefile,v 1.16 2019/04/26 14:12:31 maya Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2019/08/01 13:42:54 nia Exp $
|
||||
|
||||
DISTNAME= aubio-0.3.2
|
||||
PKGREVISION= 3
|
||||
DISTNAME= aubio-0.4.9
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= https://aubio.org/pub/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pho@cielonegro.org
|
||||
HOMEPAGE= https://aubio.org/
|
||||
COMMENT= Extracting annotations from audio signals
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
PKGCONFIG_OVERRIDE+= aubio.pc.in
|
||||
|
||||
# Python related variables:
|
||||
PY_PATCHPLIST= yes
|
||||
REPLACE_PYTHON= python/aubiocut python/aubiopitch
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 36 37 # not yet ported as of 0.3.2
|
||||
MAKE_FLAGS+= WAFCMD="${PYTHONBIN} ./waf"
|
||||
MAKE_FLAGS+= WAFOPTS="--disable-tests"
|
||||
MAKE_FLAGS+= MANDIR="${PREFIX}/${PKGMANDIR}"
|
||||
|
||||
TOOL_DEPENDS+= txt2man-[0-9]*:../../converters/txt2man
|
||||
|
||||
CPPFLAGS.SunOS+= -Du_int8_t=uint8_t -Du_int16_t=uint16_t -Du_int32_t=uint32_t -Du_int64_t=uint64_t
|
||||
|
||||
.include "options.mk"
|
||||
#REPLACE_PYTHON+= tests/create_tests_source.py
|
||||
|
||||
PYTHON_FOR_BUILD_ONLY= yes
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && ${MAKE_ENV} ${MAKE} configure ${MAKE_FLAGS}
|
||||
|
||||
.include "options.mk"
|
||||
.include "../../audio/libsamplerate/buildlink3.mk"
|
||||
.include "../../audio/libsndfile/buildlink3.mk"
|
||||
.include "../../devel/swig/buildlink3.mk"
|
||||
.include "../../multimedia/ffmpeg4/buildlink3.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
.include "../../math/fftw/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,128 +1,73 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/10/06 11:45:47 ryoon Exp $
|
||||
bin/aubiocut
|
||||
@comment $NetBSD: PLIST,v 1.2 2019/08/01 13:42:54 nia Exp $
|
||||
bin/aubiomfcc
|
||||
bin/aubionotes
|
||||
bin/aubioonset
|
||||
bin/aubiopitch
|
||||
bin/aubioquiet
|
||||
bin/aubiotrack
|
||||
include/aubio/aubio.h
|
||||
include/aubio/aubioext.h
|
||||
include/aubio/beattracking.h
|
||||
include/aubio/biquad.h
|
||||
include/aubio/config.h
|
||||
include/aubio/fft.h
|
||||
include/aubio/filter.h
|
||||
include/aubio/hist.h
|
||||
include/aubio/jackio.h
|
||||
include/aubio/cvec.h
|
||||
include/aubio/fmat.h
|
||||
include/aubio/fvec.h
|
||||
include/aubio/io/audio_unit.h
|
||||
include/aubio/io/ioutils.h
|
||||
include/aubio/io/sink.h
|
||||
include/aubio/io/sink_apple_audio.h
|
||||
include/aubio/io/sink_sndfile.h
|
||||
include/aubio/io/sink_wavwrite.h
|
||||
include/aubio/io/source.h
|
||||
include/aubio/io/source_apple_audio.h
|
||||
include/aubio/io/source_avcodec.h
|
||||
include/aubio/io/source_sndfile.h
|
||||
include/aubio/io/source_wavread.h
|
||||
include/aubio/lvec.h
|
||||
include/aubio/mathutils.h
|
||||
include/aubio/midi/list.h
|
||||
include/aubio/midi/midi.h
|
||||
include/aubio/midi/midi_driver.h
|
||||
include/aubio/midi/midi_event.h
|
||||
include/aubio/midi/midi_file.h
|
||||
include/aubio/midi/midi_parser.h
|
||||
include/aubio/midi/midi_player.h
|
||||
include/aubio/midi/midi_track.h
|
||||
include/aubio/midi/timer.h
|
||||
include/aubio/onset.h
|
||||
include/aubio/onsetdetection.h
|
||||
include/aubio/peakpick.h
|
||||
include/aubio/phasevoc.h
|
||||
include/aubio/pitchdetection.h
|
||||
include/aubio/pitchfcomb.h
|
||||
include/aubio/pitchmcomb.h
|
||||
include/aubio/pitchschmitt.h
|
||||
include/aubio/pitchyin.h
|
||||
include/aubio/pitchyinfft.h
|
||||
include/aubio/resample.h
|
||||
include/aubio/sample.h
|
||||
include/aubio/scale.h
|
||||
include/aubio/sndfileio.h
|
||||
include/aubio/tempo.h
|
||||
include/aubio/tss.h
|
||||
include/aubio/musicutils.h
|
||||
include/aubio/notes/notes.h
|
||||
include/aubio/onset/onset.h
|
||||
include/aubio/onset/peakpicker.h
|
||||
include/aubio/pitch/pitch.h
|
||||
include/aubio/pitch/pitchfcomb.h
|
||||
include/aubio/pitch/pitchmcomb.h
|
||||
include/aubio/pitch/pitchschmitt.h
|
||||
include/aubio/pitch/pitchspecacf.h
|
||||
include/aubio/pitch/pitchyin.h
|
||||
include/aubio/pitch/pitchyinfast.h
|
||||
include/aubio/pitch/pitchyinfft.h
|
||||
include/aubio/spectral/awhitening.h
|
||||
include/aubio/spectral/dct.h
|
||||
include/aubio/spectral/fft.h
|
||||
include/aubio/spectral/filterbank.h
|
||||
include/aubio/spectral/filterbank_mel.h
|
||||
include/aubio/spectral/mfcc.h
|
||||
include/aubio/spectral/phasevoc.h
|
||||
include/aubio/spectral/specdesc.h
|
||||
include/aubio/spectral/tss.h
|
||||
include/aubio/synth/sampler.h
|
||||
include/aubio/synth/wavetable.h
|
||||
include/aubio/tempo/beattracking.h
|
||||
include/aubio/tempo/tempo.h
|
||||
include/aubio/temporal/a_weighting.h
|
||||
include/aubio/temporal/biquad.h
|
||||
include/aubio/temporal/c_weighting.h
|
||||
include/aubio/temporal/filter.h
|
||||
include/aubio/temporal/resampler.h
|
||||
include/aubio/types.h
|
||||
lib/libaubio.la
|
||||
lib/libaubioext.la
|
||||
include/aubio/utils/hist.h
|
||||
include/aubio/utils/log.h
|
||||
include/aubio/utils/parameter.h
|
||||
include/aubio/utils/scale.h
|
||||
include/aubio/vecutils.h
|
||||
lib/libaubio.a
|
||||
lib/libaubio.so
|
||||
lib/libaubio.so.5
|
||||
lib/libaubio.so.5.4.8
|
||||
lib/pkgconfig/aubio.pc
|
||||
${PYSITELIB}/aubio/__init__.py
|
||||
${PYSITELIB}/aubio/__init__.pyc
|
||||
${PYSITELIB}/aubio/__init__.pyo
|
||||
${PYSITELIB}/aubio/_aubiowrapper.la
|
||||
${PYSITELIB}/aubio/aubioclass.py
|
||||
${PYSITELIB}/aubio/aubioclass.pyc
|
||||
${PYSITELIB}/aubio/aubioclass.pyo
|
||||
${PYSITELIB}/aubio/aubiowrapper.py
|
||||
${PYSITELIB}/aubio/aubiowrapper.pyc
|
||||
${PYSITELIB}/aubio/aubiowrapper.pyo
|
||||
${PYSITELIB}/aubio/bench/__init__.py
|
||||
${PYSITELIB}/aubio/bench/__init__.pyc
|
||||
${PYSITELIB}/aubio/bench/__init__.pyo
|
||||
${PYSITELIB}/aubio/bench/broadcast.py
|
||||
${PYSITELIB}/aubio/bench/broadcast.pyc
|
||||
${PYSITELIB}/aubio/bench/broadcast.pyo
|
||||
${PYSITELIB}/aubio/bench/config.py
|
||||
${PYSITELIB}/aubio/bench/config.pyc
|
||||
${PYSITELIB}/aubio/bench/config.pyo
|
||||
${PYSITELIB}/aubio/bench/node.py
|
||||
${PYSITELIB}/aubio/bench/node.pyc
|
||||
${PYSITELIB}/aubio/bench/node.pyo
|
||||
${PYSITELIB}/aubio/bench/onset.py
|
||||
${PYSITELIB}/aubio/bench/onset.pyc
|
||||
${PYSITELIB}/aubio/bench/onset.pyo
|
||||
${PYSITELIB}/aubio/gnuplot.py
|
||||
${PYSITELIB}/aubio/gnuplot.pyc
|
||||
${PYSITELIB}/aubio/gnuplot.pyo
|
||||
${PYSITELIB}/aubio/median.py
|
||||
${PYSITELIB}/aubio/median.pyc
|
||||
${PYSITELIB}/aubio/median.pyo
|
||||
${PYSITELIB}/aubio/onsetcompare.py
|
||||
${PYSITELIB}/aubio/onsetcompare.pyc
|
||||
${PYSITELIB}/aubio/onsetcompare.pyo
|
||||
${PYSITELIB}/aubio/plot/__init__.py
|
||||
${PYSITELIB}/aubio/plot/__init__.pyc
|
||||
${PYSITELIB}/aubio/plot/__init__.pyo
|
||||
${PYSITELIB}/aubio/plot/keyboard.py
|
||||
${PYSITELIB}/aubio/plot/keyboard.pyc
|
||||
${PYSITELIB}/aubio/plot/keyboard.pyo
|
||||
${PYSITELIB}/aubio/task/__init__.py
|
||||
${PYSITELIB}/aubio/task/__init__.pyc
|
||||
${PYSITELIB}/aubio/task/__init__.pyo
|
||||
${PYSITELIB}/aubio/task/beat.py
|
||||
${PYSITELIB}/aubio/task/beat.pyc
|
||||
${PYSITELIB}/aubio/task/beat.pyo
|
||||
${PYSITELIB}/aubio/task/cut.py
|
||||
${PYSITELIB}/aubio/task/cut.pyc
|
||||
${PYSITELIB}/aubio/task/cut.pyo
|
||||
${PYSITELIB}/aubio/task/notes.py
|
||||
${PYSITELIB}/aubio/task/notes.pyc
|
||||
${PYSITELIB}/aubio/task/notes.pyo
|
||||
${PYSITELIB}/aubio/task/onset.py
|
||||
${PYSITELIB}/aubio/task/onset.pyc
|
||||
${PYSITELIB}/aubio/task/onset.pyo
|
||||
${PYSITELIB}/aubio/task/params.py
|
||||
${PYSITELIB}/aubio/task/params.pyc
|
||||
${PYSITELIB}/aubio/task/params.pyo
|
||||
${PYSITELIB}/aubio/task/pitch.py
|
||||
${PYSITELIB}/aubio/task/pitch.pyc
|
||||
${PYSITELIB}/aubio/task/pitch.pyo
|
||||
${PYSITELIB}/aubio/task/silence.py
|
||||
${PYSITELIB}/aubio/task/silence.pyc
|
||||
${PYSITELIB}/aubio/task/silence.pyo
|
||||
${PYSITELIB}/aubio/task/task.py
|
||||
${PYSITELIB}/aubio/task/task.pyc
|
||||
${PYSITELIB}/aubio/task/task.pyo
|
||||
${PYSITELIB}/aubio/task/utils.py
|
||||
${PYSITELIB}/aubio/task/utils.pyc
|
||||
${PYSITELIB}/aubio/task/utils.pyo
|
||||
${PYSITELIB}/aubio/txtfile.py
|
||||
${PYSITELIB}/aubio/txtfile.pyc
|
||||
${PYSITELIB}/aubio/txtfile.pyo
|
||||
${PYSITELIB}/aubio/web/__init__.py
|
||||
${PYSITELIB}/aubio/web/__init__.pyc
|
||||
${PYSITELIB}/aubio/web/__init__.pyo
|
||||
${PYSITELIB}/aubio/web/browser.py
|
||||
${PYSITELIB}/aubio/web/browser.pyc
|
||||
${PYSITELIB}/aubio/web/browser.pyo
|
||||
${PYSITELIB}/aubio/web/html.py
|
||||
${PYSITELIB}/aubio/web/html.pyc
|
||||
${PYSITELIB}/aubio/web/html.pyo
|
||||
share/sounds/aubio/woodblock.aiff
|
||||
share/man/man1/aubio.1
|
||||
share/man/man1/aubiocut.1
|
||||
share/man/man1/aubiomfcc.1
|
||||
share/man/man1/aubionotes.1
|
||||
share/man/man1/aubioonset.1
|
||||
share/man/man1/aubiopitch.1
|
||||
share/man/man1/aubioquiet.1
|
||||
share/man/man1/aubiotrack.1
|
||||
|
|
|
@ -1,15 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2015/11/03 01:12:25 agc Exp $
|
||||
$NetBSD: distinfo,v 1.4 2019/08/01 13:42:54 nia Exp $
|
||||
|
||||
SHA1 (aubio-0.3.2.tar.gz) = 8ef7ccbf18a4fa6db712a9192acafc9c8d080978
|
||||
RMD160 (aubio-0.3.2.tar.gz) = 44e3bb8ab38aa715052466e7ae50123089914b5b
|
||||
SHA512 (aubio-0.3.2.tar.gz) = b3d8445716c0cde02ee1e7b036864598ec7562d8a938a61f644c384d80e95601abcb6e713cdaab7b2613f6f4f27db1cfafa7c23824c61f504e83d11fefdee8fc
|
||||
Size (aubio-0.3.2.tar.gz) = 609006 bytes
|
||||
SHA1 (patch-ext_Makefile.in) = 4f4f40549860ac00739c3955b034745403128d7b
|
||||
SHA1 (patch-python_aubio_Makefile.in) = 4d6b2bf9f6b1cc6661f4aa65f400a0c575c8aca5
|
||||
SHA1 (patch-python_aubio_bench_onset.py) = 1076258814ced4e91afcd0e5242b4de23c008211
|
||||
SHA1 (patch-python_aubio_gnuplot.py) = 7ed573a32f4443cf4a48ad32575e2d38d55889f2
|
||||
SHA1 (patch-python_aubio_plot_keyboard.py) = ae207a1f5a508b49d2815a1e3496d209b06ee351
|
||||
SHA1 (patch-python_aubio_task_beat.py) = 1413775da8b9982ab66604208f3d522eed270a90
|
||||
SHA1 (patch-python_aubio_task_notes.py) = d0c28c1d41519617a731cc7baed9105ff8453e42
|
||||
SHA1 (patch-python_aubio_task_onset.py) = 403879042e287edd332e56fd56f4255796665dd9
|
||||
SHA1 (patch-python_aubio_task_pitch.py) = ceb9d777f0ae91b261086d53f4cb24bdefb3a185
|
||||
SHA1 (aubio-0.4.9.tar.bz2) = ab9c4f853e74dd7774d6325da9c9840e6d50a6d6
|
||||
RMD160 (aubio-0.4.9.tar.bz2) = 6595c969e1c7ea84b667b35ea10dc0d8f3a6fc5b
|
||||
SHA512 (aubio-0.4.9.tar.bz2) = 0cb81bb4b15051db3f3f4d160d500af56fdfb237e0a74e3f366f53c2870030aa0a7cee8469a611a9694c36b8866d3d42ffb48241c999de08f3fee43e6d903130
|
||||
Size (aubio-0.4.9.tar.bz2) = 397604 bytes
|
||||
SHA1 (patch-scripts_build__apple__frameworks) = d29858886b61dc2194e228c6113fbc6a54577b45
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ext_Makefile.in,v 1.1 2013/03/24 17:06:06 joerg Exp $
|
||||
|
||||
--- ext/Makefile.in.orig 2013-03-23 15:38:08.000000000 +0000
|
||||
+++ ext/Makefile.in
|
||||
@@ -273,7 +273,7 @@ libaubioext_la_SOURCES = aubioext.h \
|
||||
midi/midi_driver.c
|
||||
|
||||
AM_CFLAGS = -I$(top_srcdir)/src @AUBIO_CFLAGS@ @SNDLIB_CFLAGS@ @JACK_CFLAGS@ @FFTWLIB_CFLAGS@ @SAMPLERATE_CFLAGS@ @ALSA_CFLAGS@
|
||||
-libaubioext_la_LIBADD = -laubio -L${top_builddir}/src @SNDLIB_LIBS@ @JACK_LIBS@ @FFTWLIB_LIBS@ @SAMPLERATE_LIBS@ @ALSA_LIBS@ @LTLIBOBJS@
|
||||
+libaubioext_la_LIBADD = ../src/libaubio.la -L${top_builddir}/src @SNDLIB_LIBS@ @JACK_LIBS@ @FFTWLIB_LIBS@ @SAMPLERATE_LIBS@ @ALSA_LIBS@ @LTLIBOBJS@
|
||||
libaubioext_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
|
||||
all: all-am
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-python_aubio_Makefile.in,v 1.1.1.1 2011/10/06 11:45:48 ryoon Exp $
|
||||
|
||||
--- python/aubio/Makefile.in.orig 2006-10-10 14:41:06.000000000 +0000
|
||||
+++ python/aubio/Makefile.in
|
||||
@@ -61,11 +61,11 @@ am__depfiles_maybe = depfiles
|
||||
@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/aubio_wrap.Plo
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) \
|
||||
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) \
|
||||
$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
|
||||
$(AM_CFLAGS) $(CFLAGS)
|
||||
CCLD = $(CC)
|
||||
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
SOURCES = $(_aubiowrapper_la_SOURCES)
|
||||
DIST_SOURCES = $(_aubiowrapper_la_SOURCES)
|
15
audio/aubio/patches/patch-scripts_build__apple__frameworks
Normal file
15
audio/aubio/patches/patch-scripts_build__apple__frameworks
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-scripts_build__apple__frameworks,v 1.1 2019/08/01 13:42:54 nia Exp $
|
||||
|
||||
Use portable test operator.
|
||||
|
||||
--- scripts/build_apple_frameworks.orig 2018-09-22 15:47:33.000000000 +0000
|
||||
+++ scripts/build_apple_frameworks
|
||||
@@ -82,7 +82,7 @@ do
|
||||
done
|
||||
|
||||
create_framework $PACKAGE $VERSION $PLATFORM
|
||||
- if [ $PLATFORM == 'darwin' ]
|
||||
+ if [ $PLATFORM = 'darwin' ]
|
||||
then
|
||||
# on darwin, build a .tar.bz2 of /usr and a .zip of aubio.framework
|
||||
create_tarballs $PACKAGE $VERSION $PLATFORM
|
Loading…
Reference in a new issue