Some general package cleanups:
- added to MESSAGE advising of rc.d script changes - added BASH as a tool - fixed pygrub install so that it doesn't get overwritten with a symlink - turned oxenstored.conf into a proper config file
This commit is contained in:
parent
434861dde7
commit
37ecf6b0b4
5 changed files with 34 additions and 4 deletions
|
@ -1,10 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.2 2013/05/22 05:32:43 jnemeth Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2013/05/25 05:19:17 jnemeth Exp $
|
||||
#
|
||||
# VERSION is set in version.mk as it is shared with other packages
|
||||
.include "version.mk"
|
||||
|
||||
DISTNAME= xen-${VERSION}
|
||||
PKGNAME= xentools42-${VERSION}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://bits.xensource.com/oss-xen/release/${VERSION}/
|
||||
|
||||
|
@ -148,6 +149,8 @@ CONF_FILES+= ${EGDIR}/formats ${PKG_SYSCONFDIR}/formats
|
|||
CONF_FILES+= ${EGDIR}/xend-config.sxp ${PKG_SYSCONFDIR}/xend-config.sxp
|
||||
CONF_FILES+= ${EGDIR}/xl.conf ${PKG_SYSCONFDIR}/xl.conf
|
||||
CONF_FILES+= ${EGDIR}/xm-config.xml ${PKG_SYSCONFDIR}/xm-config.xml
|
||||
CONF_FILES+= ${EGDIR}/oxenstored.conf ${PKG_SYSCONFDIR}/oxenstored.conf
|
||||
|
||||
|
||||
OWN_DIRS= ${PKG_SYSCONFDIR}/scripts ${VARBASE}/log/xen
|
||||
OWN_DIRS+= ${VARBASE}/lib/xen
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2013/05/15 06:58:50 jnemeth Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2013/05/25 05:19:17 jnemeth Exp $
|
||||
bin/libxl-save-helper
|
||||
bin/lsevtchn
|
||||
bin/pygrub
|
||||
|
@ -25,7 +25,6 @@ bin/xenstore-write
|
|||
bin/xentrace
|
||||
bin/xentrace_format
|
||||
bin/xentrace_setsize
|
||||
etc/xen/oxenstored.conf
|
||||
include/_libxl_list.h
|
||||
include/_libxl_types.h
|
||||
include/_libxl_types_json.h
|
||||
|
@ -679,6 +678,7 @@ share/examples/xen/README
|
|||
share/examples/xen/README.incompatibilities
|
||||
share/examples/xen/cpupool
|
||||
share/examples/xen/formats
|
||||
share/examples/xen/oxenstored.conf
|
||||
share/examples/xen/scripts/block
|
||||
share/examples/xen/scripts/hotplugpath.sh
|
||||
@comment share/examples/xen/scripts/qemu-ifup
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1 2013/05/15 06:58:50 jnemeth Exp $
|
||||
$NetBSD: distinfo,v 1.2 2013/05/25 05:19:17 jnemeth Exp $
|
||||
|
||||
SHA1 (ipxe-git-v1.0.0.tar.gz) = da052c8de5f3485fe0253c19cf52ed6d72528485
|
||||
RMD160 (ipxe-git-v1.0.0.tar.gz) = dcd9b6eaafa1ce05c1ebf2a15f2f73ad7a8c5547
|
||||
|
@ -38,8 +38,10 @@ SHA1 (patch-libxc_xc__netbsd.c) = c94a2f7b38bfc1479401acf1bb124251bb4e3fcf
|
|||
SHA1 (patch-libxl_libxl__create.c) = a212b3760f1bb796c6f126e5c795154f4e8030e2
|
||||
SHA1 (patch-libxl_libxl__internal.h) = f8ff92400f7ba7858cc1963b11c1e8ee23d4e51f
|
||||
SHA1 (patch-ocaml_common.make) = c59d32301198d65691ab23529dd791de5ac40199
|
||||
SHA1 (patch-ocaml_xenstored_Makefile) = 0df19c3507616e104ecdfa403d14e046c5b2a368
|
||||
SHA1 (patch-ocaml_xenstored_define.ml) = 044144295c2818a71c14dffc9c58f8592b222b0c
|
||||
SHA1 (patch-ocaml_xenstored_utils.ml) = cc792a696743fa348b274b1c23783ea1a0d7da47
|
||||
SHA1 (patch-pygrub_Makefile) = fa3671e0ff50a6a341ddf54a7b81c21add9e4f89
|
||||
SHA1 (patch-python_xen_xend_XendNode.py) = 2c65e4b4b85e91e92dfb3aa402ebc44694bdff06
|
||||
SHA1 (patch-python_xen_xend_osdep.py) = 8da6bba38bd7677ea829ca35058f7d2d1d7acad4
|
||||
SHA1 (patch-python_xen_xm_create.py) = 7b25b3b3a8d58effae395d776f2a4b94d79acfcb
|
||||
|
|
12
sysutils/xentools42/patches/patch-ocaml_xenstored_Makefile
Normal file
12
sysutils/xentools42/patches/patch-ocaml_xenstored_Makefile
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ocaml_xenstored_Makefile,v 1.1 2013/05/25 05:19:17 jnemeth Exp $
|
||||
|
||||
--- ocaml/xenstored/Makefile.orig 2013-04-23 16:42:55.000000000 +0000
|
||||
+++ ocaml/xenstored/Makefile
|
||||
@@ -1,6 +1,7 @@
|
||||
XEN_ROOT = $(CURDIR)/../../..
|
||||
OCAML_TOPLEVEL = $(CURDIR)/..
|
||||
include $(OCAML_TOPLEVEL)/common.make
|
||||
+XEN_CONFIG_DIR=${EGDIR}
|
||||
|
||||
OCAMLINCLUDE += \
|
||||
-I $(OCAML_TOPLEVEL)/libs/xb \
|
13
sysutils/xentools42/patches/patch-pygrub_Makefile
Normal file
13
sysutils/xentools42/patches/patch-pygrub_Makefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-pygrub_Makefile,v 1.1 2013/05/25 05:19:17 jnemeth Exp $
|
||||
|
||||
--- pygrub/Makefile.orig 2013-04-23 16:42:55.000000000 +0000
|
||||
+++ pygrub/Makefile
|
||||
@@ -15,7 +15,7 @@ install: all
|
||||
--install-scripts=$(PRIVATE_BINDIR) --force
|
||||
$(INSTALL_DIR) $(DESTDIR)/var/run/xend/boot
|
||||
set -e; if [ "`readlink -f $(DESTDIR)/$(BINDIR)`" != \
|
||||
- "`readlink -f $(PRIVATE_BINDIR)`" ]; then \
|
||||
+ "`readlink -f $(DESTDIR)/$(PRIVATE_BINDIR)`" ]; then \
|
||||
ln -sf $(PRIVATE_BINDIR)/pygrub $(DESTDIR)/$(BINDIR); \
|
||||
fi
|
||||
|
Loading…
Reference in a new issue