Fix transparent proxying with IPFilter. Patch submitted to squid mailing
list.
This commit is contained in:
parent
6060e4327f
commit
3818900cb6
3 changed files with 44 additions and 8 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.46 2015/05/29 07:50:59 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.47 2015/06/01 16:18:20 sborrill Exp $
|
||||
|
||||
DISTNAME= squid-3.5.5
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.squid-cache.org/Versions/v3/${PKGVERSION_NOREV:R}/ \
|
||||
ftp://ftp.squid-cache.org/pub/squid/ \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.33 2015/05/29 07:50:59 adam Exp $
|
||||
$NetBSD: distinfo,v 1.34 2015/06/01 16:18:20 sborrill Exp $
|
||||
|
||||
SHA1 (squid-3.5.5.tar.xz) = 2c168e8b13251ed8050d9e780127c4de016dcb61
|
||||
RMD160 (squid-3.5.5.tar.xz) = b08a0f3be548873b14353a96d694e7999e0021d1
|
||||
Size (squid-3.5.5.tar.xz) = 2290016 bytes
|
||||
SHA1 (patch-compat_compat.h) = d6cd93fa7a6d0faad3bf1aca8ae4fa5c984fe288
|
||||
SHA1 (patch-configure) = 4e658ac4722695f52412f77e168f31a2f523bb1b
|
||||
SHA1 (patch-configure) = 78ee60a2e9ddc5327c9a055bfedf95f3e8430948
|
||||
SHA1 (patch-errors_Makefile.in) = afbac822ac84d5e1734d55fc625e949ae0b85289
|
||||
SHA1 (patch-src_Makefile.in) = 7233a92a4f6ecc06d88e125f08f7413e0741f3b6
|
||||
SHA1 (patch-src_SquidNew.cc) = eef6e72e168cf7f40518fab13dc2f55ed0268db9
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: patch-configure,v 1.6 2015/05/04 09:13:35 adam Exp $
|
||||
$NetBSD: patch-configure,v 1.7 2015/06/01 16:18:20 sborrill Exp $
|
||||
|
||||
* Portability fix.
|
||||
* Fix broken tests for IPFilter
|
||||
|
||||
--- configure.orig 2015-05-01 11:29:25.000000000 +0000
|
||||
+++ configure
|
||||
@@ -32733,7 +32733,7 @@ done
|
||||
--- configure.orig 2015-05-01 12:29:25.000000000 +0100
|
||||
+++ configure 2015-05-29 11:47:07.000000000 +0100
|
||||
@@ -32733,7 +32733,7 @@
|
||||
## Please see the COPYING and CONTRIBUTORS files for details.
|
||||
##
|
||||
|
||||
|
@ -13,7 +14,7 @@ $NetBSD: patch-configure,v 1.6 2015/05/04 09:13:35 adam Exp $
|
|||
BUILD_HELPER="kerberos"
|
||||
fi
|
||||
|
||||
@@ -33292,7 +33292,7 @@ done
|
||||
@@ -33292,7 +33292,7 @@
|
||||
## Please see the COPYING and CONTRIBUTORS files for details.
|
||||
##
|
||||
|
||||
|
@ -22,3 +23,37 @@ $NetBSD: patch-configure,v 1.6 2015/05/04 09:13:35 adam Exp $
|
|||
BUILD_HELPER="kerberos_ldap_group"
|
||||
if test "x$with_apple_krb5" = "xyes" ; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for main in -lresolv" >&5
|
||||
@@ -38708,7 +38708,7 @@
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: unable to make IPFilter work with netinet/ headers" >&5
|
||||
$as_echo "unable to make IPFilter work with netinet/ headers" >&6; }
|
||||
-
|
||||
+ squid_cv_broken_ipfilter_minor_t=0
|
||||
fi
|
||||
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
|
||||
@@ -38751,6 +38751,9 @@
|
||||
#if HAVE_SYS_IOCCOM_H
|
||||
#include <sys/ioccom.h>
|
||||
#endif
|
||||
+#if HAVE_NET_IF_H
|
||||
+#include <net/if.h>
|
||||
+#endif
|
||||
#if USE_SOLARIS_IPFILTER_MINOR_T_HACK
|
||||
#undef minor_t
|
||||
#endif
|
||||
@@ -41022,6 +41025,14 @@
|
||||
case $ac_option in
|
||||
# Handling of the options.
|
||||
-recheck | --recheck | --rechec | --reche | --rech | --rec | --re | --r)
|
||||
+ : Avoid regenerating within pkgsrc
|
||||
+ exit 0
|
||||
+ : Avoid regenerating within pkgsrc
|
||||
+ exit 0
|
||||
+ : Avoid regenerating within pkgsrc
|
||||
+ exit 0
|
||||
+ : Avoid regenerating within pkgsrc
|
||||
+ exit 0
|
||||
ac_cs_recheck=: ;;
|
||||
--version | --versio | --versi | --vers | --ver | --ve | --v | -V )
|
||||
$as_echo "$ac_cs_version"; exit ;;
|
||||
|
|
Loading…
Reference in a new issue