update to 3.3.10
changes: -fixed bugs which can lead to database corruption under obscure and difficult to reproduce circumstances -new sqlite3_prepare_v2() API -bug fixes in the command-line shell -enhancements to the query optimizer pkgsrc change: fix a selftest which couldn't work as intended due to misuse of O_APPEND
This commit is contained in:
parent
4d0a440d83
commit
382750dbd4
5 changed files with 51 additions and 8 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.5 2006/04/06 06:21:43 reed Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2007/01/11 19:08:48 drochner Exp $
|
||||
|
||||
.include "../../databases/sqlite3/Makefile.common"
|
||||
|
||||
|
@ -14,4 +14,5 @@ BUILDLINK_API_DEPENDS.sqlite3+= sqlite3>=3.2.7
|
|||
|
||||
.include "../../databases/sqlite3/buildlink3.mk"
|
||||
.include "../../lang/tcl/buildlink3.mk"
|
||||
.include "../../devel/readline/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile.common,v 1.9 2006/11/18 23:56:18 wiz Exp $
|
||||
# $NetBSD: Makefile.common,v 1.10 2007/01/11 19:08:48 drochner Exp $
|
||||
|
||||
DISTNAME= sqlite-3.3.8
|
||||
DISTNAME= sqlite-3.3.10
|
||||
PKGNAME= ${DISTNAME:S/-/3-/}
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.hwaci.com/sw/sqlite/ \
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2005/03/23 22:08:06 jmmv Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2007/01/11 19:08:48 drochner Exp $
|
||||
bin/sqlite3
|
||||
include/sqlite3.h
|
||||
include/sqlite3ext.h
|
||||
lib/libsqlite3.la
|
||||
lib/pkgconfig/sqlite3.pc
|
||||
man/man1/sqlite3.1
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.8 2006/11/18 23:56:18 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.9 2007/01/11 19:08:48 drochner Exp $
|
||||
|
||||
SHA1 (sqlite-3.3.8.tar.gz) = 821dc16c8eb4d4625faa4f5fe9b0800c4bbcdc47
|
||||
RMD160 (sqlite-3.3.8.tar.gz) = 9d05a43c3adb5bbdf50713637f31a356f5772807
|
||||
Size (sqlite-3.3.8.tar.gz) = 1921871 bytes
|
||||
SHA1 (sqlite-3.3.10.tar.gz) = b3a18938dba1325f276ce1821deb30afb4add10e
|
||||
RMD160 (sqlite-3.3.10.tar.gz) = c23b01f98dd81c017556889ca77b666bf613a6c6
|
||||
Size (sqlite-3.3.10.tar.gz) = 2015050 bytes
|
||||
SHA1 (patch-aa) = 1362f7b554c91b495371de80170a9d1746e0fcd6
|
||||
SHA1 (patch-ab) = cf0748571cfb2b47a1032ca5f26e3b3cd4cf86da
|
||||
|
|
40
databases/sqlite3/patches/patch-ab
Normal file
40
databases/sqlite3/patches/patch-ab
Normal file
|
@ -0,0 +1,40 @@
|
|||
$NetBSD: patch-ab,v 1.1 2007/01/11 19:08:48 drochner Exp $
|
||||
|
||||
--- test/corrupt2.test.orig 2007-01-11 15:51:25.000000000 +0100
|
||||
+++ test/corrupt2.test
|
||||
@@ -33,7 +33,7 @@ do_test corrupt2-1.2 {
|
||||
file delete -force corrupt.db
|
||||
file delete -force corrupt.db-journal
|
||||
copy_file test.db corrupt.db
|
||||
- set f [open corrupt.db a]
|
||||
+ set f [open corrupt.db r+]
|
||||
seek $f 8 start
|
||||
puts $f blah
|
||||
close $f
|
||||
@@ -51,7 +51,7 @@ do_test corrupt2-1.3 {
|
||||
file delete -force corrupt.db
|
||||
file delete -force corrupt.db-journal
|
||||
copy_file test.db corrupt.db
|
||||
- set f [open corrupt.db a]
|
||||
+ set f [open corrupt.db r+]
|
||||
fconfigure $f -encoding binary
|
||||
seek $f 16 start
|
||||
puts -nonewline $f "\x00\xFF"
|
||||
@@ -70,7 +70,7 @@ do_test corrupt2-1.4 {
|
||||
file delete -force corrupt.db
|
||||
file delete -force corrupt.db-journal
|
||||
copy_file test.db corrupt.db
|
||||
- set f [open corrupt.db a]
|
||||
+ set f [open corrupt.db r+]
|
||||
fconfigure $f -encoding binary
|
||||
seek $f 101 start
|
||||
puts -nonewline $f "\xFF\xFF"
|
||||
@@ -89,7 +89,7 @@ do_test corrupt2-1.5 {
|
||||
file delete -force corrupt.db
|
||||
file delete -force corrupt.db-journal
|
||||
copy_file test.db corrupt.db
|
||||
- set f [open corrupt.db a]
|
||||
+ set f [open corrupt.db r+]
|
||||
fconfigure $f -encoding binary
|
||||
seek $f 101 start
|
||||
puts -nonewline $f "\x00\xC8"
|
Loading…
Reference in a new issue