ncbi-blast+: Upgrade to 2.8.1
Support for new BLAST database format Increased makeblastdb output file size limit to 4GB Other minor bug fixes and enhancements OK wiz@
This commit is contained in:
parent
dcb9592476
commit
385a79042f
6 changed files with 157 additions and 38 deletions
|
@ -1,11 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.5 2018/12/09 18:52:17 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2019/01/07 15:00:10 bacon Exp $
|
||||
|
||||
DISTNAME= ncbi-blast-${PV}+-src
|
||||
PKGNAME= ncbi-blast+-${PV}
|
||||
PKGREVISION= 3
|
||||
DISTNAME= ncbi-blast-2.8.1+-src
|
||||
PKGNAME= ${DISTNAME:S/+-src//:S/blast/blast+/}
|
||||
CATEGORIES= biology
|
||||
MASTER_SITES= https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/LATEST/ \
|
||||
https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/${PV}/
|
||||
https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/${PKGVERSION_NOREV}/
|
||||
|
||||
MAINTAINER= bacon@NetBSD.org
|
||||
HOMEPAGE= http://blast.ncbi.nlm.nih.gov/
|
||||
|
@ -21,10 +20,11 @@ SUBST_SED.configure+= -e '/--infodir=DIR/d'
|
|||
SUBST_SED.configure+= -e '/--mandir=DIR/d'
|
||||
SUBST_FILES.configure+= ${WRKSRC}/src/build-system/configure
|
||||
|
||||
USE_TOOLS+= gmake
|
||||
USE_TOOLS+= bash gmake
|
||||
USE_LANGUAGES= c c++
|
||||
GNU_CONFIGURE= yes
|
||||
# REPLACE_BASH= compilers/xcode30_prj/configure
|
||||
REPLACE_BASH= scripts/common/impl/define_random_macros.sh
|
||||
REPLACE_BASH+= src/app/blast/get_species_taxids.sh
|
||||
REPLACE_PERL= src/app/blast/legacy_blast.pl src/app/blast/update_blastdb.pl
|
||||
REPLACE_PYTHON= src/app/winmasker/windowmasker_2.2.22_adapter.py
|
||||
|
||||
|
@ -34,7 +34,6 @@ REPLACE_PYTHON= src/app/winmasker/windowmasker_2.2.22_adapter.py
|
|||
CONFIGURE_ENV= ncbi_cv_prog_amq_w=no
|
||||
CONFIGURE_ARGS+= AR="ar cr" --without-boost
|
||||
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/ncbi-tools++
|
||||
# MAKE_JOBS_SAFE= no # Intermittent issues
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/c++
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
@ -45,8 +44,6 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/c++
|
|||
CONFIGURE_ENV+= ac_cv_func_statfs=no
|
||||
.endif
|
||||
|
||||
PV= 2.7.1
|
||||
|
||||
post-install:
|
||||
${RM} ${DESTDIR}${PREFIX}/include/ncbi-tools++/*/*/.cvsignore.extra
|
||||
${STRIP} ${DESTDIR}${PREFIX}/lib/ncbi-tools++/*.so
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2018/04/27 20:28:28 bacon Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2019/01/07 15:00:10 bacon Exp $
|
||||
bin/blast_formatter
|
||||
bin/blastdb_aliastool
|
||||
bin/blastdb_convert
|
||||
bin/blastdbcheck
|
||||
bin/blastdbcmd
|
||||
bin/blastdbcp
|
||||
|
@ -13,7 +14,9 @@ bin/deltablast
|
|||
bin/dustmasker
|
||||
bin/gc_cli
|
||||
bin/gene_info_reader
|
||||
bin/get_species_taxids.sh
|
||||
bin/legacy_blast.pl
|
||||
bin/lmdbxx_sample
|
||||
bin/makeblastdb
|
||||
bin/makembindex
|
||||
bin/makeprofiledb
|
||||
|
@ -258,10 +261,12 @@ include/ncbi-tools++/cgi/ref_args.hpp
|
|||
include/ncbi-tools++/cgi/user_agent.hpp
|
||||
include/ncbi-tools++/common/boost_skew_guard.hpp
|
||||
include/ncbi-tools++/common/config/ncbiconf_msvc.h
|
||||
include/ncbi-tools++/common/config/ncbiconf_msvc_site.h.in
|
||||
include/ncbi-tools++/common/config/ncbiconf_universal.h
|
||||
include/ncbi-tools++/common/config/ncbiconf_xcode.h
|
||||
include/ncbi-tools++/common/header_template.hpp
|
||||
include/ncbi-tools++/common/metamodules_doxygen.h
|
||||
include/ncbi-tools++/common/ncbi_build_info.h
|
||||
include/ncbi-tools++/common/ncbi_build_ver.h
|
||||
include/ncbi-tools++/common/ncbi_build_ver.h.in
|
||||
include/ncbi-tools++/common/ncbi_build_ver.h.last
|
||||
|
@ -269,6 +274,7 @@ include/ncbi-tools++/common/ncbi_export.h
|
|||
include/ncbi-tools++/common/ncbi_package_ver.h
|
||||
include/ncbi-tools++/common/ncbi_pch_impl.hpp
|
||||
include/ncbi-tools++/common/ncbi_skew_guard.h
|
||||
include/ncbi-tools++/common/ncbi_source_ver.cmake_nodep
|
||||
include/ncbi-tools++/common/ncbi_source_ver.h
|
||||
include/ncbi-tools++/common/ncbiconf_impl.h
|
||||
include/ncbi-tools++/common/test_assert.h
|
||||
|
@ -313,6 +319,7 @@ include/ncbi-tools++/connect/ncbi_sendmail.h
|
|||
include/ncbi-tools++/connect/ncbi_server_info.h
|
||||
include/ncbi-tools++/connect/ncbi_service.h
|
||||
include/ncbi-tools++/connect/ncbi_service_connector.h
|
||||
include/ncbi-tools++/connect/ncbi_service_cxx.hpp
|
||||
include/ncbi-tools++/connect/ncbi_socket.h
|
||||
include/ncbi-tools++/connect/ncbi_socket.hpp
|
||||
include/ncbi-tools++/connect/ncbi_socket_connector.h
|
||||
|
@ -335,6 +342,7 @@ include/ncbi-tools++/connect/services/grid_globals.hpp
|
|||
include/ncbi-tools++/connect/services/grid_rw_impl.hpp
|
||||
include/ncbi-tools++/connect/services/grid_worker.hpp
|
||||
include/ncbi-tools++/connect/services/grid_worker_app.hpp
|
||||
include/ncbi-tools++/connect/services/impl/netcache_api_int.hpp
|
||||
include/ncbi-tools++/connect/services/impl/neticache_client_int.hpp
|
||||
include/ncbi-tools++/connect/services/impl/netschedule_api_int.hpp
|
||||
include/ncbi-tools++/connect/services/impl/netstorage_impl.hpp
|
||||
|
@ -400,6 +408,7 @@ include/ncbi-tools++/corelib/ncbi_base64.h
|
|||
include/ncbi-tools++/corelib/ncbi_bswap.hpp
|
||||
include/ncbi-tools++/corelib/ncbi_config.hpp
|
||||
include/ncbi-tools++/corelib/ncbi_cookies.hpp
|
||||
include/ncbi-tools++/corelib/ncbi_fast.hpp
|
||||
include/ncbi-tools++/corelib/ncbi_limits.h
|
||||
include/ncbi-tools++/corelib/ncbi_limits.hpp
|
||||
include/ncbi-tools++/corelib/ncbi_mask.hpp
|
||||
|
@ -1200,28 +1209,20 @@ include/ncbi-tools++/objects/genomecoll/GCClient_AssemblyInfo.hpp
|
|||
include/ncbi-tools++/objects/genomecoll/GCClient_AssemblyInfo_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_AssemblySequenceI.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_AssemblySequenceI_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_AttributeFlags.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_AttributeFlags_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_EquivalentAssembl.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_EquivalentAssembl_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_Error.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_Error_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_FindBestAssemblyF.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_FindBestAssemblyF_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_FindBestAssemblyR.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_FindBestAssemblyR_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_FindBestAssemblyS.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_FindBestAssemblyS_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_GetAssemblyBlobRe.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_GetAssemblyBlobRe_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_GetAssemblyBySequ.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_GetAssemblyBySequ_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_GetAssemblyReques.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_GetAssemblyReques_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_GetEquivalentAsse.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_GetEquivalentAsse_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_ValidateChrTypeLo.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_ValidateChrTypeLo_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_ValidateChrTypeLx.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GCClient_ValidateChrTypeLx_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GC_Assemblies.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GC_Assemblies_.hpp
|
||||
include/ncbi-tools++/objects/genomecoll/GC_Assembly.hpp
|
||||
|
@ -2923,6 +2924,7 @@ include/ncbi-tools++/objects/taxon1/Taxon1_resp.hpp
|
|||
include/ncbi-tools++/objects/taxon1/Taxon1_resp_.hpp
|
||||
include/ncbi-tools++/objects/taxon1/Taxon2_data.hpp
|
||||
include/ncbi-tools++/objects/taxon1/Taxon2_data_.hpp
|
||||
include/ncbi-tools++/objects/taxon1/local_taxon.hpp
|
||||
include/ncbi-tools++/objects/taxon1/taxon1.hpp
|
||||
include/ncbi-tools++/objects/taxon1/taxon1__.hpp
|
||||
include/ncbi-tools++/objects/taxon3/.cvsignore
|
||||
|
@ -2991,6 +2993,10 @@ include/ncbi-tools++/objects/trackmgr/TMgr_BlastRIDRequest.hpp
|
|||
include/ncbi-tools++/objects/trackmgr/TMgr_BlastRIDRequest_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_ClientInfo.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_ClientInfo_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateRemoteTrackRepl.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateRemoteTrackRepl_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateRemoteTrackRequ.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateRemoteTrackRequ_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateTracksetReply.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateTracksetReply_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateTracksetRequest.hpp
|
||||
|
@ -3001,6 +3007,8 @@ include/ncbi-tools++/objects/trackmgr/TMgr_CreateUserTrackReply.hpp
|
|||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateUserTrackReply_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateUserTrackReques.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_CreateUserTrackReques_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_DHubId.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_DHubId_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_DTrackId.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_DTrackId_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_DatasetItem.hpp
|
||||
|
@ -3017,6 +3025,10 @@ include/ncbi-tools++/objects/trackmgr/TMgr_DisplayTrackRequest_.hpp
|
|||
include/ncbi-tools++/objects/trackmgr/TMgr_DisplayTrack_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_GenomeContext.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_GenomeContext_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_Hub.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_HubTrack.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_HubTrack_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_Hub_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_Identity.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_IdentityId.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_IdentityIdType.hpp
|
||||
|
@ -3041,6 +3053,8 @@ include/ncbi-tools++/objects/trackmgr/TMgr_RemoveUserTrackReques.hpp
|
|||
include/ncbi-tools++/objects/trackmgr/TMgr_RemoveUserTrackReques_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_RenameMyNCBICollectio.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_RenameMyNCBICollectio_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_RenameMyNCBICollectix.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_RenameMyNCBICollectix_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_Reply.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_Reply_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_Request.hpp
|
||||
|
@ -3057,6 +3071,8 @@ include/ncbi-tools++/objects/trackmgr/TMgr_Status.hpp
|
|||
include/ncbi-tools++/objects/trackmgr/TMgr_Status_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_SupportedAssembliesRe.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_SupportedAssembliesRe_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_SupportedAssembliesRx.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_SupportedAssembliesRx_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_SwitchTrackContextRep.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_SwitchTrackContextRep_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_SwitchTrackContextReq.hpp
|
||||
|
@ -3083,9 +3099,12 @@ include/ncbi-tools++/objects/trackmgr/TMgr_TrackSetType_.hpp
|
|||
include/ncbi-tools++/objects/trackmgr/TMgr_TrackSet_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_TypeStat.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_TypeStat_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_TypeTrackType.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_TypeTrackType_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_ValueRequest.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/TMgr_ValueRequest_.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/blast_client.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/createremotetrack_client.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/createtrackset_client.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/createusertrack_client.hpp
|
||||
include/ncbi-tools++/objects/trackmgr/displaytrack_client.hpp
|
||||
|
@ -3141,6 +3160,30 @@ include/ncbi-tools++/objects/variation/VariationMethod.hpp
|
|||
include/ncbi-tools++/objects/variation/VariationMethod_.hpp
|
||||
include/ncbi-tools++/objects/variation/Variation_.hpp
|
||||
include/ncbi-tools++/objects/variation/variation__.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/.cvsignore
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/.gitignore
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/Error.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/Error_.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/NCBI_search_by_rsid_module.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/Placement.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/Placement_.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/SearchByRsIdReply.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/SearchByRsIdReply_.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/search_by_rsid/search_by_rsid__.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/.cvsignore
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/.gitignore
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipData.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipData_.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipSection.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipSectionValue.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipSectionValue_.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipSection_.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipServiceError.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipServiceError_.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipServiceReply.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/DbsnpTooltipServiceReply_.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/NCBI_dbsnp_tooltips_module.hpp
|
||||
include/ncbi-tools++/objects/variation_libs/dbsnp/tooltip_service/dbsnp_tooltip_service__.hpp
|
||||
include/ncbi-tools++/objects/varrep/.cvsignore
|
||||
include/ncbi-tools++/objects/varrep/.gitignore
|
||||
include/ncbi-tools++/objects/varrep/AaInterval.hpp
|
||||
|
@ -3390,6 +3433,8 @@ include/ncbi-tools++/objtools/blast/gene_info_reader/file_utils.hpp
|
|||
include/ncbi-tools++/objtools/blast/gene_info_reader/gene_info.hpp
|
||||
include/ncbi-tools++/objtools/blast/gene_info_reader/gene_info_reader.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_reader/column_reader.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_reader/impl/lmdb++.h
|
||||
include/ncbi-tools++/objtools/blast/seqdb_reader/impl/seqdb_lmdb.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_reader/impl/seqdbatlas.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_reader/impl/seqdbcol.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_reader/impl/seqdbfile.hpp
|
||||
|
@ -3401,9 +3446,11 @@ include/ncbi-tools++/objtools/blast/seqdb_reader/seqdb.hpp
|
|||
include/ncbi-tools++/objtools/blast/seqdb_reader/seqdbblob.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_reader/seqdbcommon.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_reader/seqdbexpert.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_reader/seqidlist_reader.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/build_db.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/impl/criteria.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/multisource_util.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/seqidlist_writer.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/taxid_set.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/writedb.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/writedb_convert.hpp
|
||||
|
@ -3411,8 +3458,10 @@ include/ncbi-tools++/objtools/blast/seqdb_writer/writedb_error.hpp
|
|||
include/ncbi-tools++/objtools/blast/seqdb_writer/writedb_files.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/writedb_general.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/writedb_isam.hpp
|
||||
include/ncbi-tools++/objtools/blast/seqdb_writer/writedb_lmdb.hpp
|
||||
include/ncbi-tools++/objtools/blast/services/blast_services.hpp
|
||||
include/ncbi-tools++/objtools/cleanup/autogenerated_cleanup.hpp
|
||||
include/ncbi-tools++/objtools/cleanup/capitalization_string.hpp
|
||||
include/ncbi-tools++/objtools/cleanup/cleanup.hpp
|
||||
include/ncbi-tools++/objtools/cleanup/cleanup_change.hpp
|
||||
include/ncbi-tools++/objtools/cleanup/newcleanup.hpp
|
||||
|
@ -3465,6 +3514,7 @@ include/ncbi-tools++/objtools/data_loaders/genbank/seqref.hpp
|
|||
include/ncbi-tools++/objtools/data_loaders/genbank/writer.hpp
|
||||
include/ncbi-tools++/objtools/data_loaders/genbank/writer_interface.hpp
|
||||
include/ncbi-tools++/objtools/data_loaders/loaders.hpp
|
||||
include/ncbi-tools++/objtools/edit/apply_mods.hpp
|
||||
include/ncbi-tools++/objtools/edit/apply_object.hpp
|
||||
include/ncbi-tools++/objtools/edit/autodef.hpp
|
||||
include/ncbi-tools++/objtools/edit/autodef_options.hpp
|
||||
|
@ -3473,8 +3523,11 @@ include/ncbi-tools++/objtools/edit/autodef_with_tax.hpp
|
|||
include/ncbi-tools++/objtools/edit/capitalization_string.hpp
|
||||
include/ncbi-tools++/objtools/edit/cds_fix.hpp
|
||||
include/ncbi-tools++/objtools/edit/dblink_field.hpp
|
||||
include/ncbi-tools++/objtools/edit/edit_error.hpp
|
||||
include/ncbi-tools++/objtools/edit/edit_exception.hpp
|
||||
include/ncbi-tools++/objtools/edit/external_annots.hpp
|
||||
include/ncbi-tools++/objtools/edit/feattable_edit.hpp
|
||||
include/ncbi-tools++/objtools/edit/feature_propagate.hpp
|
||||
include/ncbi-tools++/objtools/edit/field_handler.hpp
|
||||
include/ncbi-tools++/objtools/edit/gap_trim.hpp
|
||||
include/ncbi-tools++/objtools/edit/gaps_edit.hpp
|
||||
|
@ -3494,6 +3547,7 @@ include/ncbi-tools++/objtools/edit/source_edit.hpp
|
|||
include/ncbi-tools++/objtools/edit/string_constraint.hpp
|
||||
include/ncbi-tools++/objtools/edit/struc_comm_field.hpp
|
||||
include/ncbi-tools++/objtools/edit/text_desc_field.hpp
|
||||
include/ncbi-tools++/objtools/edit/text_object_description.hpp
|
||||
include/ncbi-tools++/objtools/error_codes.hpp
|
||||
include/ncbi-tools++/objtools/format/cigar_formatter.hpp
|
||||
include/ncbi-tools++/objtools/format/context.hpp
|
||||
|
@ -3548,6 +3602,8 @@ include/ncbi-tools++/objtools/format/items/wgs_item.hpp
|
|||
include/ncbi-tools++/objtools/format/ostream_text_ostream.hpp
|
||||
include/ncbi-tools++/objtools/format/sam_formatter.hpp
|
||||
include/ncbi-tools++/objtools/format/text_ostream.hpp
|
||||
include/ncbi-tools++/objtools/logging/listener.hpp
|
||||
include/ncbi-tools++/objtools/logging/message.hpp
|
||||
include/ncbi-tools++/objtools/readers/agp_converter.hpp
|
||||
include/ncbi-tools++/objtools/readers/agp_read.hpp
|
||||
include/ncbi-tools++/objtools/readers/agp_seq_entry.hpp
|
||||
|
@ -3705,8 +3761,11 @@ include/ncbi-tools++/util/bitset/bitset_pool.hpp
|
|||
include/ncbi-tools++/util/bitset/bm.h
|
||||
include/ncbi-tools++/util/bitset/bmalgo.h
|
||||
include/ncbi-tools++/util/bitset/bmalgo_impl.h
|
||||
include/ncbi-tools++/util/bitset/bmalgo_similarity.h
|
||||
include/ncbi-tools++/util/bitset/bmalloc.h
|
||||
include/ncbi-tools++/util/bitset/bmavx2.h
|
||||
include/ncbi-tools++/util/bitset/bmblocks.h
|
||||
include/ncbi-tools++/util/bitset/bmbuffer.h
|
||||
include/ncbi-tools++/util/bitset/bmconst.h
|
||||
include/ncbi-tools++/util/bitset/bmdbg.h
|
||||
include/ncbi-tools++/util/bitset/bmdef.h
|
||||
|
@ -3715,12 +3774,16 @@ include/ncbi-tools++/util/bitset/bmfwd.h
|
|||
include/ncbi-tools++/util/bitset/bmgamma.h
|
||||
include/ncbi-tools++/util/bitset/bmrandom.h
|
||||
include/ncbi-tools++/util/bitset/bmserial.h
|
||||
include/ncbi-tools++/util/bitset/bmsimd.h
|
||||
include/ncbi-tools++/util/bitset/bmsparsevec.h
|
||||
include/ncbi-tools++/util/bitset/bmsparsevec_algo.h
|
||||
include/ncbi-tools++/util/bitset/bmsparsevec_compr.h
|
||||
include/ncbi-tools++/util/bitset/bmsparsevec_serial.h
|
||||
include/ncbi-tools++/util/bitset/bmsparsevec_util.h
|
||||
include/ncbi-tools++/util/bitset/bmsse2.h
|
||||
include/ncbi-tools++/util/bitset/bmsse4.h
|
||||
include/ncbi-tools++/util/bitset/bmsse_util.h
|
||||
include/ncbi-tools++/util/bitset/bmtimer.h
|
||||
include/ncbi-tools++/util/bitset/bmtrans.h
|
||||
include/ncbi-tools++/util/bitset/bmundef.h
|
||||
include/ncbi-tools++/util/bitset/bmutil.h
|
||||
|
@ -3733,6 +3796,7 @@ include/ncbi-tools++/util/bitset/ncbi_bitset_util.hpp
|
|||
include/ncbi-tools++/util/bitset/readme
|
||||
include/ncbi-tools++/util/buffer_writer.hpp
|
||||
include/ncbi-tools++/util/bytesrc.hpp
|
||||
include/ncbi-tools++/util/cache/cache_async.hpp
|
||||
include/ncbi-tools++/util/cache/cache_ref.hpp
|
||||
include/ncbi-tools++/util/cache/icache.hpp
|
||||
include/ncbi-tools++/util/cache/icache_cf.hpp
|
||||
|
@ -3774,6 +3838,8 @@ include/ncbi-tools++/util/lightstr.hpp
|
|||
include/ncbi-tools++/util/limited_size_map.hpp
|
||||
include/ncbi-tools++/util/line_reader.hpp
|
||||
include/ncbi-tools++/util/linkedset.hpp
|
||||
include/ncbi-tools++/util/lmdb/lmdb.h
|
||||
include/ncbi-tools++/util/lmdbxx/lmdb++.h
|
||||
include/ncbi-tools++/util/lock_vector.hpp
|
||||
include/ncbi-tools++/util/logrotate.hpp
|
||||
include/ncbi-tools++/util/mask_regexp.hpp
|
||||
|
@ -3783,6 +3849,7 @@ include/ncbi-tools++/util/math/promote.hpp
|
|||
include/ncbi-tools++/util/md5.hpp
|
||||
include/ncbi-tools++/util/miscmath.h
|
||||
include/ncbi-tools++/util/multi_writer.hpp
|
||||
include/ncbi-tools++/util/multipattern_search.hpp
|
||||
include/ncbi-tools++/util/mutex_pool.hpp
|
||||
include/ncbi-tools++/util/ncbi_cache.hpp
|
||||
include/ncbi-tools++/util/ncbi_table.hpp
|
||||
|
@ -3891,6 +3958,8 @@ lib/ncbi-tools++/libdbapi.a
|
|||
lib/ncbi-tools++/libdbapi_driver-dll.so
|
||||
lib/ncbi-tools++/libdbapi_driver-static.a
|
||||
lib/ncbi-tools++/libdbapi_driver.a
|
||||
lib/ncbi-tools++/libdbsnp_tooltip_service-static.a
|
||||
lib/ncbi-tools++/libdbsnp_tooltip_service.a
|
||||
lib/ncbi-tools++/libdocsum-static.a
|
||||
lib/ncbi-tools++/libdocsum.a
|
||||
lib/ncbi-tools++/libentrez2-static.a
|
||||
|
@ -3931,6 +4000,8 @@ lib/ncbi-tools++/libigblast-static.a
|
|||
lib/ncbi-tools++/libigblast.a
|
||||
lib/ncbi-tools++/libinsdseq-static.a
|
||||
lib/ncbi-tools++/libinsdseq.a
|
||||
lib/ncbi-tools++/liblocal_taxon-static.a
|
||||
lib/ncbi-tools++/liblocal_taxon.a
|
||||
lib/ncbi-tools++/libmacro-static.a
|
||||
lib/ncbi-tools++/libmacro.a
|
||||
lib/ncbi-tools++/libmedlars-static.a
|
||||
|
@ -4001,6 +4072,8 @@ lib/ncbi-tools++/libremapcli-static.a
|
|||
lib/ncbi-tools++/libremapcli.a
|
||||
lib/ncbi-tools++/libscoremat-static.a
|
||||
lib/ncbi-tools++/libscoremat.a
|
||||
lib/ncbi-tools++/libsearchbyrsid-static.a
|
||||
lib/ncbi-tools++/libsearchbyrsid.a
|
||||
lib/ncbi-tools++/libseq-static.a
|
||||
lib/ncbi-tools++/libseq.a
|
||||
lib/ncbi-tools++/libseqcode-static.a
|
||||
|
@ -4081,6 +4154,8 @@ lib/ncbi-tools++/libxformat-static.a
|
|||
lib/ncbi-tools++/libxformat.a
|
||||
lib/ncbi-tools++/libxhtml-static.a
|
||||
lib/ncbi-tools++/libxhtml.a
|
||||
lib/ncbi-tools++/libxlogging-static.a
|
||||
lib/ncbi-tools++/libxlogging.a
|
||||
lib/ncbi-tools++/libxncbi-static.a
|
||||
lib/ncbi-tools++/libxncbi.a
|
||||
lib/ncbi-tools++/libxnetblast-static.a
|
||||
|
|
|
@ -1,12 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.2 2018/05/22 21:37:29 bacon Exp $
|
||||
$NetBSD: distinfo,v 1.3 2019/01/07 15:00:10 bacon Exp $
|
||||
|
||||
SHA1 (ncbi-blast-2.7.1+-src.tar.gz) = d04a25f01c386abd8515957a2ce1dabf376743f8
|
||||
RMD160 (ncbi-blast-2.7.1+-src.tar.gz) = 7277419e16fb215aae4136a16e13bec963b70cbd
|
||||
SHA512 (ncbi-blast-2.7.1+-src.tar.gz) = e4b3914f51165ae4c82051068ed9d3470687a4e0f1df6274018c0ba14b241666a570d72265c7d167b8ce2a9075652744244a00e3e95c00c4252da0fbd80d17c6
|
||||
Size (ncbi-blast-2.7.1+-src.tar.gz) = 23254824 bytes
|
||||
SHA1 (ncbi-blast-2.8.1+-src.tar.gz) = 16573b642d7861d0bed67f3eb1174fc646819eec
|
||||
RMD160 (ncbi-blast-2.8.1+-src.tar.gz) = ef8df6c4b3cae18b2ab4509af15554ee8d8f9bfd
|
||||
SHA512 (ncbi-blast-2.8.1+-src.tar.gz) = 3f408c5f76704183578828df3272bab7d59dd6052364e73e1831cd005b87d87dcc086bb1799b316b09e639e4af0edea6404b93a4b3e3c159d27cef34fff93d6f
|
||||
Size (ncbi-blast-2.8.1+-src.tar.gz) = 24973554 bytes
|
||||
SHA1 (patch-compilers_xcode30__prj_configure) = b89b3be8671c6c692ba474476879ee67a76fdbe5
|
||||
SHA1 (patch-src_algo_blast_core_blast__kappa.c) = a580a5fb2d5a3af04c27dd63a7edd349b7ae1be7
|
||||
SHA1 (patch-src_algo_blast_core_blast__kappa.c) = 6fcad996b3a8e5b6c2400608bff9de62ebf6927f
|
||||
SHA1 (patch-src_build-system_Makefile.in.top) = 71d5246867a8c985c1175c338fb0af664094ca01
|
||||
SHA1 (patch-src_build-system_cmake_cmake-cfg-unix.sh) = 90468f3109800e01fc7351926adb331919a12fb2
|
||||
SHA1 (patch-src_build-system_cmake_cmake-configure) = 7b9a10447b1dd665200ee73a2180b3210f586b97
|
||||
SHA1 (patch-src_build-system_configure) = 90becd948f8aca87fd68081e689bdc8c49b419c6
|
||||
SHA1 (patch-src_build-system_helpers_Makefile.run__with__lock.app) = d69b9e349646c970c3b296707f917defbe39cccd
|
||||
SHA1 (patch-src_util_checksum_farmhash_farmhash.h) = c3ff60de9a9020d3b706c2bff37f6f4cde4e6b6b
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-src_algo_blast_core_blast__kappa.c,v 1.1 2018/04/27 20:28:28 bacon Exp $
|
||||
$NetBSD: patch-src_algo_blast_core_blast__kappa.c,v 1.2 2019/01/07 15:00:10 bacon Exp $
|
||||
|
||||
# Work around NetBSD stderr def choking macro
|
||||
|
||||
--- src/algo/blast/core/blast_kappa.c.orig 2018-03-26 21:55:44.000000000 +0000
|
||||
--- src/algo/blast/core/blast_kappa.c.orig 2019-01-02 04:00:17.000000000 +0000
|
||||
+++ src/algo/blast/core/blast_kappa.c
|
||||
@@ -32,6 +32,7 @@
|
||||
* system for each match in blastpgp
|
||||
|
@ -12,7 +12,16 @@ $NetBSD: patch-src_algo_blast_core_blast__kappa.c,v 1.1 2018/04/27 20:28:28 baco
|
|||
#include <float.h>
|
||||
#include <algo/blast/core/ncbi_math.h>
|
||||
#include <algo/blast/core/blast_hits.h>
|
||||
@@ -3404,13 +3405,15 @@ Blast_RedoAlignmentCore_MT(EBlastProgram
|
||||
@@ -57,7 +58,7 @@
|
||||
* shared(...) list. */
|
||||
# define STDERR_COMMA
|
||||
# else
|
||||
-# define STDERR_COMMA stderr,
|
||||
+# define STDERR_COMMA my_stderr,
|
||||
# endif
|
||||
#endif
|
||||
|
||||
@@ -3412,6 +3413,8 @@ Blast_RedoAlignmentCore_MT(EBlastProgram
|
||||
}
|
||||
|
||||
Boolean interrupt = FALSE;
|
||||
|
@ -21,11 +30,3 @@ $NetBSD: patch-src_algo_blast_core_blast__kappa.c,v 1.1 2018/04/27 20:28:28 baco
|
|||
#pragma omp parallel \
|
||||
default(none) num_threads(actual_num_threads) \
|
||||
if(actual_num_threads>1) \
|
||||
shared(interrupt, seqsrc_tld, score_params_tld, hit_params_tld, \
|
||||
gap_align_tld, results_tld, \
|
||||
redoneMatches_tld, \
|
||||
- stderr, \
|
||||
+ my_stderr, \
|
||||
numQueries, numMatches, theseMatches, \
|
||||
numFrames, program_number, subjectBlk_tld, positionBased, \
|
||||
default_db_genetic_code, localScalingFactor, queryInfo, \
|
||||
|
|
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_build-system_cmake_cmake-cfg-unix.sh,v 1.1 2019/01/07 15:00:10 bacon Exp $
|
||||
|
||||
# Portability
|
||||
|
||||
--- src/build-system/cmake/cmake-cfg-unix.sh.orig 2019-01-02 01:22:44.549100012 +0000
|
||||
+++ src/build-system/cmake/cmake-cfg-unix.sh
|
||||
@@ -166,7 +166,7 @@ CMAKE_ARGS="$CMAKE_ARGS -DBUILD_SHARED_L
|
||||
CMAKE_ARGS="$CMAKE_ARGS -DCMAKE_USE_CCACHE=$USE_CCACHE"
|
||||
CMAKE_ARGS="$CMAKE_ARGS -DCMAKE_USE_DISTCC=$USE_DISTCC"
|
||||
build_root=CMake-${CC_NAME}${CC_VERSION}-${BUILD_TYPE}
|
||||
-if [ "$BUILD_SHARED_LIBS" == "ON" ]; then
|
||||
+if [ "$BUILD_SHARED_LIBS" = "ON" ]; then
|
||||
build_root="$build_root"DLL
|
||||
fi
|
||||
#build_root="$build_root"64
|
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-src_util_checksum_farmhash_farmhash.h,v 1.1 2019/01/07 15:00:11 bacon Exp $
|
||||
|
||||
# __GNUC__ does not imply location of endian.h. Check for BSD first.
|
||||
|
||||
--- src/util/checksum/farmhash/farmhash.h.orig 2018-09-26 12:38:06.000000000 +0000
|
||||
+++ src/util/checksum/farmhash/farmhash.h
|
||||
@@ -305,15 +305,18 @@ inline uint128_t Fingerprint128(const St
|
||||
#if !defined(FARMHASH_BIG_ENDIAN)
|
||||
#define FARMHASH_BIG_ENDIAN
|
||||
#endif
|
||||
-#elif defined(__linux__) || defined(__CYGWIN__) || defined( __GNUC__ ) || defined( __GNU_LIBRARY__ )
|
||||
- #include <endian.h> // libc6-dev, GLIBC
|
||||
+#elif defined(__OpenBSD__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__) || defined(__s390x__)
|
||||
+ #include <sys/endian.h>
|
||||
#if BYTE_ORDER == BIG_ENDIAN
|
||||
#if !defined(FARMHASH_BIG_ENDIAN)
|
||||
#define FARMHASH_BIG_ENDIAN
|
||||
#endif
|
||||
#endif
|
||||
-#elif defined(__OpenBSD__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__) || defined(__s390x__)
|
||||
- #include <sys/endian.h>
|
||||
+// __GNUC__ actually does not imply the location of endian.h. It could
|
||||
+// be set on any system running GCC. I'm wondering why this was added
|
||||
+// Working around breakage for BSD systems by checking for BSD first.
|
||||
+#elif defined(__linux__) || defined(__CYGWIN__) || defined( __GNUC__ ) || defined( __GNU_LIBRARY__ )
|
||||
+ #include <endian.h> // libc6-dev, GLIBC
|
||||
#if BYTE_ORDER == BIG_ENDIAN
|
||||
#if !defined(FARMHASH_BIG_ENDIAN)
|
||||
#define FARMHASH_BIG_ENDIAN
|
Loading…
Reference in a new issue